summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-24 17:07:24 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-24 17:07:24 +0000
commita2603b66e386de2ebc2f52cd03bbe6d10fb0d013 (patch)
treec30fe98a092368b07654618754683db19ab46145 /games-kids
parentstable x86, bug 185745 (diff)
downloadgentoo-2-a2603b66e386de2ebc2f52cd03bbe6d10fb0d013.tar.gz
gentoo-2-a2603b66e386de2ebc2f52cd03bbe6d10fb0d013.tar.bz2
gentoo-2-a2603b66e386de2ebc2f52cd03bbe6d10fb0d013.zip
Version bump
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog7
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.23
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-4.2.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index a0b70a35e15f..b7c3da7481bf 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/tuxmathscrabble
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.10 2007/07/22 01:33:35 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.11 2007/07/24 17:07:24 nyhm Exp $
+
+*tuxmathscrabble-4.2 (24 Jul 2007)
+
+ 24 Jul 2007; Tristan Heaven <nyhm@gentoo.org> +tuxmathscrabble-4.2.ebuild:
+ Version bump
*tuxmathscrabble-4.0 (22 Jul 2007)
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.2 b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.2
new file mode 100644
index 000000000000..f92e10763d9a
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.2
@@ -0,0 +1,3 @@
+MD5 d6aa0d3a4ad6f53a0ca44c01bbef9a32 TuxMathScrabble-0.4.2LIN.tgz 5491506
+RMD160 df96aa113a8a5a22d01010abb3e07272973893d9 TuxMathScrabble-0.4.2LIN.tgz 5491506
+SHA256 7987cd42dd2ca9818532ed6307b720a4052defaf4b89e865e3f10067ffdd91cb TuxMathScrabble-0.4.2LIN.tgz 5491506
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-4.2.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-4.2.ebuild
new file mode 100644
index 000000000000..2975af53a0d0
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-4.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-4.2.ebuild,v 1.1 2007/07/24 17:07:24 nyhm Exp $
+
+inherit eutils python multilib games
+
+MY_PN=TuxMathScrabble
+MY_P=${MY_PN}-0.${PV}LIN
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="http://www.asymptopia.org/software/${MY_P}.tgz
+ mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ dev-python/wxpython"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f $(find . -name '*.pyc')
+ mv -f ${MY_PN}/accounts .
+ sed -i "s:'/','var','games':'${GAMES_STATEDIR}':" \
+ asymptopia_0_1_0/environment.py \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin ${MY_PN}.py ${PN} || die "newgamesbin failed"
+
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins -r ${MY_PN} || die "doins ${MY_PN} failed"
+ doins -r asymptopia_0_1_0 || die "doins asymptopia_0_1_0 failed"
+
+ insinto "${GAMES_STATEDIR}"/${MY_PN}
+ doins -r accounts || die "doins accounts failed"
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${MY_PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+ prepgamesdirs
+ fperms -R g+w "${GAMES_STATEDIR}"/${MY_PN}
+}