summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-26 20:49:32 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-26 20:49:32 +0000
commit319bc6621b562b13ad92aab1dcb7105261bd6108 (patch)
tree6be829c9130c8576e7efc047cea54ad74572d9a9 /games-kids
parentActually, upon checking I now see that in the 9999 branch the configure flag ... (diff)
downloadgentoo-2-319bc6621b562b13ad92aab1dcb7105261bd6108.tar.gz
gentoo-2-319bc6621b562b13ad92aab1dcb7105261bd6108.tar.bz2
gentoo-2-319bc6621b562b13ad92aab1dcb7105261bd6108.zip
migrate to python-single-r1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog7
-rw-r--r--games-kids/gcompris/gcompris-12.11-r1.ebuild98
2 files changed, 104 insertions, 1 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index d71f4e7dae40..2db5908da3db 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/gcompris
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.94 2013/10/26 20:04:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.95 2013/10/26 20:49:32 hasufell Exp $
+
+*gcompris-12.11-r1 (26 Oct 2013)
+
+ 26 Oct 2013; Julian Ospald <hasufell@gentoo.org> +gcompris-12.11-r1.ebuild:
+ migrate to python-single-r1
26 Oct 2013; Julian Ospald <hasufell@gentoo.org> gcompris-12.11.ebuild,
+files/gcompris-12.11-underlinking.patch:
diff --git a/games-kids/gcompris/gcompris-12.11-r1.ebuild b/games-kids/gcompris/gcompris-12.11-r1.ebuild
new file mode 100644
index 000000000000..a51d1a0ba0e1
--- /dev/null
+++ b/games-kids/gcompris/gcompris-12.11-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-12.11-r1.ebuild,v 1.1 2013/10/26 20:49:32 hasufell Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit autotools eutils python-single-r1 games
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net/"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gstreamer"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/librsvg[gtk]
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-alsa:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )
+ !gstreamer? (
+ media-libs/sdl-mixer
+ media-libs/libsdl:0 )
+ dev-libs/libxml2
+ dev-libs/popt
+ virtual/libintl
+ games-board/gnuchess
+ dev-db/sqlite:3
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ dev-perl/XML-Parser
+ sys-devel/gettext
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-gfx/tuxpaint
+ sci-electronics/gnucap"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ # Drop DEPRECATED flags, bug #387817
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ src/gcompris/Makefile.am src/gcompris/Makefile.in \
+ src/goocanvas/src/Makefile.am src/goocanvas/src/Makefile.in \
+ || die
+
+ epatch "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+ cp /usr/share/gettext/config.rpath .
+ eautoreconf
+ sed -i \
+ -e 's#^itlocaledir =.*$#itlocaledir = @localedir@#' \
+ po/Makefile.in.in || die
+
+ # Fix desktop files
+ sed -i \
+ -e '/Encoding/d' \
+ gcompris.desktop.in \
+ gcompris-edit.desktop.in || die
+}
+
+src_configure() {
+ GNUCHESS="${GAMES_BINDIR}"/gnuchess \
+ egamesconf \
+ --datarootdir="${GAMES_DATADIR}" \
+ --datadir="${GAMES_DATADIR}" \
+ --localedir=/usr/share/locale \
+ --infodir=/usr/share/info \
+ --with-python="${PYTHON}" \
+ $(use_enable !gstreamer sdlmixer) \
+ --enable-sqlite \
+ --enable-py-build-only
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --modules
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}