summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-26 00:45:56 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-26 00:45:56 +0000
commitbec1aef45728e0a89fccfa23e30bff90fb218656 (patch)
tree99d4ed5b42b0ab8d2f34b8e9a0007766fa6d597e /games-fps
parentStable on x86 wrt bug #132213 (diff)
downloadgentoo-2-bec1aef45728e0a89fccfa23e30bff90fb218656.tar.gz
gentoo-2-bec1aef45728e0a89fccfa23e30bff90fb218656.tar.bz2
gentoo-2-bec1aef45728e0a89fccfa23e30bff90fb218656.zip
add warning to install data files
(Portage version: 2.1_rc2-r1)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake1/quake1-2.40-r1.ebuild21
1 files changed, 20 insertions, 1 deletions
diff --git a/games-fps/quake1/quake1-2.40-r1.ebuild b/games-fps/quake1/quake1-2.40-r1.ebuild
index 8b698dfbfbae..615704ecf706 100644
--- a/games-fps/quake1/quake1-2.40-r1.ebuild
+++ b/games-fps/quake1/quake1-2.40-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40-r1.ebuild,v 1.5 2006/03/15 22:23:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40-r1.ebuild,v 1.6 2006/05/26 00:45:56 vapier Exp $
inherit eutils games
@@ -84,3 +84,22 @@ src_install() {
dodoc readme.txt {WinQuake,QW}/*.txt
prepgamesdirs
}
+
+pkg_postinst() {
+ # same warning used in quake1 / quakeforge / nprquake-sdl
+ games_pkg_postinst
+ echo
+ einfo "Before you can play, you must make sure"
+ einfo "QuakeForge can find your Quake .pak files"
+ echo
+ einfo "You have 2 choices to do this"
+ einfo "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake1/id1"
+ einfo "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake1/id1"
+ echo
+ einfo "Example:"
+ einfo "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
+ einfo "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake1/id1/pak0.pak"
+ echo
+ einfo "You only need pak0.pak to play the demo version,"
+ einfo "the others are needed for registered version"
+}