summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-09-16 21:52:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-09-16 21:52:12 +0000
commit7a2ef30705e6785f2a2047b6917dae1e6c910588 (patch)
tree37a81333c86783c43b637a947cad0a3ab3604a38 /games-fps/xonotic
parentRename OF/ON defines in exported header to avoid collisions with other packag... (diff)
downloadgentoo-2-7a2ef30705e6785f2a2047b6917dae1e6c910588.tar.gz
gentoo-2-7a2ef30705e6785f2a2047b6917dae1e6c910588.tar.bz2
gentoo-2-7a2ef30705e6785f2a2047b6917dae1e6c910588.zip
Initial commit - ebuild based on the one submitted by Nikoli (bug #324159)
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/ChangeLog10
-rw-r--r--games-fps/xonotic/metadata.xml5
-rw-r--r--games-fps/xonotic/xonotic-0.5.0.ebuild104
3 files changed, 119 insertions, 0 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
new file mode 100644
index 000000000000..36275e4414ad
--- /dev/null
+++ b/games-fps/xonotic/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/xonotic
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.1 2011/09/16 21:52:12 mr_bones_ Exp $
+
+*xonotic-0.5.0 (16 Sep 2011)
+
+ 16 Sep 2011; Michael Sterrett <mr_bones_@gentoo.org> +xonotic-0.5.0.ebuild,
+ +metadata.xml:
+ Initial commit - ebuild based on the one submitted by Nikoli (bug #324159)
+
diff --git a/games-fps/xonotic/metadata.xml b/games-fps/xonotic/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/xonotic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/xonotic/xonotic-0.5.0.ebuild b/games-fps/xonotic/xonotic-0.5.0.ebuild
new file mode 100644
index 000000000000..721b16e465e4
--- /dev/null
+++ b/games-fps/xonotic/xonotic-0.5.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.5.0.ebuild,v 1.1 2011/09/16 21:52:12 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils check-reqs games
+
+MY_PN="${PN^}"
+DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
+HOMEPAGE="http://www.xonotic.org/"
+SRC_URI="http://dl.xonotic.org/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dedicated doc sdl"
+
+UIRDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/libmodplug
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ virtual/opengl
+ media-libs/freetype:2
+ alsa? ( media-libs/alsa-lib )
+ sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )"
+UIDEPEND="
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg
+ media-libs/libpng
+ net-misc/curl
+ ~dev-libs/d0_blind_id-0.3
+ !dedicated? ( ${UIRDEPEND} )"
+DEPEND="${RDEPEND}
+ !dedicated? ( ${UIDEPEND} )"
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ CHECKREQS_DISK_BUILD="1200M"
+ CHECKREQS_DISK_USR="950M"
+ check-reqs_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -rf misc/buildfiles/ # use system libs
+
+ sed -i \
+ -e "/^EXE_/s:darkplaces:${PN}:" \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/-lm/s:$: ${LDFLAGS}:" \
+ -e '/^STRIP/s/strip/true/' \
+ source/darkplaces/makefile.inc || die
+
+ if ! use alsa; then
+ sed -i \
+ -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
+ source/darkplaces/makefile || die
+ fi
+}
+
+src_compile() {
+ local t="$(use debug && echo debug || echo release)"
+
+ emake \
+ -C source/darkplaces \
+ DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ sv-${t} \
+ $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})") \
+ || die
+}
+
+src_install() {
+ if ! use dedicated; then
+ dogamesbin source/darkplaces/${PN}-glx || die
+ newicon misc/logos/${PN}_icon.svg ${PN}.svg
+ make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
+
+ if use sdl; then
+ dogamesbin source/darkplaces/${PN}-sdl || die
+ make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
+ fi
+ fi
+ dogamesbin source/darkplaces/${PN}-dedicated || die
+
+ dodoc Docs/*.txt
+ use doc && dohtml -r Docs
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r key_0.d0pk server data || die
+ prepgamesdirs
+}