summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-10-26 14:21:54 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-10-26 14:21:54 +0000
commit6e53278f856055a6252ec467c9c4b375d7e128f4 (patch)
treeca2436193636d11f63a0801ce3d58d6ddac4323b /games-fps/ut2003
parentInitial import. Ebuild by me. (diff)
downloadgentoo-2-6e53278f856055a6252ec467c9c4b375d7e128f4.tar.gz
gentoo-2-6e53278f856055a6252ec467c9c4b375d7e128f4.tar.bz2
gentoo-2-6e53278f856055a6252ec467c9c4b375d7e128f4.zip
Updated with split data and patch ebuilds and adding initial amd64 support.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-fps/ut2003')
-rw-r--r--games-fps/ut2003/ChangeLog8
-rw-r--r--games-fps/ut2003/files/digest-ut2003-2225-r41
-rw-r--r--games-fps/ut2003/ut2003-2225-r4.ebuild99
3 files changed, 107 insertions, 1 deletions
diff --git a/games-fps/ut2003/ChangeLog b/games-fps/ut2003/ChangeLog
index d113b487918a..77ef719723dd 100644
--- a/games-fps/ut2003/ChangeLog
+++ b/games-fps/ut2003/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/ut2003
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.32 2005/10/21 17:47:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.33 2005/10/26 14:21:54 wolf31o2 Exp $
+
+*ut2003-2225-r4 (26 Oct 2005)
+
+ 26 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +ut2003-2225-r4.ebuild:
+ Updated with split data and patch ebuilds and adding initial amd64 support.
21 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org> ut2003-2225-r3.ebuild:
Added addition dir variable to games_make_wrapper for bug #109793.
diff --git a/games-fps/ut2003/files/digest-ut2003-2225-r4 b/games-fps/ut2003/files/digest-ut2003-2225-r4
new file mode 100644
index 000000000000..24409cf3d475
--- /dev/null
+++ b/games-fps/ut2003/files/digest-ut2003-2225-r4
@@ -0,0 +1 @@
+MD5 3d991e6b097025e0908ee0c1569a5a3b ut2003lnx_patch2225.tar.tar 10039316
diff --git a/games-fps/ut2003/ut2003-2225-r4.ebuild b/games-fps/ut2003/ut2003-2225-r4.ebuild
new file mode 100644
index 000000000000..237d4cc1cd13
--- /dev/null
+++ b/games-fps/ut2003/ut2003-2225-r4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225-r4.ebuild,v 1.1 2005/10/26 14:21:54 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Unreal Tournament 2003 - Sequel to the 1999 Game of the Year multi-player first-person shooter"
+HOMEPAGE="http://www.unrealtournament2003.com/"
+SRC_URI="ftp://ftp.infogrames.net/misc/ut2003/ut2003lnx_patch2225.tar.tar"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall dedicated"
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc"
+RDEPEND="dedicated? ( games-server/ut2003-ded )
+ !dedicated? ( virtual/opengl )
+ cdinstall? ( games-fps/ut2003-data )
+ amd64? ( app-emulation/emul-linux-x86-compat
+ app-emulation/emul-linux-x86-xlibs )"
+
+S="${WORKDIR}"
+
+GAMES_LICENSE_CHECK="yes"
+dir="${GAMES_PREFIX_OPT}/${PN}"
+Ddir="${D}/${dir}"
+
+src_unpack() {
+ unpack ut2003lnx_patch${PV}.tar.tar \
+ || die "unpacking patch"
+}
+
+src_install() {
+ insinto ${dir}
+
+ games_make_wrapper ut2003 ./ut2003 "${dir}" "${dir}"
+
+ # this brings our install up to the newest version
+ cp -r ${S}/ut2003-lnx-2225/* ${Ddir} || die
+
+ prepgamesdirs
+ make_desktop_entry ut2003 "Unreal Tournament 2003" UT2003.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # here is where we check for the existence of a cdkey...
+ # if we don't find one, we ask the user for it
+ if [ -f ${dir}/System/cdkey ]; then
+ einfo "A cdkey file is already present in ${dir}/System"
+ else
+ ewarn "You MUST run this before playing the game:"
+ ewarn "emerge --config =${CATEGORY}/${PF}"
+ ewarn "That way you can [re]enter your cdkey."
+ fi
+ echo
+ einfo "To play the game run:"
+ einfo " ut2003"
+ echo
+ ewarn "If you are not installing for the first time and you plan on running"
+ ewarn "a server, you will probably need to edit your"
+ ewarn "~/.ut2003/System/UT2003.ini file and add a line that says"
+ ewarn "AccessControlClass=crashfix.iaccesscontrolini to your"
+ ewarn "[Engine.GameInfo] section to close a security issue."
+}
+
+pkg_postrm() {
+ ewarn "This package leaves a cdkey file in ${dir}/System that you need"
+ ewarn "to remove to completely get rid of this game's files."
+}
+
+pkg_config() {
+ ewarn "Your CD key is NOT checked for validity here."
+ ewarn " Make sure you type it in correctly."
+ eerror "If you CTRL+C out of this, the game will not run!"
+ echo
+ einfo "CD key format is: XXXX-XXXX-XXXX-XXXX"
+ while true ; do
+ einfo "Please enter your CD key:"
+ read CDKEY1
+ einfo "Please re-enter your CD key:"
+ read CDKEY2
+ if [ "$CDKEY1" == "" ] ; then
+ echo "You entered a blank CD key. Try again."
+ else
+ if [ "$CDKEY1" == "$CDKEY2" ] ; then
+ echo "$CDKEY1" | tr a-z A-Z > ${dir}/System/cdkey
+ einfo "Thank you!"
+ chown games:games ${dir}/System/cdkey
+ break
+ else
+ eerror "Your CD key entries do not match. Try again."
+ fi
+ fi
+ done
+}