summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-11 12:01:03 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-11 12:01:03 +0000
commit3cc8cf0d082825233458bfe4c7970b289f498d9a (patch)
tree1a36239167689de975085826b355e6a6fb373746 /games-fps/quake3
parentStable on ppc. Bug 125495 (diff)
downloadgentoo-2-3cc8cf0d082825233458bfe4c7970b289f498d9a.tar.gz
gentoo-2-3cc8cf0d082825233458bfe4c7970b289f498d9a.tar.bz2
gentoo-2-3cc8cf0d082825233458bfe4c7970b289f498d9a.zip
Update snapshot.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog8
-rw-r--r--games-fps/quake3/files/digest-quake3-1.34_alpha6323
-rw-r--r--games-fps/quake3/quake3-1.34_alpha632.ebuild115
3 files changed, 125 insertions, 1 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 3395f60f6d0f..71b055a40096 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.30 2006/01/22 02:53:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.31 2006/03/11 12:01:03 vapier Exp $
+
+*quake3-1.34_alpha632 (11 Mar 2006)
+
+ 11 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +quake3-1.34_alpha632.ebuild:
+ Update snapshot.
22 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org>
quake3-1.33_alpha510.ebuild:
diff --git a/games-fps/quake3/files/digest-quake3-1.34_alpha632 b/games-fps/quake3/files/digest-quake3-1.34_alpha632
new file mode 100644
index 000000000000..e4336220f06e
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.34_alpha632
@@ -0,0 +1,3 @@
+MD5 95abc17191edad2ef0cabff130f8595c quake3-1.34_SVN632M.tar.bz2 2376187
+RMD160 c71685eacb046fea63fc75ace8b8b345c1c9250a quake3-1.34_SVN632M.tar.bz2 2376187
+SHA256 2ea0b694472120c3d64f3c0f1cfd0f9a9c35da416c0379b35234815a38d6ebfc quake3-1.34_SVN632M.tar.bz2 2376187
diff --git a/games-fps/quake3/quake3-1.34_alpha632.ebuild b/games-fps/quake3/quake3-1.34_alpha632.ebuild
new file mode 100644
index 000000000000..049fe975109f
--- /dev/null
+++ b/games-fps/quake3/quake3-1.34_alpha632.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha632.ebuild,v 1.1 2006/03/11 12:01:03 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion games toolchain-funcs
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit games toolchain-funcs
+
+ MY_PV=${PV/_alpha*/}
+ SNAP=${PV/*_alpha/}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit games toolchain-funcs
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? (
+ virtual/opengl
+ media-libs/openal
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ games-fps/quake3-data"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ if use opengl ; then
+ doicon quake3.xpm
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+ fi
+
+ cd ../../build/release*
+ local old_x x
+ for old_x in ioq* ; do
+ x=${old_x%.*}
+ newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
+ dosym ${x} "${GAMES_BINDIR}"/${x/io}
+ done
+ exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}