summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-03-14 02:16:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-03-14 02:16:29 +0000
commitb5ed6b295dbedaa376efefad1fd6c47b0a717a16 (patch)
tree6eb1460228c34ef5e13d128121c5b6eae866a26f /games-fps/quake1/quake1-2.40-r1.ebuild
parentVersion bump: 1.0.3 (bug #158131) (diff)
downloadgentoo-2-b5ed6b295dbedaa376efefad1fd6c47b0a717a16.tar.gz
gentoo-2-b5ed6b295dbedaa376efefad1fd6c47b0a717a16.tar.bz2
gentoo-2-b5ed6b295dbedaa376efefad1fd6c47b0a717a16.zip
remove games-fps/quake1 masked since (17 Jun 2006)
Diffstat (limited to 'games-fps/quake1/quake1-2.40-r1.ebuild')
-rw-r--r--games-fps/quake1/quake1-2.40-r1.ebuild102
1 files changed, 0 insertions, 102 deletions
diff --git a/games-fps/quake1/quake1-2.40-r1.ebuild b/games-fps/quake1/quake1-2.40-r1.ebuild
deleted file mode 100644
index ea9a95f13121..000000000000
--- a/games-fps/quake1/quake1-2.40-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40-r1.ebuild,v 1.9 2007/03/12 14:46:02 genone Exp $
-
-inherit eutils games
-
-DESCRIPTION="The original Quake engine straight from id !"
-HOMEPAGE="http://www.idsoftware.com/games/quake/quake/"
-SRC_URI="mirror://idsoftware/source/q1source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-*"
-IUSE="cdinstall X opengl svga 3dfx"
-
-RDEPEND="X? ( x11-libs/libX11 )
- opengl? ( virtual/opengl )
- svga? ( media-libs/svgalib )
- 3dfx? ( media-libs/glide-v3 )"
-DEPEND="${RDEPEND}
- cdinstall? ( games-fps/quake1-data )
- app-arch/unzip"
-
-S=${WORKDIR}
-
-pkg_setup() {
- games_pkg_setup
- echo
- ewarn "You probably want games-fps/quakeforge if you're"
- ewarn "looking for a quake1 client ..."
- ebeep
- epause
-}
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}"/fix-sys_printf.patch
-
- mv WinQuake/Makefile{.linuxi386,}
- mv QW/Makefile{.Linux,}
-
- epatch "${FILESDIR}"/makefile-path-fixes.patch
- epatch "${FILESDIR}"/gentoo-paths.patch
- sed -i -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/quake1:" \
- {QW/client,WinQuake}/common.c || die "setting data paths"
-
- epatch "${FILESDIR}"/makefile-cflags.patch
- sed -i "s:GENTOO_CFLAGS:${CFLAGS} -DGL_EXT_SHARED=1:" {WinQuake,QW}/Makefile
-
- cp QW/client/glquake.h{,.orig}
- (echo "#define APIENTRY";cat QW/client/glquake.h.orig) > QW/client/glquake.h
-
- epatch "${FILESDIR}"/makefile-sedable.patch
- if ! use 3dfx ; then
- sed -i 's:^ $(BUILDDIR)/bin/glquake ::' WinQuake/Makefile
- sed -i 's:^ $(BUILDDIR)/bin/glquake.3dfxgl ::' WinQuake/Makefile
- sed -i 's:^ $(BUILDDIR)/glqwcl ::' QW/Makefile
- fi
- if ! use X ; then
- sed -i 's:^ $(BUILDDIR)/bin/quake.x11 ::' WinQuake/Makefile
- sed -i 's:^ $(BUILDDIR)/qwcl.x11 ::' QW/Makefile
- fi
- if ! use opengl ; then
- sed -i 's:^ $(BUILDDIR)/bin/quake.glx ::' WinQuake/Makefile
- sed -i 's:^ $(BUILDDIR)/glqwcl.glx ::' QW/Makefile
- fi
- if ! use svga ; then
- sed -i 's:^ $(BUILDDIR)/bin/squake ::' WinQuake/Makefile
- sed -i 's:^ $(BUILDDIR)/qwcl ::' QW/Makefile
- fi
-}
-
-src_compile() {
- emake -j1 -C "${S}"/WinQuake build_release || die "failed to build WinQuake"
- emake -j1 -C "${S}"/QW build_release || die "failed to build QW"
-}
-
-src_install() {
- dogamesbin WinQuake/release*/bin/* QW/release*/*qw* || die "dogamesbin failed"
- dodoc readme.txt {WinQuake,QW}/*.txt
- prepgamesdirs
-}
-
-pkg_postinst() {
- # same warning used in quake1 / quakeforge / nprquake-sdl
- games_pkg_postinst
- echo
- elog "Before you can play, you must make sure"
- elog "${PN} can find your Quake .pak files"
- elog
- elog "You have 2 choices to do this"
- elog "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake1/id1"
- elog "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake1/id1"
- elog
- elog "Example:"
- elog "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
- elog "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake1/id1/pak0.pak"
- elog
- elog "You only need pak0.pak to play the demo version,"
- elog "the others are needed for registered version"
-}