summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-03 21:32:08 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-03 21:32:08 +0000
commitaa125e24b0bd9ca01b746756f184d33719c85377 (patch)
treea899cf2ea0f79df3dca17522b56afdd7489db50e /games-fps/doom3
parentFix bugs 515504, 515502 (diff)
downloadgentoo-2-aa125e24b0bd9ca01b746756f184d33719c85377.tar.gz
gentoo-2-aa125e24b0bd9ca01b746756f184d33719c85377.tar.bz2
gentoo-2-aa125e24b0bd9ca01b746756f184d33719c85377.zip
bumped EAPI to 5, adjusted deps for gx86-mulitlib, dropped bundled glibc libs, dropped hardware-accellerated x11-driver deps for amd64. Could not confirm everything is as it should be because I don't have access to the missing PAK files.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'games-fps/doom3')
-rw-r--r--games-fps/doom3/ChangeLog13
-rw-r--r--games-fps/doom3/doom3-1.3.1304-r1.ebuild107
2 files changed, 118 insertions, 2 deletions
diff --git a/games-fps/doom3/ChangeLog b/games-fps/doom3/ChangeLog
index 81247e3c337f..f84747f73e94 100644
--- a/games-fps/doom3/ChangeLog
+++ b/games-fps/doom3/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-fps/doom3
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/ChangeLog,v 1.39 2012/02/05 06:02:13 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/ChangeLog,v 1.40 2014/07/03 21:32:08 axs Exp $
+
+*doom3-1.3.1304-r1 (03 Jul 2014)
+
+ 03 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +doom3-1.3.1304-r1.ebuild:
+ bumped EAPI to 5, adjusted deps for gx86-mulitlib, dropped bundled glibc libs,
+ dropped hardware-accellerated x11-driver deps for amd64. Could not confirm
+ everything is as it should be because I don't have access to the missing PAK
+ files.
05 Feb 2012; Mike Frysinger <vapier@gentoo.org> doom3-1.3.1304.ebuild:
Move to new unpacker eclass for unpack_makeself.
diff --git a/games-fps/doom3/doom3-1.3.1304-r1.ebuild b/games-fps/doom3/doom3-1.3.1304-r1.ebuild
new file mode 100644
index 000000000000..ca14041e19ac
--- /dev/null
+++ b/games-fps/doom3/doom3-1.3.1304-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.3.1304-r1.ebuild,v 1.1 2014/07/03 21:32:08 axs Exp $
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PV="1.3.1.1304"
+
+DESCRIPTION="3rd installment of the classic iD 3D first-person shooter"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI="mirror://idsoftware/doom3/linux/doom3-linux-${MY_PV}.x86.run
+ http://zerowing.idsoftware.com/linux/${PN}.png"
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cdinstall dedicated opengl roe"
+RESTRICT="strip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ || (
+ (
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ )
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ opengl? ( || (
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ ) )
+ alsa? ( || (
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ ) )
+ cdinstall? (
+ >=games-fps/doom3-data-1.1.1282-r1
+ roe? ( games-fps/doom3-roe ) )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_TEXTRELS="${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbsv.so
+ ${dir:1}/pb/pbags.so"
+
+QA_EXECSTACK="${dir:1}/doom.x86
+ ${dir:1}/doomded.x86"
+
+src_unpack() {
+ unpack_makeself ${PN}-linux-${MY_PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ doins License.txt CHANGES README version.info ${PN}.png || die
+
+ exeinto "${dir}"
+ # skip these, they are on the system -- doexe *.so.? || die "doexe libs"
+ doexe openurl.sh || die "openurl.sh"
+
+ if use amd64 ; then
+ doexe bin/Linux/amd64/doom{,ded}.x86 || die "doexe amd64"
+ else
+ doexe bin/Linux/x86/doom{,ded}.x86 || die "doexe x86"
+ fi
+
+ doins -r base d3xp pb || die "doins base d3xp pb"
+
+ games_make_wrapper ${PN} ./doom.x86 "${dir}" "${dir}"
+ if use dedicated ; then
+ games_make_wrapper ${PN}-ded ./doomded.x86 "${dir}" "${dir}"
+ fi
+
+ doicon "${DISTDIR}"/${PN}.png || die "doicon"
+ make_desktop_entry ${PN} "Doom III"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ elog "You need to copy pak000.pk4, pak001.pk4, pak002.pk4, pak003.pk4, and"
+ elog "pak004.pk4 from either your installation media or your hard drive to"
+ elog "${dir}/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
+ echo
+ if use roe ; then
+ elog "To use the Resurrection of Evil expansion pack, you also need to copy"
+ elog "pak000.pk4 to ${dir}/d3xp from the RoE CD before running the game,"
+ elog "or 'emerge doom3-roe' to install from CD."
+ fi
+ fi
+
+ echo
+ elog "To play the game, run:"
+ elog " doom3"
+ echo
+}