summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-09-14 22:40:36 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-09-14 22:40:36 +0000
commit8ecd5509a5eff0e5ec566a77d15bb5456795fff2 (patch)
tree084ac00c9b65f7e56828aa18552427472e127542 /games-fps/americas-army
parentsandbox fix (Manifest recommit) (diff)
downloadgentoo-2-8ecd5509a5eff0e5ec566a77d15bb5456795fff2.tar.gz
gentoo-2-8ecd5509a5eff0e5ec566a77d15bb5456795fff2.tar.bz2
gentoo-2-8ecd5509a5eff0e5ec566a77d15bb5456795fff2.zip
Removed old versions and added dedicated server init scripts by Bjorn Michaelsen <bmichaelsen@gmx.de>. Closing bug #58581.
Diffstat (limited to 'games-fps/americas-army')
-rw-r--r--games-fps/americas-army/ChangeLog8
-rw-r--r--games-fps/americas-army/americas-army-200a-r1.ebuild90
-rw-r--r--games-fps/americas-army/americas-army-210.ebuild23
-rw-r--r--games-fps/americas-army/files/armyops4
-rw-r--r--games-fps/americas-army/files/armyops-ded.conf.d20
-rw-r--r--games-fps/americas-army/files/armyops-ded.rc25
-rw-r--r--games-fps/americas-army/files/digest-americas-army-200a-r12
7 files changed, 67 insertions, 105 deletions
diff --git a/games-fps/americas-army/ChangeLog b/games-fps/americas-army/ChangeLog
index 3e78dcc737eb..a8e108b90180 100644
--- a/games-fps/americas-army/ChangeLog
+++ b/games-fps/americas-army/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/americas-army
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/ChangeLog,v 1.20 2004/07/26 04:39:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/ChangeLog,v 1.21 2004/09/14 22:40:36 wolf31o2 Exp $
+
+ 14 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org> -files/armyops,
+ +files/armyops-ded.conf.d, +files/armyops-ded.rc,
+ -americas-army-200a-r1.ebuild, americas-army-210.ebuild:
+ Removed old versions and added dedicated server init scripts by Bjorn
+ Michaelsen <bmichaelsen@gmx.de>. Closing bug #58581.
25 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
americas-army-210.ebuild:
diff --git a/games-fps/americas-army/americas-army-200a-r1.ebuild b/games-fps/americas-army/americas-army-200a-r1.ebuild
deleted file mode 100644
index 9be6f86b140a..000000000000
--- a/games-fps/americas-army/americas-army-200a-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-200a-r1.ebuild,v 1.6 2004/07/14 14:41:39 agriffis Exp $
-
-inherit games
-
-MY_P="armyops200a-linux.bin"
-DESCRIPTION="America's Army: Operations - military simulations by the U.S. Army to provide civilians with insights on soldiering"
-HOMEPAGE="http://www.americasarmy.com/"
-SRC_URI="ftp://3dgamers.in-span.net/pub/3dgamers5/games/${PN/-/}/${MY_P}
- http://3dgamers.reliableservers.net/pub/3dgamers/games/${PN/-/}/${MY_P}
- http://3dgamers.gameservers.net/pub/3dgamers/games/${PN/-/}/${MY_P}
- http://3dgamers.planetmirror.com/pub/3dgamers/games/${PN/-/}/${MY_P}
- http://download.factoryunreal.com/mirror/UT2003CrashFix.zip"
-
-LICENSE="Army-EULA"
-SLOT="0"
-KEYWORDS="x86"
-RESTRICT="nostrip nomirror"
-
-# dedicated is unused at this time until I can find some good generic dedicated
-# server scripts to include.
-IUSE="opengl"
-
-DEPEND="virtual/libc
- app-arch/unzip"
-RDEPEND="virtual/libc
- opengl? ( virtual/opengl )"
-
-S=${WORKDIR}
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
-
-pkg_setup() {
- games_pkg_setup
- ewarn "The installed game takes about 1.6GB of space when installed and 2.4GB of space in ${PORTAGE_TMPDIR} to build!"
-}
-
-src_unpack() {
- unpack_makeself ${DISTDIR}/${MY_P} || die "unpacking game"
- unzip ${DISTDIR}/UT2003CrashFix.zip \
- || die "unpacking crash-fix"
- tar -zxf setupstuff.tar.gz || die
-}
-
-src_install() {
- einfo "This will take a while ... go get a pizza or something"
-
- dodir ${dir}
-
- tar -jxf armyops200a.tar.bz2 -C ${Ddir}/ || die "armyops untar failed"
- tar -jxf binaries.tar.bz2 -C ${Ddir}/ || die "binaries untar failed"
-
- dodoc README.linux
- insinto ${dir} ; doins ArmyOps.xpm README.linux
- insinto /usr/share/pixmaps ; doins ArmyOps.xpm
- exeinto ${dir} ; doexe bin/armyops
-
- dogamesbin ${FILESDIR}/armyops
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/armyops
- dosym ${dir}/armyops ${GAMES_BINDIR}/armyops
-
- # Here we apply DrSiN's crash patch
- cp ${S}/CrashFix/System/crashfix.u ${Ddir}/System
- ed ${Ddir}/System/Default.ini >/dev/null 2>&1 <<EOT
-$
-?Engine.GameInfo?
-a
-AccessControlClass=crashfix.iaccesscontrolini
-.
-w
-q
-EOT
-
- prepgamesdirs
- make_desktop_entry armyops "America's Army" ArmyOps.xpm
-}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo "To play the game run:"
- einfo " armyops"
- echo
- ewarn "If you are not installing for the first time and you plan on running"
- ewarn "a server, you will probably need to edit your"
- ewarn "~/.armyops200/System/UT2003.ini file and add a line that says"
- ewarn "AccessControlClass=crashfix.iaccesscontrolini to your"
- ewarn "[Engine.GameInfo] section to close a security issue."
- echo
-}
diff --git a/games-fps/americas-army/americas-army-210.ebuild b/games-fps/americas-army/americas-army-210.ebuild
index 20ad4b844cbe..8bdd20a5d00d 100644
--- a/games-fps/americas-army/americas-army-210.ebuild
+++ b/games-fps/americas-army/americas-army-210.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-210.ebuild,v 1.7 2004/07/26 04:39:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-210.ebuild,v 1.8 2004/09/14 22:40:36 wolf31o2 Exp $
inherit games
@@ -18,15 +18,14 @@ SLOT="0"
KEYWORDS="x86 amd64"
RESTRICT="nostrip nomirror"
-# dedicated is unused at this time until I can find some good generic dedicated
-# server scripts to include.
-IUSE="opengl" # dedicated
+IUSE="opengl dedicated"
DEPEND="virtual/libc
app-arch/unzip"
RDEPEND="virtual/libc
opengl? ( virtual/opengl )
- amd64? ( app-emulation/emul-linux-x86-xlibs )"
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-nvidia )"
S=${WORKDIR}
dir=${GAMES_PREFIX_OPT}/${PN}
@@ -58,9 +57,12 @@ src_install() {
exeinto ${dir}
doexe bin/armyops || die "doexe failed"
- dogamesbin "${FILESDIR}/armyops"
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/armyops
- dosym ${dir}/armyops ${GAMES_BINDIR}/armyops
+ if use dedicated; then
+ exeinto /etc/init.d ; newexe ${FILESDIR}/armyops-ded.rc armyops-ded
+ insinto /etc/conf.d ; newins ${FILESDIR}/armyops-ded.conf.d armyops-ded
+ fi
+
+ games_make_wrapper armyops ./armyops ${dir}
prepgamesdirs
make_desktop_entry armyops "America's Army" ArmyOps.xpm
@@ -71,4 +73,9 @@ pkg_postinst() {
einfo "To play the game run:"
einfo " armyops"
echo
+ if use dedicated; then
+ einfo "To start a dedicated server, run"
+ einfo " /etc/init.d/armyops-ded start"
+ echo
+ fi
}
diff --git a/games-fps/americas-army/files/armyops b/games-fps/americas-army/files/armyops
deleted file mode 100644
index 9dd669ff8d2c..000000000000
--- a/games-fps/americas-army/files/armyops
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/bash
-
-cd GENTOO_DIR
-./armyops $@
diff --git a/games-fps/americas-army/files/armyops-ded.conf.d b/games-fps/americas-army/files/armyops-ded.conf.d
new file mode 100644
index 000000000000..d92a3ed6cab6
--- /dev/null
+++ b/games-fps/americas-army/files/armyops-ded.conf.d
@@ -0,0 +1,20 @@
+# Copyright 2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/files/armyops-ded.conf.d,v 1.1 2004/09/14 22:40:36 wolf31o2 Exp $
+
+# Type of Server
+# This can be lan, global, lantournament, tournament
+SERVERTYPE="lan"
+
+# starting map of the Server
+MAP="Bridge.aao"
+
+# INI-File the Server should use.
+# Do NOT change the content of /opt/americas-army/System/Default.ini !!
+# See the comment in the file for reasons.
+INIFILE="/opt/americas-army/System/Default.ini"
+
+# LOG-File the server should write to.
+# LOGFILE="/var/log/armyopsserver.log"
+LOGFILE="/dev/null"
+
diff --git a/games-fps/americas-army/files/armyops-ded.rc b/games-fps/americas-army/files/armyops-ded.rc
new file mode 100644
index 000000000000..4e514d59c1f6
--- /dev/null
+++ b/games-fps/americas-army/files/armyops-ded.rc
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/files/armyops-ded.rc,v 1.1 2004/09/14 22:40:36 wolf31o2 Exp $
+
+depend() {
+ use net
+ }
+
+start() {
+ ebegin "Starting Americas Army Server"
+ cd /opt/americas-army/System
+ start-stop-daemon --start --chuid games \
+ --background --make-pidfile \
+ --pidfile /var/run/armyopsserver.pid \
+ --exec ./server-bin -- ${SERVERTYPE} ${MAP} log=${LOGFILE} ini=${INIFILE}
+ eend $?
+ }
+
+stop() {
+ ebegin "Stopping Americas Army Server"
+ start-stop-daemon --stop --quiet --pidfile /var/run/armyopsserver.pid
+ rm /var/run/armyopsserver.pid
+ eend $?
+ }
diff --git a/games-fps/americas-army/files/digest-americas-army-200a-r1 b/games-fps/americas-army/files/digest-americas-army-200a-r1
deleted file mode 100644
index f31501195f8d..000000000000
--- a/games-fps/americas-army/files/digest-americas-army-200a-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 1c35c2922a61faa0b2468c2eb83615a7 armyops200a-linux.bin 689600292
-MD5 bba41d9a1c552ae1664c7521798324cd UT2003CrashFix.zip 2764