summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-21 09:29:32 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-21 09:29:32 +0000
commit39282d6e39bff7e59f7969d44783a488738bf1bd (patch)
treec707cb21c5973ea258d398e03f305a1959d6825d /games-fps/alienarena
parentFix building with ecj (bug #249288) and depend on 1.5 jdk only when tests ena... (diff)
downloadgentoo-2-39282d6e39bff7e59f7969d44783a488738bf1bd.tar.gz
gentoo-2-39282d6e39bff7e59f7969d44783a488738bf1bd.tar.bz2
gentoo-2-39282d6e39bff7e59f7969d44783a488738bf1bd.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-fps/alienarena')
-rw-r--r--games-fps/alienarena/ChangeLog10
-rw-r--r--games-fps/alienarena/alienarena-20090616.ebuild83
-rw-r--r--games-fps/alienarena/files/alienarena-20090616-path-overflows.patch51
3 files changed, 142 insertions, 2 deletions
diff --git a/games-fps/alienarena/ChangeLog b/games-fps/alienarena/ChangeLog
index a6165ae94213..8375ccacdb45 100644
--- a/games-fps/alienarena/ChangeLog
+++ b/games-fps/alienarena/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alienarena
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.12 2008/12/22 17:20:30 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.13 2009/06/21 09:29:31 nyhm Exp $
+
+*alienarena-20090616 (21 Jun 2009)
+
+ 21 Jun 2009; Tristan Heaven <nyhm@gentoo.org> +alienarena-20090616.ebuild,
+ +files/alienarena-20090616-path-overflows.patch:
+ Version bump
*alienarena-20081016 (22 Dec 2008)
diff --git a/games-fps/alienarena/alienarena-20090616.ebuild b/games-fps/alienarena/alienarena-20090616.ebuild
new file mode 100644
index 000000000000..696d7ceaff79
--- /dev/null
+++ b/games-fps/alienarena/alienarena-20090616.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/alienarena-20090616.ebuild,v 1.1 2009/06/21 09:29:31 nyhm Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+
+MY_PN=${PN}${PV:0:4}
+DESCRIPTION="Fast-paced multiplayer deathmatch game"
+HOMEPAGE="http://red.planetarena.org/"
+SRC_URI="http://icculus.org/${PN}/Files/${MY_PN}-linux${PV}.zip"
+
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="" # ~amd64 ~x86
+IUSE="dedicated opengl"
+
+UIRDEPEND="media-libs/jpeg
+ media-libs/openal
+ media-libs/libvorbis
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )
+ net-misc/curl"
+UIDEPEND="x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto"
+DEPEND="${RDEPEND}
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )
+ dev-util/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_PN}/source
+
+src_prepare() {
+ rm -f ../*/*.so
+ epatch "${FILESDIR}"/${P}-path-overflows.patch
+}
+
+src_compile() {
+ emake \
+ ARCH="unknown" \
+ OSTYPE="linux" \
+ CC="$(tc-getCC)" \
+ OPTIMIZED_CFLAGS=no \
+ WITH_DATADIR=yes \
+ WITH_LIBDIR=yes \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ LIBDIR="$(games_get_libdir)"/${PN} \
+ $(use opengl && ! use dedicated && echo BUILD=CLIENT) \
+ $(! use opengl && use dedicated && echo BUILD=DEDICATED) \
+ $(use opengl && use dedicated && echo BUILD=ALL) \
+ $(use opengl || use dedicated || echo BUILD=CLIENT) \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe game.so || die "doexe failed"
+ dosym . "$(games_get_libdir)"/${PN}/arena
+ dosym . "$(games_get_libdir)"/${PN}/data1
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin crx ${PN} || die "newgamesbin crx failed"
+ make_desktop_entry ${PN} "Alien Arena"
+ fi
+
+ if use dedicated ; then
+ newgamesbin crded ${PN}-ded || die "newgamesbin crded failed"
+ fi
+
+ cd "${WORKDIR}"/${MY_PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r arena botinfo data1 || die "doins failed"
+ newicon aa.png ${PN}.png || die "newicon failed"
+ dodoc docs/README.txt
+
+ prepgamesdirs
+}
diff --git a/games-fps/alienarena/files/alienarena-20090616-path-overflows.patch b/games-fps/alienarena/files/alienarena-20090616-path-overflows.patch
new file mode 100644
index 000000000000..3d8aba46c3cb
--- /dev/null
+++ b/games-fps/alienarena/files/alienarena-20090616-path-overflows.patch
@@ -0,0 +1,51 @@
+--- source/game/acesrc/acebot_nodes.c
++++ source/game/acesrc/acebot_nodes.c
+@@ -719,7 +719,7 @@
+ void ACEND_SaveNodes()
+ {
+ FILE *pOut;
+- char filename[60];
++ char filename[MAX_OSPATH];
+ int i,j;
+ int version = 1;
+
+@@ -760,7 +760,7 @@
+ {
+ FILE *pIn;
+ int i,j;
+- char filename[60];
++ char filename[MAX_OSPATH];
+ int version;
+
+ strcpy(filename,BOTDIR"/botinfo/nav/");
+--- source/game/acesrc/acebot_spawn.c
++++ source/game/acesrc/acebot_spawn.c
+@@ -119,7 +119,7 @@
+ int i, j, count, spawnkicknum;
+ char *info;
+ char *skin;
+- char bot_filename[128];
++ char bot_filename[MAX_OSPATH];
+ int found;
+ int real_players, total_players;
+ edict_t *cl_ent;
+@@ -226,7 +226,7 @@
+ {
+ FILE *pIn;
+ int count;
+- char bot_filename[128];
++ char bot_filename[MAX_OSPATH];
+
+ //bots and configurations are loaded level specific
+ if (((int)(dmflags->value) & DF_SKINTEAMS) || ctf->value || tca->value || cp->value)
+--- source/ref_gl/r_model.c
++++ source/ref_gl/r_model.c
+@@ -1689,7 +1689,7 @@
+
+ void R_BeginRegistration (char *model)
+ {
+- char fullname[MAX_QPATH];
++ char fullname[MAX_OSPATH];
+ char *path;
+ cvar_t *flushmap;
+ FILE *file;