summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-04-20 22:56:19 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-04-20 22:56:19 +0000
commitfd02997b6f065d1272eff38558f08ffb3349b99b (patch)
tree3ee8a8e730c4aa43e86f2e95aede9ae7a0d6ea04 /games-engines
parentVersion bump (diff)
downloadgentoo-2-fd02997b6f065d1272eff38558f08ffb3349b99b.tar.gz
gentoo-2-fd02997b6f065d1272eff38558f08ffb3349b99b.tar.bz2
gentoo-2-fd02997b6f065d1272eff38558f08ffb3349b99b.zip
Version bump, bug #412717.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/love/ChangeLog8
-rw-r--r--games-engines/love/love-0.8.0.ebuild48
-rw-r--r--games-engines/love/love-9999.ebuild16
3 files changed, 64 insertions, 8 deletions
diff --git a/games-engines/love/ChangeLog b/games-engines/love/ChangeLog
index 10f101063601..57cf66fd75d2 100644
--- a/games-engines/love/ChangeLog
+++ b/games-engines/love/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/love
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/love/ChangeLog,v 1.4 2012/04/17 15:06:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/love/ChangeLog,v 1.5 2012/04/20 22:56:19 chithanh Exp $
+
+*love-0.8.0 (20 Apr 2012)
+
+ 20 Apr 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +love-0.8.0.ebuild, love-9999.ebuild:
+ Version bump, bug #412717.
17 Apr 2012; Michał Górny <mgorny@gentoo.org> love-0.7.2.ebuild,
love-9999.ebuild:
diff --git a/games-engines/love/love-0.8.0.ebuild b/games-engines/love/love-0.8.0.ebuild
new file mode 100644
index 000000000000..fc1806dacd8c
--- /dev/null
+++ b/games-engines/love/love-0.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/love/love-0.8.0.ebuild,v 1.1 2012/04/20 22:56:19 chithanh Exp $
+
+EAPI=3
+
+inherit games
+
+if [[ ${PV} == 9999* ]]; then
+ inherit autotools mercurial
+ EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://bitbucket/rude/${PN}/downloads/${P}-linux-src.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-games/physfs
+ dev-lang/lua
+ media-libs/devil[mng,tiff]
+ media-libs/freetype
+ media-libs/libmodplug
+ media-libs/libsdl[joystick,opengl]
+ media-libs/libvorbis
+ media-libs/openal
+ media-sound/mpg123
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ media-libs/libmng
+ media-libs/tiff"
+
+DOCS=( "readme.md" "changes.txt" )
+
+src_prepare() {
+ if [[ ${PV} == 9999* ]]; then
+ sh platform/unix/gen-makefile || die
+ mkdir platform/unix/m4 || die
+ eautoreconf
+ fi
+}
diff --git a/games-engines/love/love-9999.ebuild b/games-engines/love/love-9999.ebuild
index aa826dbc1f3e..cf6f16e4583e 100644
--- a/games-engines/love/love-9999.ebuild
+++ b/games-engines/love/love-9999.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/love/love-9999.ebuild,v 1.3 2012/04/17 15:06:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/love/love-9999.ebuild,v 1.4 2012/04/20 22:56:19 chithanh Exp $
EAPI=3
inherit games
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-
if [[ ${PV} == 9999* ]]; then
inherit autotools mercurial
EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
@@ -19,6 +16,9 @@ else
KEYWORDS="~amd64 ~x86"
fi
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+
LICENSE="ZLIB"
SLOT="0"
IUSE=""
@@ -40,7 +40,9 @@ DEPEND="${RDEPEND}
DOCS=( "readme.md" "changes.txt" )
src_prepare() {
- sh platform/unix/gen-makefile || die
- mkdir platform/unix/m4 || die
- eautoreconf
+ if [[ ${PV} == 9999* ]]; then
+ sh platform/unix/gen-makefile || die
+ mkdir platform/unix/m4 || die
+ eautoreconf
+ fi
}