summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-14 00:21:31 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-14 00:21:31 +0000
commitd0ecd50caa4858c84dc50bfff7ba84a0a7156183 (patch)
tree6fccb1ff1db65cebb40434f0f768487d54a8a451 /games-engines
parentversion bump (diff)
downloadgentoo-2-d0ecd50caa4858c84dc50bfff7ba84a0a7156183.tar.gz
gentoo-2-d0ecd50caa4858c84dc50bfff7ba84a0a7156183.tar.bz2
gentoo-2-d0ecd50caa4858c84dc50bfff7ba84a0a7156183.zip
version bump
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/residualvm/ChangeLog7
-rw-r--r--games-engines/residualvm/residualvm-0.1.1.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/games-engines/residualvm/ChangeLog b/games-engines/residualvm/ChangeLog
index 0cdde12baa8e..33544957b029 100644
--- a/games-engines/residualvm/ChangeLog
+++ b/games-engines/residualvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/residualvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/residualvm/ChangeLog,v 1.3 2013/02/02 22:57:43 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/residualvm/ChangeLog,v 1.4 2013/02/14 00:21:31 hasufell Exp $
+
+*residualvm-0.1.1 (14 Feb 2013)
+
+ 14 Feb 2013; Julian Ospald <hasufell@gentoo.org> +residualvm-0.1.1.ebuild:
+ version bump
02 Feb 2013; Julian Ospald <hasufell@gentoo.org>
files/residualvm-0.1.0-EE.patch:
diff --git a/games-engines/residualvm/residualvm-0.1.1.ebuild b/games-engines/residualvm/residualvm-0.1.1.ebuild
new file mode 100644
index 000000000000..0440ac41f266
--- /dev/null
+++ b/games-engines/residualvm/residualvm-0.1.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/residualvm/residualvm-0.1.1.ebuild,v 1.1 2013/02/14 00:21:31 hasufell Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs gnome2-utils games
+
+DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
+HOMEPAGE="http://www.residualvm.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: fix dynamic plugin support
+# games crash without media-libs/libsdl[alsa]
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype:2
+ media-libs/libsdl[X,audio,alsa,joystick,opengl,video]
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not an autotools script
+ # most configure options currently do nothing, recheck on version bump !!!
+ # disable explicitly, otherwise we get unneeded linkage (some copy-paste build system)
+ ./configure \
+ --disable-debug \
+ --enable-all-engines \
+ --backend=sdl \
+ --enable-release-mode \
+ --disable-tremor \
+ --disable-sparkle \
+ --prefix="${GAMES_PREFIX}" \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ --libdir="$(games_get_libdir)" \
+ --docdir="/usr/share/doc/${PF}" \
+ --disable-libunity \
+ --disable-faad \
+ --disable-flac \
+ --disable-fluidsynth \
+ --disable-mad \
+ --disable-translation \
+ --disable-vorbis \
+ --enable-zlib \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ VERBOSE_BUILD=1 \
+ AR="$(tc-getAR) cru" \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ dogamesbin residualvm
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab
+
+ doicon -s scalable icons/${PN}.svg
+ doicon -s 256 icons/${PN}.png
+ domenu dists/${PN}.desktop
+
+ doman dists/${PN}.6
+ dodoc AUTHORS README KNOWN_BUGS TODO
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}