summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-04 04:31:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-04 04:31:47 +0000
commit97d90dfbabeaddc54cdcf63ad5a31a02be7659ae (patch)
tree713de94e709b2bfb8b760572724b0556a54aa89e /games-engines
parentFix to use of unsupported themes in building docs applied wrt Bug #423963, pa... (diff)
downloadgentoo-2-97d90dfbabeaddc54cdcf63ad5a31a02be7659ae.tar.gz
gentoo-2-97d90dfbabeaddc54cdcf63ad5a31a02be7659ae.tar.bz2
gentoo-2-97d90dfbabeaddc54cdcf63ad5a31a02be7659ae.zip
add upstream patch to support building against latest boost (bug #422769)
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog6
-rw-r--r--games-engines/scummvm-tools/files/scummvm-tools-1.4.0-boost.patch53
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild5
3 files changed, 61 insertions, 3 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index 45964ace7a50..cb3d627cc287 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.56 2012/11/01 14:53:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.57 2012/11/04 04:31:47 mr_bones_ Exp $
+
+ 04 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scummvm-tools-1.4.0-boost.patch, scummvm-tools-1.4.0.ebuild:
+ add upstream patch to support building against latest boost (bug #422769)
01 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
-scummvm-tools-1.3.0.ebuild:
diff --git a/games-engines/scummvm-tools/files/scummvm-tools-1.4.0-boost.patch b/games-engines/scummvm-tools/files/scummvm-tools-1.4.0-boost.patch
new file mode 100644
index 000000000000..d492e194d3c5
--- /dev/null
+++ b/games-engines/scummvm-tools/files/scummvm-tools-1.4.0-boost.patch
@@ -0,0 +1,53 @@
+From 36cb68919303bc2b874a5faa879e269a35874eff Mon Sep 17 00:00:00 2001
+From: Johannes Schickel <lordhoto@scummvm.org>
+Date: Sat, 3 Nov 2012 21:57:08 +0100
+Subject: [PATCH] TOOLS: Fix decompiler compilation with gcc 4.7.
+
+---
+ decompiler/refcounted.h | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/decompiler/refcounted.h b/decompiler/refcounted.h
+index a496ff7..f4d9020 100644
+--- a/decompiler/refcounted.h
++++ b/decompiler/refcounted.h
+@@ -25,10 +25,8 @@
+
+ class RefCounted;
+
+-namespace boost {
+ inline void intrusive_ptr_add_ref(RefCounted *p);
+ inline void intrusive_ptr_release(RefCounted *p);
+-} // End of namespace boost
+
+ /**
+ * Provides a base implementation of reference counting for use with boost::intrusive_ptr.
+@@ -36,16 +34,14 @@
+ class RefCounted {
+ private:
+ long _refCount; ///< Reference count used for boost::intrusive_ptr.
+- friend void ::boost::intrusive_ptr_add_ref(RefCounted *p); ///< Allow access by reference counting methods in boost namespace.
+- friend void ::boost::intrusive_ptr_release(RefCounted *p); ///< Allow access by reference counting methods in boost namespace.
++ friend void ::intrusive_ptr_add_ref(RefCounted *p); ///< Allow access by reference counting methods.
++ friend void ::intrusive_ptr_release(RefCounted *p); ///< Allow access by reference counting methods.
+
+ protected:
+ RefCounted() : _refCount(0) { }
+ virtual ~RefCounted() { }
+ };
+
+-namespace boost {
+-
+ /**
+ * Add a reference to a pointer.
+ */
+@@ -61,6 +57,4 @@ inline void intrusive_ptr_release(RefCounted *p) {
+ delete p;
+ }
+
+-} // End of namespace boost
+-
+ #endif
+--
+1.7.10
+
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild
index f0176ecdebd3..b179124f7761 100644
--- a/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild
+++ b/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild,v 1.7 2012/11/01 14:58:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild,v 1.8 2012/11/04 04:31:47 mr_bones_ Exp $
EAPI=2
WX_GTK_VER=2.8
-inherit wxwidgets flag-o-matic games
+inherit wxwidgets eutils flag-o-matic games
DESCRIPTION="utilities for the SCUMM game engine"
HOMEPAGE="http://scummvm.sourceforge.net/"
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_/}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-boost.patch
rm -rf *.bat dists/win32
# use $T instead of /tmp - bug #402459
sed -i \