summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-25 05:38:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-25 05:38:32 +0000
commit6793a9f1df1d8d4c39c459f8b128f3629c646e97 (patch)
tree73a75b7137f3351ade7cae02cd38a69a0621afe7 /games-engines
parentVersion bump #453806 by Agostino Sarubbo. (diff)
downloadgentoo-2-6793a9f1df1d8d4c39c459f8b128f3629c646e97.tar.gz
gentoo-2-6793a9f1df1d8d4c39c459f8b128f3629c646e97.tar.bz2
gentoo-2-6793a9f1df1d8d4c39c459f8b128f3629c646e97.zip
old
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/gargoyle/ChangeLog7
-rw-r--r--games-engines/gargoyle/gargoyle-2010.1.ebuild110
2 files changed, 5 insertions, 112 deletions
diff --git a/games-engines/gargoyle/ChangeLog b/games-engines/gargoyle/ChangeLog
index c200c23da467..aa7d2d004bfc 100644
--- a/games-engines/gargoyle/ChangeLog
+++ b/games-engines/gargoyle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-engines/gargoyle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.23 2012/09/23 08:54:41 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.24 2013/01/25 05:38:32 mr_bones_ Exp $
+
+ 25 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -gargoyle-2010.1.ebuild:
+ old
23 Sep 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> gargoyle-2011.1.ebuild:
x86 stable wrt bug #432098
diff --git a/games-engines/gargoyle/gargoyle-2010.1.ebuild b/games-engines/gargoyle/gargoyle-2010.1.ebuild
deleted file mode 100644
index f358735677ad..000000000000
--- a/games-engines/gargoyle/gargoyle-2010.1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2010.1.ebuild,v 1.2 2012/09/05 07:44:50 jlec Exp $
-
-EAPI=2
-
-# Notes:
-# - fmod support is based on an old version of fmod which is not in portage,
-# and therefore not supported by this ebuild. SDL is the preferred library.
-# - Have contacted upstream requesting overridable build variables and a
-# configurable config file path, to obviate file editing in src_prepare.
-
-# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
-# interpreters are licensed under GPLv2, BSD or MIT license, except:
-# - alan2/alan3: status unclear!
-# - glulxe: custom license, see "terps/glulxle/README"
-# - hugo: custom license, see "licenses/HUGO License.txt"
-# Since we don't compile or install any of the bundled fonts, their licenses
-# don't apply. (Fonts are installed through dependencies instead.)
-
-inherit eutils games
-
-DESCRIPTION="An interactive fiction (IF) player supporting all major formats"
-HOMEPAGE="http://ccxvii.net/gargoyle/"
-SRC_URI="http://garglk.googlecode.com/files/${P}-sources.zip"
-
-LICENSE="BSD GPL-2 MIT Hugo Glulxe"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE="sdl"
-
-RDEPEND="media-libs/freetype:2
- virtual/jpeg
- media-libs/libpng
- media-fonts/liberation-fonts
- media-fonts/libertine-ttf
- sys-libs/zlib
- x11-libs/gtk+:2
- sdl? (
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-sound
- media-libs/libvorbis
- media-libs/smpeg
- )"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-util/ftjam"
-
-src_prepare() {
- if ! use sdl; then
- sed -i -e '/^USESDL = /s/yes/no/' Jamrules || die
- fi
-
- # Substitute custom CFLAGS/LDFLAGS:
- sed -i -e \
- "/^\s*OPTIM = / {
- s/ \(-O.*\)\? ;/ ${CFLAGS} ;/
- a LINKFLAGS = ${LDFLAGS} ;
- a SHRLINKFLAGS = ${LDFLAGS} ;
- }" Jamrules || die
-
- # Don't bundle default fonts; we'll install better ones as a dependency:
- sed -i -e '/^BUNDLEFONTS = /s/yes/no/' Jamrules || die
-
- # Convert garglk.ini to UNIX format:
- edos2unix garglk/garglk.ini
-
- # Fix path to garglk.ini in config loader:
- sed -i -e "s|/etc|${GAMES_SYSCONFDIR}|" garglk/config.c || die
-}
-
-src_compile() {
- jam || die
- jam install || die
- # Note: the line above doesn't actually install anything yet!
-}
-
-src_install() {
- # Install config file:
- insinto "${GAMES_SYSCONFDIR}"
- newins garglk/garglk.ini garglk.ini || die
-
- # Install application entry and icon:
- domenu garglk/${PN}.desktop || die
- doicon garglk/${PN}-house.png || die
-
- # Install library:
- cd build/dist || die
- dogameslib libgarglk.so || die
-
- # Install launcher and terps, symlinking binaries to avoid name clashes:
- insinto "${GAMES_PREFIX}/libexec/${PN}"
- insopts -m0755
- for terp in advsys agility alan2 alan3 frotz geas git glulxe hugo jacl \
- level9 magnetic nitfol scare tadsr
- do
- doins ${terp} || die
- dosym "${GAMES_PREFIX}/libexec/${PN}/${terp}" \
- "${GAMES_BINDIR}/${PN}-${terp}" || die
- done
- # N.B. the launcher binary is installed in libexec too, because it
- # expects to find the interpreters in the same directory:
- doins ${PN}|| die
- dosym "${GAMES_PREFIX}/libexec/${PN}/${PN}" \
- "${GAMES_BINDIR}/${PN}" || die
-
- prepgamesdirs
-}