summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 00:33:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 00:33:44 +0000
commit1aae5d7ea00b8344a3b0f09e4cfb799cc53e4d64 (patch)
treed63c8073a4d524ff255a09618a90badba47a6ac6 /games-engines
parentversion bump thanks to David Holm <dholm@gentoo.org> in bug #64571. Modified ... (diff)
downloadgentoo-2-1aae5d7ea00b8344a3b0f09e4cfb799cc53e4d64.tar.gz
gentoo-2-1aae5d7ea00b8344a3b0f09e4cfb799cc53e4d64.tar.bz2
gentoo-2-1aae5d7ea00b8344a3b0f09e4cfb799cc53e4d64.zip
clean older ebuilds and patches
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/files/0.5.1-alsa.patch22
-rw-r--r--games-engines/scummvm/files/0.6.0-gcc34.patch53
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.5.11
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.6.01
-rw-r--r--games-engines/scummvm/scummvm-0.5.1.ebuild60
-rw-r--r--games-engines/scummvm/scummvm-0.6.0.ebuild62
7 files changed, 6 insertions, 200 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index ba195e92e170..0e305ab8e0f3 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.12 2004/08/09 08:20:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.13 2004/09/19 00:33:44 mr_bones_ Exp $
+
+ 18 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/0.5.1-alsa.patch, -files/0.6.0-gcc34.patch, -scummvm-0.5.1.ebuild,
+ -scummvm-0.6.0.ebuild:
+ clean older ebuilds and patches
*scummvm-0.6.1b (09 Aug 2004)
diff --git a/games-engines/scummvm/files/0.5.1-alsa.patch b/games-engines/scummvm/files/0.5.1-alsa.patch
deleted file mode 100644
index 37528000b51c..000000000000
--- a/games-engines/scummvm/files/0.5.1-alsa.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- backends/midi/alsa.cpp 2003-07-06 20:19:54.000000000 +0000
-+++ backends/midi/alsa.cpp.patched 2004-01-02 17:13:45.268397592 +0000
-@@ -37,6 +37,11 @@
- * (you really rox, you know?)
- */
-
-+#if SND_LIB_MAJOR >= 1
-+#define snd_seq_flush_output(x) snd_seq_drain_output(x)
-+#define snd_seq_set_client_group(x,name) /*nop */
-+#define my_snd_seq_open(seqp) snd_seq_open(seqp, "hw", SND_SEQ_OPEN_OUTPUT, 0)
-+#else
- #if SND_LIB_MINOR >= 6
- #define snd_seq_flush_output(x) snd_seq_drain_output(x)
- #define snd_seq_set_client_group(x,name) /*nop */
-@@ -45,6 +50,7 @@
- /* SND_SEQ_OPEN_OUT causes oops on early version of ALSA */
- #define my_snd_seq_open(seqp) snd_seq_open(seqp, SND_SEQ_OPEN)
- #endif
-+#endif
-
- /*
- * parse address string
diff --git a/games-engines/scummvm/files/0.6.0-gcc34.patch b/games-engines/scummvm/files/0.6.0-gcc34.patch
deleted file mode 100644
index e0c07cf2ade3..000000000000
--- a/games-engines/scummvm/files/0.6.0-gcc34.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Naur scummvm-0.6.0.orig/base/main.cpp scummvm-0.6.0/base/main.cpp
---- scummvm-0.6.0.orig/base/main.cpp 2004-04-28 19:48:07.199890232 +0200
-+++ scummvm-0.6.0/base/main.cpp 2004-04-28 19:51:21.806305560 +0200
-@@ -262,7 +262,7 @@
-
- // Free up memory
- delete engine;
--};
-+}
-
- #ifndef _WIN32_WCE
- int main(int argc, char *argv[]) {
-diff -Naur scummvm-0.6.0.orig/scumm/actor.cpp scummvm-0.6.0/scumm/actor.cpp
---- scummvm-0.6.0.orig/scumm/actor.cpp 2004-04-28 19:48:07.272879136 +0200
-+++ scummvm-0.6.0/scumm/actor.cpp 2004-04-28 19:48:55.117605632 +0200
-@@ -789,14 +789,14 @@
- return _V1_talkingActor;
- else
- return VAR(VAR_TALK_ACTOR);
--};
-+}
-
- void ScummEngine::talkingActor(int value) {
- if (_gameId == GID_MANIAC && _version == 1)
- _V1_talkingActor = value;
- else
- VAR(VAR_TALK_ACTOR) = value;
--};
-+}
-
- void ScummEngine::showActors() {
- int i;
-diff -Naur scummvm-0.6.0.orig/scumm/debugger.cpp scummvm-0.6.0/scumm/debugger.cpp
---- scummvm-0.6.0.orig/scumm/debugger.cpp 2004-04-28 19:48:07.256881568 +0200
-+++ scummvm-0.6.0/scumm/debugger.cpp 2004-04-28 19:49:32.345946064 +0200
-@@ -57,7 +57,7 @@
- va_end(va);
-
- debug(buf);
--};
-+}
-
- ScummDebugger::ScummDebugger(ScummEngine *s)
- : Common::Debugger<ScummDebugger>() {
-@@ -592,7 +592,7 @@
-
- DebugPrintf("Unknown flag. Type 'Debug ?' for syntax\n");
- return true;
--};
-+}
-
- bool ScummDebugger::Cmd_DebugLevel(int argc, const char **argv) {
- if (argc == 1) {
diff --git a/games-engines/scummvm/files/digest-scummvm-0.5.1 b/games-engines/scummvm/files/digest-scummvm-0.5.1
deleted file mode 100644
index a0bbcd1c3c91..000000000000
--- a/games-engines/scummvm/files/digest-scummvm-0.5.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 67bdbe2e145b8072d0bac61f7ed150c0 scummvm-0.5.1.tar.bz2 1149076
diff --git a/games-engines/scummvm/files/digest-scummvm-0.6.0 b/games-engines/scummvm/files/digest-scummvm-0.6.0
deleted file mode 100644
index 885bcbbc1bb7..000000000000
--- a/games-engines/scummvm/files/digest-scummvm-0.6.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 efc4207a7f10b24e9fc5afa10ed9c455 scummvm-0.6.0.tar.bz2 1631951
diff --git a/games-engines/scummvm/scummvm-0.5.1.ebuild b/games-engines/scummvm/scummvm-0.5.1.ebuild
deleted file mode 100644
index 2ae140ccd99b..000000000000
--- a/games-engines/scummvm/scummvm-0.5.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.5.1.ebuild,v 1.6 2004/06/24 22:39:14 agriffis Exp $
-
-inherit eutils games
-
-DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
-HOMEPAGE="http://scummvm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc amd64"
-IUSE="alsa oggvorbis mad"
-
-DEPEND="media-libs/libsdl
- >=sys-apps/sed-4
- oggvorbis? ( media-libs/libvorbis )
- alsa? ( media-libs/alsa-lib )
- mad? ( media-libs/libmad )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${PV}-alsa.patch"
-}
-
-src_compile() {
- egamesconf \
- `use_with alsa` \
- `use_with oggvorbis vorbis` \
- `use_with mad` \
- || die
- if use alsa ; then
- sed -i \
- -e "/^# DEF.*ALSA$/s:# ::" \
- -e "/^# LIBS.*asound$/s:# ::" \
- Makefile || die "sed Makefile (alsa) failed"
- fi
- if use oggvorbis ; then
- sed -i \
- -e "/^# DEF.*VORBIS$/s:# ::" \
- -e "/^# LIBS.*vorbis$/s:# ::" \
- Makefile || die "sed Makefile (oggvorbis) failed"
- fi
- if ! use mad ; then
- sed -i \
- -e "s:^DEF.*MAD$::" \
- -e "s:^LIBS.*mad$::" \
- Makefile || die "sed Makefile (mad) failed"
- fi
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin scummvm || die "dogamesbin failed"
- doman scummvm.6
- dodoc NEWS README
- prepgamesdirs
-}
diff --git a/games-engines/scummvm/scummvm-0.6.0.ebuild b/games-engines/scummvm/scummvm-0.6.0.ebuild
deleted file mode 100644
index cef32d406657..000000000000
--- a/games-engines/scummvm/scummvm-0.6.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.0.ebuild,v 1.9 2004/07/01 05:23:12 mr_bones_ Exp $
-
-inherit eutils games
-
-DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
-HOMEPAGE="http://scummvm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc amd64 ~sparc"
-IUSE="alsa debug mad oggvorbis sdl zlib"
-
-DEPEND="virtual/libc
- virtual/x11
- >media-libs/libmpeg2-0.3.1
- sdl? ( >=media-libs/libsdl-1.2.2 )
- oggvorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- mad? ( media-libs/libmad )
- zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gcc34.patch
-}
-
-src_compile() {
- local myconf=
-
- use sdl \
- && myconf="${myconf} --backend=sdl" \
- || myconf="${myconf} --backend=x11"
- use debug \
- || myconf="${myconf} --disable-debug"
-
- # not an autoconf script so dont call econf
- ./configure \
- `use_enable alsa` \
- `use_enable mad` \
- `use_enable oggvorbis vorbis` \
- `use_enable zlib` \
- ${myconf} \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin scummvm || die "dobin failed"
- doman scummvm.6
- dodoc NEWS README TODO
- insinto /usr/share/pixmaps
- doins scummvm.xpm || die "doins failed"
- make_desktop_entry scummvm ScummVM
- prepgamesdirs
-}