summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-26 09:58:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-26 09:58:10 +0000
commit5ff3b8571040b7930def11a0734f821c3852cc30 (patch)
treeab0175aa14ef0936686797a65ba8f0ac9ceb2583 /games-engines/scummvm
parentCleaning out some old versions. (Manifest recommit) (diff)
downloadgentoo-2-5ff3b8571040b7930def11a0734f821c3852cc30.tar.gz
gentoo-2-5ff3b8571040b7930def11a0734f821c3852cc30.tar.bz2
gentoo-2-5ff3b8571040b7930def11a0734f821c3852cc30.zip
Version bump #75614 by cpu.
Diffstat (limited to 'games-engines/scummvm')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.7.01
-rw-r--r--games-engines/scummvm/scummvm-0.7.0.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index c039842d185a..26c8e4a36b32 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.15 2004/09/25 23:35:32 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.16 2004/12/26 09:58:10 vapier Exp $
+
+*scummvm-0.7.0 (26 Dec 2004)
+
+ 26 Dec 2004; Mike Frysinger <vapier@gentoo.org> +scummvm-0.7.0.ebuild:
+ Version bump #75614 by cpu.
25 Sep 2004; Jason Wever <weeve@gentoo.org> scummvm-0.6.1b.ebuild:
Stable on sparc.
diff --git a/games-engines/scummvm/files/digest-scummvm-0.7.0 b/games-engines/scummvm/files/digest-scummvm-0.7.0
new file mode 100644
index 000000000000..3de9d7da0e2b
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.7.0
@@ -0,0 +1 @@
+MD5 7e2f9bc1bc54aa78285f7f3189ee8a7c scummvm-0.7.0.tar.bz2 2045328
diff --git a/games-engines/scummvm/scummvm-0.7.0.ebuild b/games-engines/scummvm/scummvm-0.7.0.ebuild
new file mode 100644
index 000000000000..6194e5a0b93f
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.0.ebuild,v 1.1 2004/12/26 09:58:10 vapier Exp $
+
+inherit fixheadtails eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa debug mad oggvorbis sdl zlib"
+
+DEPEND="virtual/libc
+ virtual/x11
+ >media-libs/libmpeg2-0.3.1
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mad? ( media-libs/libmad )
+ zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #ht_fix_file configure #64550
+}
+
+src_compile() {
+ local myconf=
+
+ use sdl \
+ && myconf="${myconf} --backend=sdl" \
+ || myconf="${myconf} --backend=x11"
+ use debug \
+ || myconf="${myconf} --disable-debug"
+
+ # not an autoconf script so dont call econf
+ ./configure \
+ $(use_enable alsa) \
+ $(use_enable mad) \
+ $(use_enable oggvorbis vorbis) \
+ $(use_enable zlib) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
+ insinto /usr/share/pixmaps
+ doins scummvm.xpm || die "doins failed"
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}