summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-09 18:19:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-09 18:19:05 +0000
commitfa61bdc3842c4c7dfc070aa8064b32abc3b491f6 (patch)
tree20d9af2c27b6ba193a58357f8ed98d4a3ea53801 /games-emulation
parenthide the qt5 stuff for yabause for now (diff)
downloadgentoo-2-fa61bdc3842c4c7dfc070aa8064b32abc3b491f6.tar.gz
gentoo-2-fa61bdc3842c4c7dfc070aa8064b32abc3b491f6.tar.bz2
gentoo-2-fa61bdc3842c4c7dfc070aa8064b32abc3b491f6.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/yabause/ChangeLog7
-rw-r--r--games-emulation/yabause/files/yabause-0.9.12-RWX.patch22
-rw-r--r--games-emulation/yabause/files/yabause-0.9.12-cmake.patch60
-rw-r--r--games-emulation/yabause/yabause-0.9.12.ebuild64
4 files changed, 6 insertions, 147 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index 30e0c72283a6..da51ccba967d 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/yabause
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.38 2015/02/09 21:39:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.39 2015/03/09 18:19:05 mr_bones_ Exp $
+
+ 09 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/yabause-0.9.12-RWX.patch, -files/yabause-0.9.12-cmake.patch,
+ -yabause-0.9.12.ebuild, yabause-0.9.14.ebuild:
+ old
*yabause-0.9.14 (09 Feb 2015)
diff --git a/games-emulation/yabause/files/yabause-0.9.12-RWX.patch b/games-emulation/yabause/files/yabause-0.9.12-RWX.patch
deleted file mode 100644
index 1a8d3a66db16..000000000000
--- a/games-emulation/yabause/files/yabause-0.9.12-RWX.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
-
---- src/sh2_dynarec/linkage_x64.s
-+++ src/sh2_dynarec/linkage_x64.s
-@@ -747,3 +747,7 @@
- ret
- /* Set breakpoint here for debugging */
- .size breakpoint, .-breakpoint
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
---- src/sh2_dynarec/linkage_x86.s
-+++ src/sh2_dynarec/linkage_x86.s
-@@ -743,3 +743,7 @@
- ret
- /* Set breakpoint here for debugging */
- .size breakpoint, .-breakpoint
-+
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
diff --git a/games-emulation/yabause/files/yabause-0.9.12-cmake.patch b/games-emulation/yabause/files/yabause-0.9.12-cmake.patch
deleted file mode 100644
index 0ed719a70abc..000000000000
--- a/games-emulation/yabause/files/yabause-0.9.12-cmake.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Mon Feb 18 00:04:44 UTC 2013
-Subject: build system
-
- make bindir translation dir modifiable
-
---- yabause-0.9.12/src/gtk/CMakeLists.txt
-+++ yabause-0.9.12/src/gtk/CMakeLists.txt
-@@ -59,7 +59,10 @@
- yab_port_success(yabause-gtk)
- configure_file(yabause.desktop.in ${YAB_PORT_NAME}.desktop)
-
--install(TARGETS yabause-gtk DESTINATION "bin")
-+# paths
-+set(BINDIR "bin" CACHE STRING "dir to binary")
-+
-+install(TARGETS yabause-gtk DESTINATION ${BINDIR})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${YAB_PORT_NAME}.desktop DESTINATION "share/applications")
- install(FILES "doc/yabause.1" DESTINATION "${YAB_MAN_DIR}/man1" RENAME "${YAB_PORT_NAME}.1")
- install(FILES "yabause.png" DESTINATION "share/pixmaps")
---- yabause-0.9.12/src/qt/CMakeLists.txt
-+++ yabause-0.9.12/src/qt/CMakeLists.txt
-@@ -184,6 +184,9 @@
- yab_port_success(yabause-qt)
- configure_file(yabause.desktop.in ${YAB_PORT_NAME}.desktop)
-
-+# paths
-+set(BINDIR "bin" CACHE STRING "dir to binary")
-+
- if (WIN32)
- install(TARGETS yabause-qt DESTINATION ".")
- if (GLUT_FOUND)
-@@ -208,8 +211,8 @@
- install(FILES ${Mingw_Path}/mingwm10.dll DESTINATION ".")
- endif ()
- else ()
-- install(TARGETS yabause-qt DESTINATION "bin")
-+ install(TARGETS yabause-qt DESTINATION ${BINDIR})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${YAB_PORT_NAME}.desktop DESTINATION "share/applications")
- install(FILES "doc/yabause.1" DESTINATION "${YAB_MAN_DIR}/man1" RENAME "${YAB_PORT_NAME}.1")
- install(FILES "resources/icons/yabause.png" DESTINATION "share/pixmaps")
--endif ()
-\ No newline at end of file
-+endif ()
---- yabause-0.9.12/l10n/CMakeLists.txt
-+++ yabause-0.9.12/l10n/CMakeLists.txt
-@@ -2,9 +2,12 @@
-
- set(LANGS de es fr it lt pt pt_BR sv)
-
-+# paths
-+set(TRANSDIR "share/yabause/yts" CACHE STRING "dir to translation files")
-+
- if (UNIX AND NOT APPLE)
- foreach(LANG ${LANGS})
-- install(FILES "yabause_${LANG}.yts" DESTINATION "share/yabause/yts" RENAME "${LANG}.yts")
-+ install(FILES "yabause_${LANG}.yts" DESTINATION ${TRANSDIR} RENAME "${LANG}.yts")
- endforeach()
- elseif (WIN32)
- foreach(LANG ${LANGS})
diff --git a/games-emulation/yabause/yabause-0.9.12.ebuild b/games-emulation/yabause/yabause-0.9.12.ebuild
deleted file mode 100644
index 4d9c52351eb0..000000000000
--- a/games-emulation/yabause/yabause-0.9.12.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.12.ebuild,v 1.2 2013/03/02 21:15:10 hwoarang Exp $
-
-EAPI=5
-inherit eutils cmake-utils games
-
-DESCRIPTION="A Sega Saturn emulator"
-HOMEPAGE="http://yabause.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="openal opengl qt4 sdl"
-
-RDEPEND="
- openal? ( media-libs/openal )
- opengl? (
- media-libs/freeglut
- virtual/glu
- virtual/opengl
- )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- opengl? ( dev-qt/qtopengl:4 )
- )
- !qt4? (
- dev-libs/glib:2
- x11-libs/gtk+:2
- x11-libs/gtkglext
- )
- sdl? ( media-libs/libsdl[opengl?,video] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-RWX.patch \
- "${FILESDIR}"/${P}-cmake.patch
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBINDIR="${GAMES_BINDIR}"
- -DTRANSDIR="${GAMES_DATADIR}"/${PN}/yts
- -DYAB_OPTIMIZATION=""
- $(cmake-utils_use sdl YAB_WANT_SDL)
- $(cmake-utils_use openal YAB_WANT_OPENAL)
- $(cmake-utils_use opengl YAB_WANT_OPENGL)
- -DYAB_PORTS=$(usex qt4 "qt" "gtk")
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS ChangeLog GOALS README README.LIN
- prepgamesdirs
-}