summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-02 17:21:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-02 17:21:22 +0000
commitdbbf4286928f15e6051fac2ed8835fb5bc11e583 (patch)
tree8c538e9076c071e587f28c4a1652d3ea91ce23d6 /games-emulation
parentStable for amd64, wrt bug #414319 (diff)
downloadgentoo-2-dbbf4286928f15e6051fac2ed8835fb5bc11e583.tar.gz
gentoo-2-dbbf4286928f15e6051fac2ed8835fb5bc11e583.tar.bz2
gentoo-2-dbbf4286928f15e6051fac2ed8835fb5bc11e583.zip
version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dgen-sdl/ChangeLog9
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.30.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/games-emulation/dgen-sdl/ChangeLog b/games-emulation/dgen-sdl/ChangeLog
index 31239619111d..3e0a32f798f0 100644
--- a/games-emulation/dgen-sdl/ChangeLog
+++ b/games-emulation/dgen-sdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/dgen-sdl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.13 2010/04/26 15:06:56 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.14 2012/05/02 17:21:22 mr_bones_ Exp $
+
+*dgen-sdl-1.30 (02 May 2012)
+
+ 02 May 2012; Michael Sterrett <mr_bones_@gentoo.org> +dgen-sdl-1.30.ebuild:
+ version bump
26 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> dgen-sdl-1.23.ebuild:
add a blocker for media-gfx/fondu which also has a tobin (bug #289715)
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.30.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.30.ebuild
new file mode 100644
index 000000000000..5c9f0ba3bcb2
--- /dev/null
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.30.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.30.ebuild,v 1.1 2012/05/02 17:21:22 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+HOMEPAGE="http://tamentis.com/projects/dgen/"
+SRC_URI="mirror://sourceforge/dgen/files/${P}.tar.gz"
+
+LICENSE="dgen-sdl as-is LGPL-2.1 GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick opengl"
+
+RDEPEND="media-libs/libsdl[joystick?]
+ app-arch/libarchive
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable x86 asm) \
+ $(use_enable joystick) \
+ $(use_enable opengl)
+}
+
+src_compile() {
+ emake -C musa m68kops.h || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README sample.dgenrc
+ prepgamesdirs
+}