summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-05 23:51:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-05 23:51:31 +0000
commitcd50bfffd3cf99bf69287ce90cb1e68a8d0ad809 (patch)
tree6632e550a18ef4deaf8f926d7b814201973d6a87 /games-emulation
parentadjust orphaned dependencies (diff)
downloadgentoo-2-cd50bfffd3cf99bf69287ce90cb1e68a8d0ad809.tar.gz
gentoo-2-cd50bfffd3cf99bf69287ce90cb1e68a8d0ad809.tar.bz2
gentoo-2-cd50bfffd3cf99bf69287ce90cb1e68a8d0ad809.zip
version bump (bug #280044)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemenu/ChangeLog11
-rw-r--r--games-emulation/advancemenu/advancemenu-2.5.0.ebuild89
-rw-r--r--games-emulation/advancemenu/files/advancemenu-2.5.0-alsa-pkg-config.patch44
-rw-r--r--games-emulation/advancemenu/files/advancemenu-2.5.0-pic.patch13
4 files changed, 155 insertions, 2 deletions
diff --git a/games-emulation/advancemenu/ChangeLog b/games-emulation/advancemenu/ChangeLog
index 3cf2c8f3be41..498e869bc87e 100644
--- a/games-emulation/advancemenu/ChangeLog
+++ b/games-emulation/advancemenu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/advancemenu
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemenu/ChangeLog,v 1.29 2008/12/05 16:19:47 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemenu/ChangeLog,v 1.30 2009/08/05 23:51:31 mr_bones_ Exp $
+
+*advancemenu-2.5.0 (05 Aug 2009)
+
+ 05 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +advancemenu-2.5.0.ebuild, +files/advancemenu-2.5.0-alsa-pkg-config.patch,
+ +files/advancemenu-2.5.0-pic.patch:
+ version bump (bug #280044)
05 Dec 2008; Tristan Heaven <nyhm@gentoo.org> advancemenu-2.4.13.ebuild:
Remove expat and zlib USE flags, bug #249459
diff --git a/games-emulation/advancemenu/advancemenu-2.5.0.ebuild b/games-emulation/advancemenu/advancemenu-2.5.0.ebuild
new file mode 100644
index 000000000000..e1e144565d81
--- /dev/null
+++ b/games-emulation/advancemenu/advancemenu-2.5.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemenu/advancemenu-2.5.0.ebuild,v 1.1 2009/08/05 23:51:31 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Frontend for AdvanceMAME, MAME, MESS, RAINE and any other emulator"
+HOMEPAGE="http://advancemame.sourceforge.net/menu-readme.html"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa debug fbcon ncurses oss sdl slang static svga truetype"
+
+RDEPEND="dev-libs/expat
+ alsa? ( media-libs/alsa-lib )
+ ncurses? ( sys-libs/ncurses )
+ sdl? ( media-libs/libsdl )
+ slang? ( >=sys-libs/slang-1.4 )
+ svga? ( >=media-libs/svgalib-1.9 )
+ !sdl? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
+ truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ fbcon? ( virtual/os-headers )"
+
+src_prepare() {
+ # pic patch - bug #142021
+ epatch \
+ "${FILESDIR}"/${P}-alsa-pkg-config.patch \
+ "${FILESDIR}"/${P}-pic.patch
+ sed -i \
+ -e 's/"-s"//' \
+ configure \
+ || die "sed failed"
+
+ use x86 && ln -s $(type -P nasm) "${T}/${CHOST}-nasm"
+ use sdl && ln -s $(type -P sdl-config) "${T}/${CHOST}-sdl-config"
+ use !sdl && use !svga && use !fbcon && ln -s $(type -P sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && ln -s $(type -P freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_configure() {
+ export PATH="${PATH}:${T}"
+ egamesconf \
+ --enable-expat \
+ --enable-zlib \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable fbcon fb) \
+ $(use_enable ncurses) \
+ $(use_enable truetype freetype) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use !sdl && use !svga && use !fbcon && echo --enable-sdl) \
+ $(use_enable x86 asm)
+}
+
+src_compile() {
+ STRIPPROG=true emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin advmenu || die "dogamesbin failed"
+ dodoc HISTORY README RELEASE doc/*.txt
+ doman doc/{advmenu,advdev}.1
+ dohtml doc/*.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Execute:"
+ elog " advmenu -default"
+ elog "to generate a config file"
+ elog
+ elog "An example emulator config found in advmenu.rc:"
+ elog " emulator \"snes9x\" generic \"/usr/games/bin/snes9x\" \"%f\""
+ elog " emulator_roms \"snes9x\" \"/home/user/myroms\""
+ elog " emulator_roms_filter \"snes9x\" \"*.smc;*.sfc\""
+ elog
+ elog "For more information, see the advmenu man page."
+}
diff --git a/games-emulation/advancemenu/files/advancemenu-2.5.0-alsa-pkg-config.patch b/games-emulation/advancemenu/files/advancemenu-2.5.0-alsa-pkg-config.patch
new file mode 100644
index 000000000000..de0af21f2fc0
--- /dev/null
+++ b/games-emulation/advancemenu/files/advancemenu-2.5.0-alsa-pkg-config.patch
@@ -0,0 +1,44 @@
+Make sure we ask alsa what libraries it needs rather than assuming.
+
+http://bugs.gentoo.org/97628
+
+Changes for configure.ac:
+ --------------------------------------
+ [snd_pcm_open],
+ [ac_lib_alsa=yes],
+ [ac_lib_alsa=no],
+ - [-lm]
+ + [`pkg-config alsa --libs`]
+ )
+ if test $ac_lib_alsa = yes; then
+ AC_MSG_CHECKING([for ALSA])
+ --------------------------------------
+ [snd_pcm_open],
+ [],
+ [AC_MSG_ERROR([the ALSA library is missing])],
+ - [-lm]
+ + [`pkg-config alsa --libs`]
+ )
+ AC_MSG_CHECKING([for ALSA version])
+ AC_TRY_COMPILE([
+
+--- configure
++++ configure
+@@ -8298,7 +8298,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lasound -lm
++LIBS="-lasound `pkg-config alsa --libs`
+ $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -8428,7 +8428,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lasound -lm
++LIBS="-lasound `pkg-config alsa --libs`
+ $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
diff --git a/games-emulation/advancemenu/files/advancemenu-2.5.0-pic.patch b/games-emulation/advancemenu/files/advancemenu-2.5.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemenu/files/advancemenu-2.5.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"