summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-05-06 17:23:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-05-06 17:23:23 +0000
commitc5193616111c62cd3ab160feeea00e5fed634704 (patch)
treee6839b01a6d3fa159079d1eeca43f53aa6e10595 /games-emulation
parentAdd ~arm/~s390/~sh (diff)
downloadgentoo-2-c5193616111c62cd3ab160feeea00e5fed634704.tar.gz
gentoo-2-c5193616111c62cd3ab160feeea00e5fed634704.tar.bz2
gentoo-2-c5193616111c62cd3ab160feeea00e5fed634704.zip
Version bump to 0.9.21 Bug #414597
(Portage version: 2.1.10.57/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen/ChangeLog8
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.21-zlib.patch27
-rw-r--r--games-emulation/mednafen/mednafen-0.9.21.ebuild63
3 files changed, 97 insertions, 1 deletions
diff --git a/games-emulation/mednafen/ChangeLog b/games-emulation/mednafen/ChangeLog
index dddb023021d6..8ccc82a23891 100644
--- a/games-emulation/mednafen/ChangeLog
+++ b/games-emulation/mednafen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mednafen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.34 2012/05/04 04:38:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.35 2012/05/06 17:23:23 tupone Exp $
+
+*mednafen-0.9.21 (06 May 2012)
+
+ 06 May 2012; Tupone Alfredo <tupone@gentoo.org> +mednafen-0.9.21.ebuild,
+ +files/mednafen-0.9.21-zlib.patch:
+ Version bump to 0.9.21 Bug #414597 by Tatsh
04 May 2012; Jeff Horelick <jdhore@gentoo.org> mednafen-0.8.13.3.ebuild,
mednafen-0.8.13.3-r1.ebuild:
diff --git a/games-emulation/mednafen/files/mednafen-0.9.21-zlib.patch b/games-emulation/mednafen/files/mednafen-0.9.21-zlib.patch
new file mode 100644
index 000000000000..2eec3ed1bf14
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.21-zlib.patch
@@ -0,0 +1,27 @@
+--- src/file.cpp.old 2012-05-06 13:20:45.762299681 +0200
++++ src/file.cpp 2012-05-06 13:21:13.634342683 +0200
+@@ -33,7 +33,7 @@
+
+
+ #include <zlib.h>
+-#include "compress/unzip.h"
++#include <minizip/unzip.h>
+
+ #include "file.h"
+ #include "general.h"
+--- src/compress/Makefile.am.inc.old 2012-05-06 13:19:12.625839129 +0200
++++ src/compress/Makefile.am.inc 2012-05-06 13:19:30.012618340 +0200
+@@ -1 +1 @@
+-mednafen_SOURCES += compress/minilzo.c compress/quicklz.c compress/blz.cpp compress/ioapi.c compress/unzip.c
++mednafen_SOURCES += compress/minilzo.c compress/quicklz.c compress/blz.cpp
+--- src/Makefile.am.old 2012-05-06 13:19:54.047930734 +0200
++++ src/Makefile.am 2012-05-06 13:20:26.888624869 +0200
+@@ -5,7 +5,7 @@
+
+ bin_PROGRAMS = mednafen
+ mednafen_SOURCES = debug.cpp error.cpp mempatcher.cpp settings.cpp endian.cpp mednafen.cpp file.cpp general.cpp md5.cpp memory.cpp netplay.cpp state.cpp movie.cpp player.cpp PSFLoader.cpp tests.cpp qtrecord.cpp cdplay.cpp okiadpcm.cpp math_ops.cpp FileWrapper.cpp Stream.cpp
+-mednafen_LDADD = trio/libtrio.a drivers/libmdfnsdl.a sexyal/libsexyal.a @SDL_LIBS@
++mednafen_LDADD = trio/libtrio.a drivers/libmdfnsdl.a sexyal/libsexyal.a @SDL_LIBS@ -lminizip
+ mednafen_DEPENDENCIES = trio/libtrio.a drivers/libmdfnsdl.a sexyal/libsexyal.a
+
+ SUBDIRS += sexyal drivers
diff --git a/games-emulation/mednafen/mednafen-0.9.21.ebuild b/games-emulation/mednafen/mednafen-0.9.21.ebuild
new file mode 100644
index 000000000000..c47ffb174de7
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-0.9.21.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.9.21.ebuild,v 1.1 2012/05/06 17:23:23 tupone Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="An advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, NGPC and Lynx emulator"
+HOMEPAGE="http://mednafen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-wip.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa altivec cjk debug jack nls"
+
+RDEPEND="virtual/opengl
+ media-libs/libsndfile
+ dev-libs/libcdio
+ media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-net
+ sys-libs/zlib[minizip]
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ $(find . -name 'Makefile.am') \
+ intl/Makefile.in \
+ || die 'sed failed'
+ sed -i \
+ -e '/-ffast-math/d' \
+ -e '/^AX_CFLAGS_GCC_OPTION.*OPTIMIZER_FLAGS/d' \
+ configure.ac \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-zlib.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa) \
+ $(use_enable altivec) \
+ $(use_enable cjk cjk-fonts) \
+ $(use_enable debug debugger) \
+ $(use_enable jack) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Documentation/cheats.txt AUTHORS ChangeLog TODO
+ dohtml Documentation/*
+ prepgamesdirs
+}