summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-08 00:36:48 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-08 00:36:48 +0000
commit8db65f4d4c0b76941baa3c8d447aee0c184e01ea (patch)
tree2d689f2a4d687b35d73efdb61f8391724b00707f /games-emulation
parentadd usb to DEPEND (diff)
downloadgentoo-2-8db65f4d4c0b76941baa3c8d447aee0c184e01ea.tar.gz
gentoo-2-8db65f4d4c0b76941baa3c8d447aee0c184e01ea.tar.bz2
gentoo-2-8db65f4d4c0b76941baa3c8d447aee0c184e01ea.zip
Fix PIC usage #101627 by Jens Pranaitis.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-gssoft/ChangeLog6
-rw-r--r--games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-PIC.patch23
-rw-r--r--games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild3
3 files changed, 30 insertions, 2 deletions
diff --git a/games-emulation/ps2emu-gssoft/ChangeLog b/games-emulation/ps2emu-gssoft/ChangeLog
index 7b85d45be5ab..71580bc097d4 100644
--- a/games-emulation/ps2emu-gssoft/ChangeLog
+++ b/games-emulation/ps2emu-gssoft/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/ps2emu-gssoft
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ChangeLog,v 1.7 2005/08/07 07:13:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ChangeLog,v 1.8 2005/08/08 00:36:48 vapier Exp $
+
+ 08 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/ps2emu-gssoft-0.9-PIC.patch, ps2emu-gssoft-0.9.ebuild:
+ Fix PIC usage #101627 by Jens Pranaitis.
*ps2emu-gssoft-0.9 (07 Aug 2005)
diff --git a/games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-PIC.patch b/games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-PIC.patch
new file mode 100644
index 000000000000..91b747e8fb80
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-PIC.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/101627
+--- Src/x86/ix86_cpudetect.c
++++ Src/x86/ix86_cpudetect.c
+@@ -151,16 +151,18 @@
+ }
+
+ __asm__ __volatile__ (
++ "push %%ebx\n"
+ "mov %4, %%eax\n"
+ "cpuid\n"
+ "mov %%eax, %0\n"
+ "mov %%ebx, %1\n"
+ "mov %%ecx, %2\n"
+ "mov %%edx, %3\n"
++ "pop %%ebx\n"
+ : "=m" (regs[0]), "=m" (regs[1]),
+ "=m" (regs[2]), "=m" (regs[3])
+ : "m"(cmd)
+- : "eax", "ebx", "ecx", "edx"
++ : "eax", "ecx", "edx"
+ );
+
+ return 0;
diff --git a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
index 22723d76390d..16e9799b20e6 100644
--- a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
+++ b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.2 2005/08/07 07:35:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.3 2005/08/08 00:36:48 vapier Exp $
inherit games
@@ -27,6 +27,7 @@ src_unpack() {
cd "${S}"
sed -i 's:-O2 -fomit-frame-pointer -ffast-math:$(OPTFLAGS):' Src/Linux/Makefile || die
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-PIC.patch
}
src_compile() {