summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-17 19:58:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-17 19:58:21 +0000
commit864b8e26a21213423d3a6ce33336471c628d2687 (patch)
tree55ed1777861b6ae4a38a64f1bd91140c8be7b270 /games-emulation
parentRevision bump, fixes bug 331899 and bug 332737 (diff)
downloadgentoo-2-864b8e26a21213423d3a6ce33336471c628d2687.tar.gz
gentoo-2-864b8e26a21213423d3a6ce33336471c628d2687.tar.bz2
gentoo-2-864b8e26a21213423d3a6ce33336471c628d2687.zip
add debug use flag (bug #333219) - patch from Martin Väth
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sdlmame/ChangeLog6
-rw-r--r--games-emulation/sdlmame/files/sdlmame-0.136-nodebug.patch31
-rw-r--r--games-emulation/sdlmame/sdlmame-0.136.ebuild15
3 files changed, 47 insertions, 5 deletions
diff --git a/games-emulation/sdlmame/ChangeLog b/games-emulation/sdlmame/ChangeLog
index 054255ec317a..89322fb1a4b9 100644
--- a/games-emulation/sdlmame/ChangeLog
+++ b/games-emulation/sdlmame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/sdlmame
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.29 2010/05/22 15:06:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/ChangeLog,v 1.30 2010/08/17 19:58:21 mr_bones_ Exp $
+
+ 17 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> sdlmame-0.136.ebuild,
+ +files/sdlmame-0.136-nodebug.patch:
+ add debug use flag (bug #333219) - patch from Martin Väth
22 May 2010; Pacho Ramos <pacho@gentoo.org> sdlmame-0.136.ebuild:
stable amd64, bug 303487
diff --git a/games-emulation/sdlmame/files/sdlmame-0.136-nodebug.patch b/games-emulation/sdlmame/files/sdlmame-0.136-nodebug.patch
new file mode 100644
index 000000000000..0779a907d51b
--- /dev/null
+++ b/games-emulation/sdlmame/files/sdlmame-0.136-nodebug.patch
@@ -0,0 +1,31 @@
+--- src/osd/sdl/sdl.mak
++++ src/osd/sdl/sdl.mak
+@@ -37,6 +37,10 @@
+
+ # NO_X11 = 1
+
++# comment next line to build with debugging support
++
++NO_DEBUGGER = 1
++
+ # uncomment and adapt next line to link against specific GL-Library
+ # this will also add a rpath to the executable
+ # MESA_INSTALL_ROOT = /usr/local/dfb_GL
+@@ -297,12 +301,17 @@
+ # the new debugger relies on GTK+ in addition to the base SDLMAME needs
+ # Non-X11 builds can not use the debugger
+ ifndef NO_X11
++ifndef NO_DEBUGGER
+ OSDCOREOBJS += $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
+ CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
+ LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
+ CFLAGS += -DGTK_DISABLE_DEPRECATED
+ else
+ OSDCOREOBJS += $(SDLOBJ)/debugwin.o
++DEFS += -DNO_DEBUGGER
++endif # NO_DEBUGGER
++else
++OSDCOREOBJS += $(SDLOBJ)/debugwin.o
+ endif # NO_X11
+
+ # make sure we can find X headers
diff --git a/games-emulation/sdlmame/sdlmame-0.136.ebuild b/games-emulation/sdlmame/sdlmame-0.136.ebuild
index c3f5075b7ebe..e6c0c82d80bc 100644
--- a/games-emulation/sdlmame/sdlmame-0.136.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.136.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.136.ebuild,v 1.4 2010/05/22 15:06:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/sdlmame/sdlmame-0.136.ebuild,v 1.5 2010/08/17 19:58:21 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -18,13 +18,15 @@ SRC_URI="mirror://gentoo/${MY_P}.zip
LICENSE="XMAME"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="opengl"
+IUSE="opengl debug"
RDEPEND=">=media-libs/libsdl-1.2.10[audio,joystick,opengl?,video]
dev-libs/expat
x11-libs/libXinerama
- x11-libs/gtk+:2
- gnome-base/gconf:2"
+ debug? (
+ x11-libs/gtk+:2
+ gnome-base/gconf
+ )"
DEPEND="${RDEPEND}
app-arch/unzip
x11-proto/xineramaproto"
@@ -69,6 +71,11 @@ src_prepare() {
einfo "Enabling PPC support"
enable_feature BIGENDIAN
fi
+
+ if ! use debug; then
+ einfo "Disabling Debugging"
+ epatch "${FILESDIR}"/${P}-nodebug.patch
+ fi
}
src_compile() {