summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-06 18:48:05 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-06 18:48:05 +0000
commit29771fef6b8ac5ef17b3a7e6465eca1f56502ff4 (patch)
tree51c8f24c62e4636cbc509714d280436908dd53d3 /games-emulation
parentStable for HPPA (bug #179533). (diff)
downloadgentoo-2-29771fef6b8ac5ef17b3a7e6465eca1f56502ff4.tar.gz
gentoo-2-29771fef6b8ac5ef17b3a7e6465eca1f56502ff4.tar.bz2
gentoo-2-29771fef6b8ac5ef17b3a7e6465eca1f56502ff4.zip
Fix for recent linux-headers and exec stack
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gnuboy/ChangeLog9
-rw-r--r--games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch27
-rw-r--r--games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch93
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3.ebuild25
4 files changed, 144 insertions, 10 deletions
diff --git a/games-emulation/gnuboy/ChangeLog b/games-emulation/gnuboy/ChangeLog
index f03f51b77827..01b650e9301f 100644
--- a/games-emulation/gnuboy/ChangeLog
+++ b/games-emulation/gnuboy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/gnuboy
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/ChangeLog,v 1.10 2006/09/28 12:45:03 nyhm Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/ChangeLog,v 1.11 2007/07/06 18:48:05 nyhm Exp $
+
+ 06 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/gnuboy-1.0.3-exec-stack.patch,
+ +files/gnuboy-1.0.3-linux-headers.patch, gnuboy-1.0.3.ebuild:
+ Fix for recent linux-headers and exec stack
28 Sep 2006; Tristan Heaven <nyhm@gentoo.org> gnuboy-1.0.3.ebuild:
Add missing RDEPEND on sys-apps/fbset, bug #99983
diff --git a/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch b/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch
new file mode 100644
index 000000000000..b8059f915f6f
--- /dev/null
+++ b/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch
@@ -0,0 +1,27 @@
+--- asm/i386/cpu.s
++++ asm/i386/cpu.s
+@@ -2428,3 +2428,6 @@
+
+
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- asm/i386/lcd.s
++++ asm/i386/lcd.s
+@@ -288,3 +288,6 @@
+
+
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- asm/i386/refresh.s
++++ asm/i386/refresh.s
+@@ -283,3 +283,6 @@
+
+
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch b/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch
new file mode 100644
index 000000000000..b0dd24a8e50e
--- /dev/null
+++ b/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch
@@ -0,0 +1,93 @@
+# -ansi breaks <linux/joystick.h>
+
+--- configure.in
++++ configure.in
+@@ -133,7 +133,7 @@
+ if test "$enable_warnings" = yes ; then
+ case "$CC" in *gcc*)
+ AC_MSG_RESULT(enabling selected compiler warnings)
+-CFLAGS="$CFLAGS -ansi -pedantic -Wall -Wno-implicit -Wno-long-long" ;;
++CFLAGS="$CFLAGS -Wall -Wno-implicit -Wno-long-long" ;;
+ *)
+ AC_MSG_RESULT(disabling warnings for non-gcc compiler) ;;
+ esac
+--- loader.c
++++ loader.c
+@@ -11,7 +11,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-char *strdup();
+
+ static int mbc_table[256] =
+ {
+--- main.c
++++ main.c
+@@ -8,7 +8,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-char *strdup();
+
+ #include <stdarg.h>
+ #include <signal.h>
+--- path.c
++++ path.c
+@@ -5,7 +5,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-char *strdup();
+
+ #ifdef ALT_PATH_SEP
+ #define SEP ';'
+--- rckeys.c
++++ rckeys.c
+@@ -4,7 +4,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-char *strdup();
+
+ #include "defs.h"
+ #include "rc.h"
+--- rcvars.c
++++ rcvars.c
+@@ -5,7 +5,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-char *strdup();
+
+ #include "defs.h"
+ #include "rc.h"
+--- sys/linux/fbdev.c
++++ sys/linux/fbdev.c
+@@ -10,7 +10,6 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-char *strdup();
+ #include <unistd.h>
+ #include <sys/mman.h>
+ #include <linux/fb.h>
+--- sys/linux/joy.c
++++ sys/linux/joy.c
+@@ -2,7 +2,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-char *strdup();
+ #include <linux/joystick.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- sys/oss/oss.c
++++ sys/oss/oss.c
+@@ -2,7 +2,6 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-char *strdup();
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
index 80f9c05e96d1..0dc318d6917a 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.12 2006/09/28 12:45:03 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.13 2007/07/06 18:48:05 nyhm Exp $
-inherit games
+inherit autotools eutils games
DESCRIPTION="Gameboy emulator with multiple renderers"
HOMEPAGE="http://gnuboy.unix-fu.org/"
@@ -14,14 +14,23 @@ KEYWORDS="amd64 ppc x86"
IUSE="X fbcon sdl svga"
RDEPEND="sdl? ( media-libs/libsdl )
- !X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
- X? ( x11-libs/libXext )
- fbcon? ( sys-apps/fbset )"
+ !X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
+ X? ( x11-libs/libXext )
+ fbcon? ( sys-apps/fbset )"
DEPEND="${RDEPEND}
svga? ( media-libs/svgalib )
X? ( x11-proto/xextproto
x11-proto/xproto )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-exec-stack.patch \
+ "${FILESDIR}"/${P}-linux-headers.patch
+ eautoreconf
+}
+
src_compile() {
local myconf
@@ -44,8 +53,8 @@ src_compile() {
src_install() {
for f in fbgnuboy sdlgnuboy sgnuboy xgnuboy
do
- if [[ -f $f ]] ; then
- dogamesbin $f || die "dogamesbin failed"
+ if [[ -f ${f} ]] ; then
+ dogamesbin ${f} || die "dogamesbin failed"
fi
done
dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}