summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-11 20:49:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-11 20:49:46 +0000
commit0816ce85e1f571cc904969b1df01d4c121d7f447 (patch)
treed1940653b37f439b031145738f819a60e225e8eb /games-emulation
parentSpell 'deprecated' correctly. (diff)
downloadgentoo-2-0816ce85e1f571cc904969b1df01d4c121d7f447.tar.gz
gentoo-2-0816ce85e1f571cc904969b1df01d4c121d7f447.tar.bz2
gentoo-2-0816ce85e1f571cc904969b1df01d4c121d7f447.zip
version bump with patch from Julian Ospald (bug #430922)
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.7.2.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 2afffd8612d2..c46eb34d7f6b 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.67 2012/01/30 17:40:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.68 2012/08/11 20:49:46 mr_bones_ Exp $
+
+*stella-3.7.2 (11 Aug 2012)
+
+ 11 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.7.2.ebuild:
+ version bump with patch from Julian Ospald (bug #430922)
30 Jan 2012; Michael Sterrett <mr_bones_@gentoo.org> stella-3.5.ebuild:
build with newer zlib (bug #401471)
diff --git a/games-emulation/stella/stella-3.7.2.ebuild b/games-emulation/stella/stella-3.7.2.ebuild
new file mode 100644
index 000000000000..aca782b77998
--- /dev/null
+++ b/games-emulation/stella/stella-3.7.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.7.2.ebuild,v 1.1 2012/08/11 20:49:46 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick opengl"
+
+DEPEND="media-libs/libsdl[joystick?,video]
+ x11-libs/libX11
+ media-libs/libpng:0
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+ sed -i \
+ -e '/Icon/s/.png//' \
+ -e '/Categories/s/Application;//' \
+ src/unix/stella.desktop || die
+ # build with newer zlib (bug #390093)
+ sed -i -e '60i#define OF(x) x' src/emucore/unzip.h || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ # icons
+ local i
+ for i in 48 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}