summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-14 01:07:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-14 01:07:47 +0000
commitf0eb693b6407d4ccc693197715356390d63a2105 (patch)
treedd76ec9ae8377771f81f0bf4388fc6dc16228423 /games-emulation/stella
parentVersion bump, bug #284726. (diff)
downloadgentoo-2-f0eb693b6407d4ccc693197715356390d63a2105.tar.gz
gentoo-2-f0eb693b6407d4ccc693197715356390d63a2105.tar.bz2
gentoo-2-f0eb693b6407d4ccc693197715356390d63a2105.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 643ba2e12ed2..7d80cff606ef 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.42 2009/08/17 20:34:14 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.43 2009/09/14 01:07:47 mr_bones_ Exp $
+
+*stella-3.0 (14 Sep 2009)
+
+ 14 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.0.ebuild:
+ version bump
17 Aug 2009; Christian Faulhammer <fauli@gentoo.org> stella-2.8.4.ebuild:
stable x86, bug 279546
diff --git a/games-emulation/stella/stella-3.0.ebuild b/games-emulation/stella/stella-3.0.ebuild
new file mode 100644
index 000000000000..78d2ed7898b8
--- /dev/null
+++ b/games-emulation/stella/stella-3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.0.ebuild,v 1.1 2009/09/14 01:07:47 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}