summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-24 00:53:40 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-24 00:53:40 +0000
commit18d2c433fba6464973b1850d2737dfc225404d70 (patch)
tree07e853931bdaa4a52cf3dd97df7d90bd13abe908 /games-emulation/pcsx
parentinitial import of basemap-data (diff)
downloadgentoo-2-18d2c433fba6464973b1850d2737dfc225404d70.tar.gz
gentoo-2-18d2c433fba6464973b1850d2737dfc225404d70.tar.bz2
gentoo-2-18d2c433fba6464973b1850d2737dfc225404d70.zip
Fix dependencies, bug #168179
(Portage version: 2.1.2-r10)
Diffstat (limited to 'games-emulation/pcsx')
-rw-r--r--games-emulation/pcsx/ChangeLog8
-rw-r--r--games-emulation/pcsx/files/pcsx24
-rw-r--r--games-emulation/pcsx/pcsx-1.5-r1.ebuild55
3 files changed, 44 insertions, 43 deletions
diff --git a/games-emulation/pcsx/ChangeLog b/games-emulation/pcsx/ChangeLog
index b7cddf991937..368d6907c14e 100644
--- a/games-emulation/pcsx/ChangeLog
+++ b/games-emulation/pcsx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/pcsx
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/ChangeLog,v 1.9 2006/07/25 04:19:19 mr_bones_ Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/ChangeLog,v 1.10 2007/02/24 00:53:40 nyhm Exp $
+
+ 24 Feb 2007; Tristan Heaven <nyhm@gentoo.org> files/pcsx,
+ pcsx-1.5-r1.ebuild:
+ Fix dependencies, bug #168179
25 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org> pcsx-1.5-r1.ebuild:
avoid pre-stripping binaries; tidy - patch from Tristan Heaven via bug #137830
diff --git a/games-emulation/pcsx/files/pcsx b/games-emulation/pcsx/files/pcsx
index 0a66d5411542..106788c0c5c4 100644
--- a/games-emulation/pcsx/files/pcsx
+++ b/games-emulation/pcsx/files/pcsx
@@ -2,28 +2,28 @@
source /sbin/functions.sh
-if [ ! -f ${HOME}/.pcsx/config ]; then
+if [[ ! -f ~/.pcsx/config ]]; then
einfo You are running PCSX for the first time.
einfo Setting up your PCSX environment... Please wait...
- mkdir -p ${HOME}/.pcsx
- cd ${HOME}/.pcsx
+ mkdir -p ~/.pcsx
+ cd ~/.pcsx
mkdir memcards bios cfg plugins
- ln -s /usr/games/bin/pcsx.bin pcsx
- ln -s /usr/games/lib/psemu/plugins/* plugins/
- ln -s /usr/share/games/pcsx .pixmaps
+ ln -s GAMES_BINDIR/pcsx.bin pcsx
+ ln -s GAMES_LIBDIR/psemu/plugins/* plugins/
+ ln -s GAMES_DATADIR/pcsx .pixmaps
cd bios
- if [ -f /usr/games/lib/psemu/bios/scph1001.bin ]; then
- ln -s /usr/games/lib/psemu/bios/scph1001.bin .
+ if [[ -f GAMES_LIBDIR/psemu/bios/scph1001.bin ]]; then
+ ln -s GAMES_LIBDIR/psemu/bios/scph1001.bin .
biosname=scph1001.bin
else
biosname=HLE
fi
cd ..
- cat >${HOME}/.pcsx/config <<EOF
+ cat >~/.pcsx/config <<EOF
Bios = $biosname
Gpu = $(basename $(ls plugins/libgpu* | cut -f1 -d\ ) )
Spu = $(basename $(ls plugins/libspu* | cut -f1 -d\ ) )
@@ -48,9 +48,9 @@ EOF
unset biosname
fi
-cd ${HOME}/.pcsx/
+cd ~/.pcsx/
-ln -s /usr/games/lib/psemu/cfg/* cfg/ &>/dev/null
-ln -s /usr/games/lib/psemu/plugins/* plugins/ &>/dev/null
+ln -s GAMES_LIBDIR/psemu/cfg/* cfg/ &>/dev/null
+ln -s GAMES_LIBDIR/psemu/plugins/* plugins/ &>/dev/null
exec ./pcsx "$@"
diff --git a/games-emulation/pcsx/pcsx-1.5-r1.ebuild b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
index b81dcabf2928..9e3fdfc637b8 100644
--- a/games-emulation/pcsx/pcsx-1.5-r1.ebuild
+++ b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
@@ -1,68 +1,65 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.9 2006/07/25 04:19:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.10 2007/02/24 00:53:40 nyhm Exp $
inherit eutils games
-S=${WORKDIR}/PcsxSrc-${PV}
-DESCRIPTION="Playstation emulator"
+DESCRIPTION="PlayStation emulator"
HOMEPAGE="http://www.pcsx.net/"
SRC_URI="http://www.pcsx.net/downloads/PcsxSrc-${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 -ppc"
+KEYWORDS="-ppc x86"
IUSE="opengl"
-DEPEND="sys-libs/zlib
- app-arch/unzip
- >=x11-libs/gtk+-2
+DEPEND=">=x11-libs/gtk+-2
gnome-base/libglade"
-RDEPEND="games-emulation/psemu-cdr
+RDEPEND="${DEPEND}
+ games-emulation/psemu-cdr
games-emulation/psemu-cdriso
games-emulation/psemu-padxwin
games-emulation/psemu-padjoy
games-emulation/psemu-peopsspu
- || (
- opengl? ( x86? ( games-emulation/psemu-gpupetemesagl ) )
- games-emulation/psemu-peopssoftgpu
- )"
+ opengl? ( games-emulation/psemu-gpupetemesagl )
+ !opengl? ( games-emulation/psemu-peopssoftgpu )"
+
+S=${WORKDIR}/PcsxSrc-${PV}
src_unpack() {
- unpack PcsxSrc-${PV}.tgz
+ unpack ${A}
cd "${S}"
- edos2unix `find -regex '.*\.[ch]'`
+ edos2unix $(find -regex '.*\.[ch]')
- epatch "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}/${P}"-gcc41.patch
+ epatch \
+ "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc41.patch
sed -i \
-e "s:Plugin/:${GAMES_LIBDIR}/psemu/plugins/:" \
-e "s:Bios/:${GAMES_LIBDIR}/psemu/bios/:" \
-e 's:Pcsx.cfg:~/.pcsx/config:' \
Linux/LnxMain.c \
|| die "sed LnxMain.c failed"
- if [ "${ARCH}" = "ppc" ]; then
- sed -i \
- -e "s:^CPU\ =.*:CPU = powerpc:" Linux/Makefile \
- || die "sed Linux/Makefile failed"
- sed -i \
- -e "s:__LINUX__:__i386__:g" Gte.c \
- || die "sed Gte.c failed"
- fi
+ sed \
+ -e "s:GAMES_DATADIR:${GAMES_DATADIR}:" \
+ -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ "${FILESDIR}"/pcsx > "${T}"/pcsx \
+ || die "sed failed"
}
src_compile() {
cd Linux
- econf || die "econf failed"
+ egamesconf || die
emake OPTIMIZE="${CFLAGS}" STRIP=true || die "emake failed"
}
src_install() {
- newgamesbin Linux/pcsx pcsx.bin
- dogamesbin "${FILESDIR}"/pcsx
+ newgamesbin Linux/pcsx pcsx.bin || die "newgamesbin failed"
+ dogamesbin "${T}"/pcsx || die "dogamesbin failed"
insinto "${GAMES_DATADIR}"/${PN}
- doins Linux/.pixmaps/*
+ doins Linux/.pixmaps/* || die "doins failed"
dodoc Docs/*
prepgamesdirs
}