summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-15 12:10:36 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-15 12:10:36 +0000
commit05e6a8a7958340ebc32eae99e95c4f59f019dde6 (patch)
tree6f9c956e5a1e0fb3c33d59abbb97d129383bea46 /games-emulation/mupen64plus-rsp-hle
parentIntroduce the SDL input plugin for mupen64plus-2.0. (diff)
downloadgentoo-2-05e6a8a7958340ebc32eae99e95c4f59f019dde6.tar.gz
gentoo-2-05e6a8a7958340ebc32eae99e95c4f59f019dde6.tar.bz2
gentoo-2-05e6a8a7958340ebc32eae99e95c4f59f019dde6.zip
Introduce the HLE RSP plugin for mupen64plus-2.0.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation/mupen64plus-rsp-hle')
-rw-r--r--games-emulation/mupen64plus-rsp-hle/ChangeLog9
-rw-r--r--games-emulation/mupen64plus-rsp-hle/metadata.xml13
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild64
3 files changed, 86 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-rsp-hle/ChangeLog b/games-emulation/mupen64plus-rsp-hle/ChangeLog
new file mode 100644
index 000000000000..ebd5682c5f01
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-emulation/mupen64plus-rsp-hle
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-rsp-hle/ChangeLog,v 1.1 2013/12/15 12:10:36 mgorny Exp $
+
+*mupen64plus-rsp-hle-2.0 (15 Dec 2013)
+
+ 15 Dec 2013; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +mupen64plus-rsp-hle-2.0.ebuild:
+ Introduce the HLE RSP plugin for mupen64plus-2.0.
diff --git a/games-emulation/mupen64plus-rsp-hle/metadata.xml b/games-emulation/mupen64plus-rsp-hle/metadata.xml
new file mode 100644
index 000000000000..9047711e4ffd
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer>
+ <email>joker@gentoo.org</email>
+ <name>Christian Birchinger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild
new file mode 100644
index 000000000000..3e37ee4cb76a
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild,v 1.1 2013/12/15 12:10:36 mgorny Exp $
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
+HOMEPAGE="http://code.google.com/p/mupen64plus/"
+SRC_URI="mirror://bitbucket/richard42/${PN}/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="games-emulation/mupen64plus-core:0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR="$(games_get_libdir)"
+ PLUGINDIR="$(games_get_libdir)"/mupen64plus
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+ prepgamesdirs
+}