summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-04 08:11:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-04 08:11:39 +0000
commit253e7c34abe3bb0a86993312a218d5e9b7bbfc43 (patch)
tree16a09e1ae82ddf86f00de894ba0524271836a1d8 /games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild
parentUpdate multilib stable mask (diff)
downloadgentoo-2-253e7c34abe3bb0a86993312a218d5e9b7bbfc43.tar.gz
gentoo-2-253e7c34abe3bb0a86993312a218d5e9b7bbfc43.tar.bz2
gentoo-2-253e7c34abe3bb0a86993312a218d5e9b7bbfc43.zip
EAPI=5; simplify; add include patch to clean up build a bit
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..f6d447a4933a
--- /dev/null
+++ b/games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3-r1.ebuild,v 1.1 2014/07/04 08:11:39 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Gameboy emulator with multiple renderers"
+HOMEPAGE="http://code.google.com/p/gnuboy/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X sdl"
+
+RDEPEND="sdl? ( media-libs/libsdl )
+ !X? ( media-libs/libsdl )
+ X? ( x11-libs/libXext )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xextproto
+ x11-proto/xproto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-exec-stack.patch \
+ "${FILESDIR}"/${P}-linux-headers.patch \
+ "${FILESDIR}"/${P}-include.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if ! use X ; then
+ myconf="--with-sdl"
+ fi
+
+ egamesconf \
+ $(use_with X x) \
+ $(use_with sdl) \
+ $(use_enable x86 asm) \
+ ${myconf} \
+ --disable-arch \
+ --disable-optimize
+}
+
+src_install() {
+ for f in sdlgnuboy xgnuboy
+ do
+ if [[ -f ${f} ]] ; then
+ dogamesbin ${f}
+ fi
+ done
+ dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}
+ prepgamesdirs
+}