summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2014-01-25 04:40:29 +0000
committerDevan Franchini <twitch153@gentoo.org>2014-01-25 04:40:29 +0000
commitb5056fad985b5113ab071d9f2e0bec0c123507b6 (patch)
treeba44ff08c52dbf9ea4ef3fc81bba3fa48e039075 /games-emulation/dolphin/dolphin-9999.ebuild
parentVersion bump to 1.53 (diff)
downloadgentoo-2-b5056fad985b5113ab071d9f2e0bec0c123507b6.tar.gz
gentoo-2-b5056fad985b5113ab071d9f2e0bec0c123507b6.tar.bz2
gentoo-2-b5056fad985b5113ab071d9f2e0bec0c123507b6.zip
Saves external GL folder from removal
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index f86587a3730b..64b51750eabe 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.9 2014/01/24 17:23:50 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.10 2014/01/25 04:40:29 twitch153 Exp $
EAPI=5
@@ -90,13 +90,16 @@ src_prepare() {
# Remove ALL the bundled libraries, aside from:
# - SOIL: The sources are not public.
# - Bochs-disasm: Don't know what it is.
+ # - GL: A custom gl.h file is used.
mv Externals/SOIL . || die
mv Externals/Bochs_disasm . || die
mv Externals/polarssl . || die
+ mv Externals/GL . || die
rm -r Externals/* || die "Failed to delete Externals dir."
mv Bochs_disasm Externals || die
mv SOIL Externals || die
mv polarssl Externals || die
+ mv GL Externals || die
}
src_configure() {