summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2013-08-26 04:25:00 +0000
committerDevan Franchini <twitch153@gentoo.org>2013-08-26 04:25:00 +0000
commit020db97fa2a8d947aa6b651aa712f62ea7444abc (patch)
treeeb095011d54792525df06861b75f268a0ab42363 /games-emulation/dolphin/dolphin-9999.ebuild
parentdev-haskell/asn1-types: 0.2.0 (diff)
downloadgentoo-2-020db97fa2a8d947aa6b651aa712f62ea7444abc.tar.gz
gentoo-2-020db97fa2a8d947aa6b651aa712f62ea7444abc.tar.bz2
gentoo-2-020db97fa2a8d947aa6b651aa712f62ea7444abc.zip
New ebuild and live ebuild for dolphin emulator. Written by myself. Fixes bug #281543
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild129
1 files changed, 129 insertions, 0 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
new file mode 100644
index 000000000000..21e9911f70d6
--- /dev/null
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.1 2013/08/26 04:24:59 twitch153 Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.9"
+
+inherit cmake-utils eutils pax-utils toolchain-funcs versionator wxwidgets games
+
+if [[ ${PV} == 9999* ]]
+then
+ EGIT_REPO_URI="https://code.google.com/p/dolphin-emu/"
+ inherit git-2
+ KEYWORKD=""
+else
+ SRC_URI="http://${PN}-emu.googlecode.com/files/${P}-src.zip"
+ KEYWORDS="~amd"
+fi
+
+DESCRIPTION="Dolphin is a Gamecube and Wii game emulator"
+HOMEPAGE="http://www.dolphin-emulator.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa ao bluetooth doc ffmpeg +lzo openal opengl openmp portaudio pulseaudio"
+
+RDEPEND=">=media-libs/glew-1.6
+ >=media-libs/libsdl-1.2[joystick]
+ <media-libs/libsfml-2.0
+ >=net-libs/miniupnpc-1.8
+ sys-libs/readline
+ x11-libs/libXext
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ bluetooth? ( net-wireless/bluez )
+ ffmpeg? ( virtual/ffmpeg )
+ lzo? ( dev-libs/lzo )
+ openal? ( media-libs/openal )
+ opengl? ( virtual/opengl )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ "
+DEPEND="${RDEPEND}
+ app-arch/zip
+ media-gfx/nvidia-cg-toolkit
+ media-libs/freetype
+ media-libs/libsoundtouch
+ >=sys-devel/gcc-4.6.0
+ x11-libs/wxGTK:2.9
+ "
+
+src_prepare() {
+
+ version_is_at_least 4.6.0 $(gcc-fullversion) || die "${PN} needs >=gcc-4.6.0 set to compile."
+
+ # Remove automatic dependencies to prevent building without flags enabled.
+ if use !alsa; then
+ sed -i -e '^/include(FindALSA/d' CMakeLists.txt || die
+ fi
+ if use !ao; then
+ sed -i -e '/^check_lib(AO/d' CMakeLists.txt || die
+ fi
+ if use !bluetooth; then
+ sed -i -e '/^check_lib(BLUEZ/d' CMakeLists.txt || die
+ fi
+ if use !openal; then
+ sed -i -e '/^include(FindOpenAL/d' CMakeLists.txt || die
+ fi
+ if use !portaudio; then
+ sed -i -e '/CMAKE_REQUIRED_LIBRARIES portaudio/d' CMakeLists.txt || die
+ fi
+ if use !pulseaudio; then
+ sed -i -e '/^check_lib(PULSEAUDIO/d' CMakeLists.txt || die
+ fi
+
+ # Remove ALL the bundled libraries, aside from:
+ # - SOIL: The sources are not public.
+ # - Bochs-disasm: Don't know what it is.
+ # - CLRun: Part of OpenCL
+ mv Externals/SOIL . || die
+ mv Externals/Bochs_disasm . || die
+ mv Externals/CLRun . || die
+ rm -r Externals/* || die
+ mv CLRun Externals || die
+ mv Bochs_disasm Externals || die
+ mv SOIL Externals || die
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ "-DDOLPHIN_WC_REVISION=${PV}"
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-Dprefix=${GAMES_PREFIX}"
+ "-Ddatadir=${GAMES_DATADIR}/${PN}"
+ "-Dplugindir=$(games_get_libdir)/${PN}"
+ $( cmake-utils_use ffmpeg ENCODE_FRAMEDUMPS )
+ $( cmake-utils_use openmp OPENMP )
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+
+ cmake-utils_src_install
+
+ dodoc Readme.txt
+ if use doc; then
+ doins -r doc
+ fi
+
+ doicon Source/Core/DolphinWX/resources/Dolphin.xpm
+ make_desktop_entry "dolphin-emu" "Dolphin" "Dolphin" "Game;"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # Add pax markings for hardened systems
+ pax-mark -m "${EPREFIX}"/usr/games/bin/"${PN}"-emu
+
+ if ! use portaudio; then
+ ewarn "If you want microphone capabilities in dolphin-emu, rebuild with"
+ ewarn "USE=\"portaudio\""
+ fi
+}