summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-13 01:26:04 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-13 01:26:04 +0000
commit6a2307a00224e8a73f6f89deb46021d7b7e20ff1 (patch)
tree7cacd85ce71a7828227e44d98d80cd8a01f2bda9 /games-emulation/advancemame
parentDon't use `which`, use `type -P`. (diff)
downloadgentoo-2-6a2307a00224e8a73f6f89deb46021d7b7e20ff1.tar.gz
gentoo-2-6a2307a00224e8a73f6f89deb46021d7b7e20ff1.tar.bz2
gentoo-2-6a2307a00224e8a73f6f89deb46021d7b7e20ff1.zip
Change which to type -P for QA.
(Portage version: 2.1.2.1)
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog6
-rw-r--r--games-emulation/advancemame/advancemame-0.104.0.ebuild8
-rw-r--r--games-emulation/advancemame/advancemame-0.106.0.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 90606f04f858..05646a314b8e 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.42 2007/03/07 16:28:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.43 2007/03/13 01:26:04 wolf31o2 Exp $
+
+ 13 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ advancemame-0.104.0.ebuild, advancemame-0.106.0.ebuild:
+ Change which to type -P for QA.
07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
advancemame-0.104.0.ebuild, advancemame-0.106.0.ebuild:
diff --git a/games-emulation/advancemame/advancemame-0.104.0.ebuild b/games-emulation/advancemame/advancemame-0.104.0.ebuild
index a408ec6f42f8..6933dace2bee 100644
--- a/games-emulation/advancemame/advancemame-0.104.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.104.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.104.0.ebuild,v 1.3 2007/03/07 16:28:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.104.0.ebuild,v 1.4 2007/03/13 01:26:04 wolf31o2 Exp $
inherit eutils flag-o-matic games
@@ -32,11 +32,11 @@ src_unpack() {
#epatch "${FILESDIR}/${PV}-pic.patch" #74899
use x86 && \
- ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ ln -s $(type -P nasm) "${T}/${CHOST}-nasm"
use sdl && \
- ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ ln -s $(type -P sdl-config) "${T}/${CHOST}-sdl-config"
use truetype && \
- ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+ ln -s $(type -P freetype-config) "${T}/${CHOST}-freetype-config"
}
src_compile() {
diff --git a/games-emulation/advancemame/advancemame-0.106.0.ebuild b/games-emulation/advancemame/advancemame-0.106.0.ebuild
index 92f2f0892dd8..e30af05e89d1 100644
--- a/games-emulation/advancemame/advancemame-0.106.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.106.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.3 2007/03/07 16:28:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.4 2007/03/13 01:26:04 wolf31o2 Exp $
inherit eutils flag-o-matic games
@@ -37,11 +37,11 @@ src_unpack() {
|| die "sed failed"
use x86 && \
- ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ ln -s $(type -P nasm) "${T}/${CHOST}-nasm"
use sdl && \
- ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ ln -s $(type -P sdl-config) "${T}/${CHOST}-sdl-config"
use truetype && \
- ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+ ln -s $(type -P freetype-config) "${T}/${CHOST}-freetype-config"
}
src_compile() {