summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-12-19 23:24:03 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-12-19 23:24:03 +0000
commit7793e82b6e1b0b9c1cd59d28e9762f71a766c0b7 (patch)
treeb2c9f5fb151d87b8d3bc2ff0384fce68c4c8ccf0 /games-board
parentalpha stable, bug 467186. (diff)
downloadgentoo-2-7793e82b6e1b0b9c1cd59d28e9762f71a766c0b7.tar.gz
gentoo-2-7793e82b6e1b0b9c1cd59d28e9762f71a766c0b7.tar.bz2
gentoo-2-7793e82b6e1b0b9c1cd59d28e9762f71a766c0b7.zip
respect system CFLAGS/LDFLAGS
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pioneers/ChangeLog6
-rw-r--r--games-board/pioneers/files/pioneers-15.1-build.patch36
-rw-r--r--games-board/pioneers/pioneers-15.1.ebuild3
3 files changed, 33 insertions, 12 deletions
diff --git a/games-board/pioneers/ChangeLog b/games-board/pioneers/ChangeLog
index 88d8393cfc51..aac465442179 100644
--- a/games-board/pioneers/ChangeLog
+++ b/games-board/pioneers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pioneers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.31 2013/12/19 22:05:19 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.32 2013/12/19 23:24:03 hasufell Exp $
+
+ 19 Dec 2013; Julian Ospald <hasufell@gentoo.org>
+ files/pioneers-15.1-build.patch, pioneers-15.1.ebuild:
+ respect system CFLAGS/LDFLAGS
*pioneers-15.1 (19 Dec 2013)
diff --git a/games-board/pioneers/files/pioneers-15.1-build.patch b/games-board/pioneers/files/pioneers-15.1-build.patch
index eab138595a50..fa3590ff413f 100644
--- a/games-board/pioneers/files/pioneers-15.1-build.patch
+++ b/games-board/pioneers/files/pioneers-15.1-build.patch
@@ -2,14 +2,24 @@ From: Julian Ospald <hasufell@gentoo.org>
Date: Thu Dec 19 21:30:53 UTC 2013
* add --with-help switch
+* add --enable-minimal-flags switch
* don't use AM_CFLAGS in configure.ac, it is bad form
--- a/configure.ac
+++ b/configure.ac
-@@ -129,12 +129,21 @@
+@@ -129,21 +129,40 @@
*) pioneers_deprecationChecks=no ;;
esac])
++AC_ARG_ENABLE([minimal-flags],
++ AS_HELP_STRING([--enable-minimal-flags],
++ ["Don't add unneeded flags."]),
++[case "${enableval}" in
++ yes) minimal_flags=yes ;;
++ "") minimal_flags=no ;;
++ *) minimal_flags=no ;;
++esac])
++
+AC_ARG_WITH([help],
+ AS_HELP_STRING([--with-help],
+ [Enable gnome help via scrollkeeper.]),
@@ -19,33 +29,39 @@ Date: Thu Dec 19 21:30:53 UTC 2013
+ *) with_help=no ;;
+esac])
+
++
## The warnings are in the same order as in 'man gcc'
- if test "x$GCC" = xyes; then
+-if test "x$GCC" = xyes; then
++if test "x$GCC" = xyes && test "x$minimal_flags" != xyes; then
# Flags from Debian hardening (dpkg-buildflags --get CFLAGS)
- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security"])
- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -D_FORTIFY_SOURCE=2"])
- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -pie -fPIE"])
-+ AC_SUBST(CFLAGS, ["$CFLAGS -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security"])
-+ AC_SUBST(CFLAGS, ["$CFLAGS -D_FORTIFY_SOURCE=2"])
-+ AC_SUBST(CFLAGS, ["$CFLAGS -pie -fPIE"])
++ CFLAGS="$CFLAGS -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security"
++ CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
++ CFLAGS="$CFLAGS -pie -fPIE"
if test "$pioneers_is_windows_port" = "no"; then
# Flags from Debian hardening (dpkg-buildflags --get LDFLAGS)
-@@ -143,7 +152,7 @@
+- AC_SUBST(AM_LDFLAGS, ["$AM_LDFLAGS -Wl,-z,relro"])
+- AC_SUBST(AM_LDFLAGS, ["$AM_LDFLAGS -Wl,-z,now"])
++ LDFLAGS="$LDFLAGS -Wl,-z,relro"
++ LDFLAGS="$LDFLAGS -Wl,-z,now"
fi
- # Only link the directly needed libraries
+- # Only link the directly needed libraries
- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -Wl,--as-needed"])
-+ AC_SUBST(CFLAGS, ["$CFLAGS -Wl,--as-needed"])
++ # Only link the directly needed libraries
++ LDFLAGS="$LDFLAGS -Wl,--as-needed"
if test "$pioneers_warnings" = yes -o "$pioneers_warnings" = full; then
AC_SUBST(WARNINGS, "-Wall")
-@@ -385,7 +394,7 @@
+@@ -385,7 +404,7 @@
AM_GLIB_GNU_GETTEXT
if test $pioneers_is_mingw_port = yes; then
- AC_SUBST(AM_CFLAGS, "-mms-bitfields $AM_CFLAGS")
-+ AC_SUBST(CFLAGS, "-mms-bitfields $CFLAGS")
++ CFLAGS="-mms-bitfields $CFLAGS"
# No console window for the graphical applications
AC_SUBST(GTK2_LIBS, "$GTK2_LIBS -mwindows")
# Don't use bin, lib and share subdirectories
diff --git a/games-board/pioneers/pioneers-15.1.ebuild b/games-board/pioneers/pioneers-15.1.ebuild
index 7162d9d9ccd7..0eea195cd842 100644
--- a/games-board/pioneers/pioneers-15.1.ebuild
+++ b/games-board/pioneers/pioneers-15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/pioneers-15.1.ebuild,v 1.1 2013/12/19 22:05:19 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/pioneers-15.1.ebuild,v 1.2 2013/12/19 23:24:03 hasufell Exp $
EAPI=5
inherit autotools eutils gnome-games
@@ -37,6 +37,7 @@ src_prepare() {
src_configure() {
gnome-games_src_configure \
$(use_enable nls) \
+ --enable-minimal-flags \
$(use_with help)
}