summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-07 16:47:16 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-07 16:47:16 +0000
commit656b8cd532014535e803f068914954fa0083716c (patch)
tree1015f444d6116990207e95293b807889a7902b70 /games-board/pouetchess
parentlicense change, bug 150118 (diff)
downloadgentoo-2-656b8cd532014535e803f068914954fa0083716c.tar.gz
gentoo-2-656b8cd532014535e803f068914954fa0083716c.tar.bz2
gentoo-2-656b8cd532014535e803f068914954fa0083716c.zip
Don't use MAKEOPTS with scons
(Portage version: 2.1.2.1)
Diffstat (limited to 'games-board/pouetchess')
-rw-r--r--games-board/pouetchess/ChangeLog8
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch31
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0.ebuild45
3 files changed, 49 insertions, 35 deletions
diff --git a/games-board/pouetchess/ChangeLog b/games-board/pouetchess/ChangeLog
index 755a7aa2cf58..f335e9e8bf30 100644
--- a/games-board/pouetchess/ChangeLog
+++ b/games-board/pouetchess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pouetchess
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/ChangeLog,v 1.3 2006/12/01 20:58:52 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/ChangeLog,v 1.4 2007/03/07 16:47:16 nyhm Exp $
+
+ 07 Mar 2007; Tristan Heaven <nyhm@gentoo.org>
+ files/pouetchess-0.2.0-sconstruct-sandbox.patch, pouetchess-0.2.0.ebuild:
+ Don't use MAKEOPTS with scons
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
pouetchess-0.2.0.ebuild:
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch b/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch
index 99149b7f6a7f..c33c9164787c 100644
--- a/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-sconstruct-sandbox.patch
@@ -1,11 +1,30 @@
---- SConstruct 2006-05-27 03:44:34.000000000 +0200
-+++ SConstruct 2006-06-01 13:12:54.000000000 +0200
-@@ -28,6 +28,8 @@
+--- SConstruct
++++ SConstruct
+@@ -22,14 +22,25 @@
+
+
+
+-import os,glob
++import os,glob,SCons.Util
+
+
++# http://dev.gentoo.org/~vapier/scons-blows.txt
# create build environment
-+env = Environment()
-+env.SConsignFile()
env = Environment(tools = ['default', 'pouetChess'], toolpath = ['.'])
- env.AppendUnique(CXXFLAGS = ['-Wall'])
+-env.AppendUnique(CXXFLAGS = ['-Wall'])
++env.SConsignFile()
++
++env['CC'] = os.environ['CC']
++env['CXX'] = os.environ['CXX']
++
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] = SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] = SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] = SCons.Util.CLVar(os.environ['LDFLAGS'])
+ # gather a list of source files
+ SOURCES = glob.glob('src/*.cpp')
diff --git a/games-board/pouetchess/pouetchess-0.2.0.ebuild b/games-board/pouetchess/pouetchess-0.2.0.ebuild
index 54dd7284d163..0a10b7507776 100644
--- a/games-board/pouetchess/pouetchess-0.2.0.ebuild
+++ b/games-board/pouetchess/pouetchess-0.2.0.ebuild
@@ -1,27 +1,22 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0.ebuild,v 1.2 2006/12/01 20:58:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0.ebuild,v 1.3 2007/03/07 16:47:16 nyhm Exp $
-inherit eutils games
+inherit eutils toolchain-funcs games
MY_PN=${PN/c/C}
DESCRIPTION="3D and open source chess game"
HOMEPAGE="http://pouetchess.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pouetchess/${PN}_src_${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_src_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE="debug"
-RDEPEND=">=media-libs/libsdl-1.2.8
+RDEPEND="media-libs/libsdl
media-libs/sdl-image
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext"
-
+ virtual/opengl"
DEPEND="${RDEPEND}
dev-util/scons"
@@ -39,9 +34,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- # modify SConstruct file like seen on
- # http://permalink.gmane.org/gmane.comp.audio.csound.devel/6646
- # Fix up nvidia headers
epatch \
"${FILESDIR}"/${P}-sconstruct-sandbox.patch \
"${FILESDIR}"/${P}-nvidia_glext.patch
@@ -51,30 +43,29 @@ src_unpack() {
-e "s:sdlver.split('.') >= \['1','2','8'\]:sdlver.split('.') >= [1,2,8]:" \
pouetChess.py \
|| die "sed failed"
- sed -i \
- -e "/strip/d" \
- SConstruct \
- || die "sed failed"
}
src_compile() {
- local myconf="prefix=${GAMES_PREFIX} datadir=${GAMES_DATADIR}/${PN}"
- use debug && myconf="${myconf} debug=1 strip=false"
-
- scons configure ${myconf} || die "scons configure failed"
- scons ${MAKEOPTS} || die "scons make failed"
+ tc-export CC CXX
+ scons configure \
+ strip=false \
+ prefix="${GAMES_PREFIX}" \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use debug && echo debug=1) \
+ || die "scons configure failed"
+ scons || die "scons failed"
}
src_install() {
- dogamesbin bin/"${MY_PN}" || die "dogamesbin failed"
+ dogamesbin bin/${MY_PN} || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data/* || die "installing data failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
dodoc ChangeLog README
doicon data/icons/${MY_PN}.png
- make_desktop_entry ${MY_PN} "pouetChess" ${MY_PN}.png "KDE;Qt;Game;BoardGame"
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}.png "KDE;Qt;Game;BoardGame"
prepgamesdirs
}