summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-03-30 17:21:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-03-30 17:21:49 +0000
commitc50fc90f91dac4054b24302d1d96df3f1c198f88 (patch)
treeba50d35dda19736473a1133344cd69b58d38cc8b /games-board/gnuchess-book/gnuchess-book-1.01.ebuild
parentstable x86, bug 172740 (diff)
downloadgentoo-2-c50fc90f91dac4054b24302d1d96df3f1c198f88.tar.gz
gentoo-2-c50fc90f91dac4054b24302d1d96df3f1c198f88.tar.bz2
gentoo-2-c50fc90f91dac4054b24302d1d96df3f1c198f88.zip
version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-board/gnuchess-book/gnuchess-book-1.01.ebuild')
-rw-r--r--games-board/gnuchess-book/gnuchess-book-1.01.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-board/gnuchess-book/gnuchess-book-1.01.ebuild b/games-board/gnuchess-book/gnuchess-book-1.01.ebuild
new file mode 100644
index 000000000000..643bed2b377d
--- /dev/null
+++ b/games-board/gnuchess-book/gnuchess-book-1.01.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnuchess-book/gnuchess-book-1.01.ebuild,v 1.1 2007/03/30 17:21:49 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Opening book for gnuchess"
+HOMEPAGE="http://www.gnu.org/software/chess/chess.html"
+SRC_URI="mirror://gnu/chess/book_${PV}.pgn.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc ppc64 sparc x86"
+IUSE=""
+RESTRICT="userpriv" # bug #112898
+
+DEPEND="games-board/gnuchess"
+
+S=${WORKDIR}
+
+src_compile() {
+ echo -e "book add book_${PV}.pgn"$'\n'"quit" | "${GAMES_BINDIR}"/gnuchess \
+ || die "generation failed"
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/gnuchess"
+ doins book.dat || die "doins failed"
+ prepgamesdirs
+}