summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-29 10:27:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-29 10:27:12 +0000
commite3e5b75c43099485e1ff10c7b477bd2c2c462a56 (patch)
tree45e495003a64569edad96b9fa1baf5130c99d784 /games-board/gnubg
parentold (diff)
downloadgentoo-2-e3e5b75c43099485e1ff10c7b477bd2c2c462a56.tar.gz
gentoo-2-e3e5b75c43099485e1ff10c7b477bd2c2c462a56.tar.bz2
gentoo-2-e3e5b75c43099485e1ff10c7b477bd2c2c462a56.zip
touchups
Diffstat (limited to 'games-board/gnubg')
-rw-r--r--games-board/gnubg/files/digest-gnubg-0.13.03
-rw-r--r--games-board/gnubg/gnubg-0.13.0-r1.ebuild17
-rw-r--r--games-board/gnubg/gnubg-0.13.0.ebuild71
3 files changed, 8 insertions, 83 deletions
diff --git a/games-board/gnubg/files/digest-gnubg-0.13.0 b/games-board/gnubg/files/digest-gnubg-0.13.0
deleted file mode 100644
index e21082abc05d..000000000000
--- a/games-board/gnubg/files/digest-gnubg-0.13.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 91db5727b6589dbfd410e6ce1683fa95 gnubg-0.13.0.tar.gz 2232531
-MD5 82d1eab50ef604c41dced139afb469ba gnubg.weights-0.13.gz 470118
-MD5 e247fbc2d2ac370ccad29489e8be9181 gnubg.bd.gz 2427893
diff --git a/games-board/gnubg/gnubg-0.13.0-r1.ebuild b/games-board/gnubg/gnubg-0.13.0-r1.ebuild
index f397848a0143..eccc2227672b 100644
--- a/games-board/gnubg/gnubg-0.13.0-r1.ebuild
+++ b/games-board/gnubg/gnubg-0.13.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.13.0-r1.ebuild,v 1.2 2003/09/30 07:23:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.13.0-r1.ebuild,v 1.3 2004/02/29 10:22:52 vapier Exp $
inherit games
@@ -19,9 +19,8 @@ IUSE="gtk gtk2 readline guile X gdbm truetype nls png esd arts nas"
# FIXME does this need to DEPEND on netpbm?
RDEPEND="guile? ( dev-util/guile )
truetype? ( =media-libs/freetype-1* )
- || (
- gtk2? ( =x11-libs/gtk+-2* =dev-libs/glib-2* )
- gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1* )
+ gtk? (
+ gtk2? ( =x11-libs/gtk+-2* =dev-libs/glib-2* ) : ( =x11-libs/gtk+-1.2* =dev-libs/glib-1* )
)
readline? ( sys-libs/readline )
X? ( virtual/x11 )
@@ -48,15 +47,15 @@ src_unpack() {
src_compile() {
local myconf=""
- if [ -n "`use gtk`" -o -n "`use gtk2`" ] ; then
+ if use gtk ; then
# doesn't make any sense to add this without gtk or gtk2
- if [ -n "`best_version x11-libs/gtk+extra`" ] ; then
+ if has_version x11-libs/gtk+extra ; then
myconf="--with-gtkextra"
else
myconf="--without-gtkextra"
fi
# --with-gtk doesn't mean what you think it means for configuring gnubg.
- if [ `use gtk2` ] ; then
+ if use gtk2 ; then
myconf="${myconf} --with-gtk --with-gtk2"
else
myconf="${myconf} --with-gtk --without-gtk2"
@@ -64,7 +63,7 @@ src_compile() {
else
myconf="${myconf} --disable-gtktest"
fi
- if [ -n "`use esd`" -o -n "`use arts`" -o -n "`use nas`" ] ; then
+ if use esd || use arts ; then
myconf="${myconf} --with-sound"
else
myconf="${myconf} --without-sound --disable-esdtest --disable-artsc-test"
diff --git a/games-board/gnubg/gnubg-0.13.0.ebuild b/games-board/gnubg/gnubg-0.13.0.ebuild
deleted file mode 100644
index 50bd462d52ae..000000000000
--- a/games-board/gnubg/gnubg-0.13.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.13.0.ebuild,v 1.2 2003/09/12 06:18:06 vapier Exp $
-
-inherit games
-
-WPV=0.13
-DESCRIPTION="GNU BackGammon"
-HOMEPAGE="http://www.gnu.org/software/gnubg/gnubg.html"
-SRC_URI="ftp://alpha.gnu.org/gnu/gnubg/${P}.tar.gz
- ftp://alpha.gnu.org/gnu/gnubg/${PN}.weights-${WPV}.gz
- ftp://alpha.gnu.org/gnu/gnubg/${PN}.bd.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="gtk gtk2 readline guile X gdbm truetype nls png"
-
-DEPEND="guile? ( dev-util/guile )
- truetype? ( =media-libs/freetype-1* )
- || (
- gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1* )
- gtk2? ( =x11-libs/gtk+-2* =dev-libs/glib-2* )
- )
- readline? ( sys-libs/readline )
- X? ( virtual/x11 )
- gdbm? ( sys-libs/gdbm )
- png? ( media-libs/libpng )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- mv ../${PN}.weights-${WPV} ${S}/${PN}.weights
- mv ../${PN}.bd ${S}
-}
-
-src_compile() {
- local myconf=""
- [ -n "`best_version x11-libs/gtk+extra`" ] && myconf="--with-gtkextra"
- if [ `use esd` ] ; then
- myconf="${myconf} --with-sound --enable-esd"
- elif [ `use arts` ] ; then
- myconf="${myconf} --with-sound --enable-artsc"
- elif [ `use nas` ] ; then
- myconf="${myconf} --with-sound --enable-nas"
- else
- myconf="${myconf} --without-sound"
- fi
-
- #configure script doesnt hanlde this param properly
- # `use_with guile` \
- egamesconf \
- `use_with gtk` \
- `use_with gtk2` \
- `use_with readline` \
- `use_with X x` \
- `use_with gdbm` \
- `use_with truetype freetype` \
- `use_enable nls` \
- ${myconf} \
- || die
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- insinto ${GAMES_DATADIR}/${PN}
- doins ${PN}.weights
- dodoc AUTHORS README NEWS
- prepgamesdirs
-}