summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-06-21 07:00:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-06-21 07:00:38 +0000
commit71555c24adcfb06776e22ad01697c5f896a1e55c (patch)
tree479f86041979b5677ad29e4446961b49100baf61 /games-board/blokish
parentfortran-2.eclass added (diff)
downloadgentoo-2-71555c24adcfb06776e22ad01697c5f896a1e55c.tar.gz
gentoo-2-71555c24adcfb06776e22ad01697c5f896a1e55c.tar.bz2
gentoo-2-71555c24adcfb06776e22ad01697c5f896a1e55c.zip
Fix underlink. Bug #371607
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'games-board/blokish')
-rw-r--r--games-board/blokish/ChangeLog8
-rw-r--r--games-board/blokish/blokish-0.9.4-r1.ebuild12
-rw-r--r--games-board/blokish/files/blokish-0.9.4-underlink.patch9
3 files changed, 22 insertions, 7 deletions
diff --git a/games-board/blokish/ChangeLog b/games-board/blokish/ChangeLog
index 483c35d0dc0a..b4c044751783 100644
--- a/games-board/blokish/ChangeLog
+++ b/games-board/blokish/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/blokish
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.9 2009/01/04 19:33:23 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.10 2011/06/21 07:00:38 tupone Exp $
+
+ 21 Jun 2011; Tupone Alfredo <tupone@gentoo.org> blokish-0.9.4-r1.ebuild,
+ +files/blokish-0.9.4-underlink.patch:
+ Fix underlink. Bug #371607 by Diego Elio Pettenò
04 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
blokish-0.9.4-r1.ebuild:
diff --git a/games-board/blokish/blokish-0.9.4-r1.ebuild b/games-board/blokish/blokish-0.9.4-r1.ebuild
index ff30de834f61..38593ba4c4be 100644
--- a/games-board/blokish/blokish-0.9.4-r1.ebuild
+++ b/games-board/blokish/blokish-0.9.4-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4-r1.ebuild,v 1.6 2009/08/17 21:36:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4-r1.ebuild,v 1.7 2011/06/21 07:00:38 tupone Exp $
EAPI=2
WX_GTK_VER="2.8"
-inherit eutils wxwidgets games
+inherit eutils autotools wxwidgets games
MY_P="${PN}_v${PV}"
DESCRIPTION="Open source clone of the four-player board game Blokus"
@@ -22,11 +22,13 @@ DEPEND="x11-libs/wxGTK:2.8[X,opengl]
S=${WORKDIR}/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-underlink.patch
sed -i \
-e "s:wx-config:${WX_CONFIG}:" \
- configure makefile.in \
+ configure.in makefile.am \
|| die "sed failed"
+ eautoreconf
}
src_install() {
diff --git a/games-board/blokish/files/blokish-0.9.4-underlink.patch b/games-board/blokish/files/blokish-0.9.4-underlink.patch
new file mode 100644
index 000000000000..9a9eb6eab5a4
--- /dev/null
+++ b/games-board/blokish/files/blokish-0.9.4-underlink.patch
@@ -0,0 +1,9 @@
+--- makefile.am.old 2011-06-21 08:43:21.804880067 +0200
++++ makefile.am 2011-06-21 08:43:49.875661081 +0200
+@@ -1,5 +1,5 @@
+ INCLUDES = `wx-config --cxxflags`
+-LIBS = `wx-config --libs --gl-libs`
++LIBS = `wx-config --libs --gl-libs` -lGL -lm
+
+ bin_PROGRAMS = blokish
+