summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-05 21:47:20 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-05 21:47:20 +0000
commite58f5b03a9cc88b8a4c66ccbb9f0a7be69ebe777 (patch)
tree843b74395e056f80261b2edabe9332b08c039cd7 /games-arcade
parentStable on amd64 wrt bug #406853 (diff)
downloadgentoo-2-e58f5b03a9cc88b8a4c66ccbb9f0a7be69ebe777.tar.gz
gentoo-2-e58f5b03a9cc88b8a4c66ccbb9f0a7be69ebe777.tar.bz2
gentoo-2-e58f5b03a9cc88b8a4c66ccbb9f0a7be69ebe777.zip
Clean up ebuild.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/performous/ChangeLog6
-rw-r--r--games-arcade/performous/files/performous-0.6.1-linguas.patch15
-rw-r--r--games-arcade/performous/performous-0.6.1.ebuild36
3 files changed, 34 insertions, 23 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
index 7f7d18939592..9b3f2e1e1b65 100644
--- a/games-arcade/performous/ChangeLog
+++ b/games-arcade/performous/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/performous
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.3 2012/03/05 08:07:59 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.4 2012/03/05 21:47:20 vapier Exp $
+
+ 05 Mar 2012; Mike Frysinger <vapier@gentoo.org> performous-0.6.1.ebuild,
+ +files/performous-0.6.1-linguas.patch:
+ Clean up ebuild.
05 Mar 2012; Tupone Alfredo <tupone@gentoo.org> performous-0.6.1.ebuild:
Respect LINGUAS settings. Bug #406551 by Piotr Szymaniak
diff --git a/games-arcade/performous/files/performous-0.6.1-linguas.patch b/games-arcade/performous/files/performous-0.6.1-linguas.patch
new file mode 100644
index 000000000000..21836766d878
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-linguas.patch
@@ -0,0 +1,15 @@
+--- lang/CMakeLists.txt
++++ lang/CMakeLists.txt
+@@ -7,5 +7,11 @@
+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
+ add_custom_command(OUTPUT ${mofile} COMMAND ${Msgfmt_BIN} -v "${pofile}" -o ${mofile} MAIN_DEPENDENCY ${pofile} COMMENT "Building ${language} locale" VERBATIM)
+ add_custom_target(locale_${language} ALL DEPENDS ${mofile}) # Make sure the mofiles are always built
+- install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
+ endforeach(language)
++foreach(language $ENV{LINGUAS})
++ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
++ if (EXISTS ${pofile})
++ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
++ install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
++ endif()
++endforeach(language)
diff --git a/games-arcade/performous/performous-0.6.1.ebuild b/games-arcade/performous/performous-0.6.1.ebuild
index da0165fc165c..4b65d9a49f8b 100644
--- a/games-arcade/performous/performous-0.6.1.ebuild
+++ b/games-arcade/performous/performous-0.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.3 2012/03/05 08:07:59 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.4 2012/03/05 21:47:20 vapier Exp $
-EAPI=3
+EAPI="3"
inherit flag-o-matic base cmake-utils games
@@ -26,12 +26,8 @@ LICENSE="GPL-2
CCPL-Attribution-NonCommercial-NoDerivs-2.5
)"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="songs tools"
-LANGS="da de es fi fr hu it ja nl sv"
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
RDEPEND="dev-cpp/glibmm
dev-cpp/libxmlpp
@@ -56,33 +52,31 @@ DEPEND="${RDEPEND}
media-libs/glew
sys-apps/help2man"
-S="${WORKDIR}"/${MY_P}-Source
+S=${WORKDIR}/${MY_P}-Source
PATCHES=(
"${FILESDIR}"/${P}-ffmpeg.patch
"${FILESDIR}"/${P}-libpng.patch
"${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-linguas.patch
)
-append-cppflags -DBOOST_FILESYSTEM_VERSION=2
src_prepare() {
base_src_prepare
sed -i \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
game/CMakeLists.txt \
- || die "sed failed"
- cd lang
- for X in $LANGS
- do
- use linguas_$X || rm $X.po
- done
+ || die
+ append-cppflags -DBOOST_FILESYSTEM_VERSION=2
+
+ strip-linguas -u lang
}
src_configure() {
- local mycmakeargs="
+ local mycmakeargs=(
$(cmake-utils_use_enable tools TOOLS)
-DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
- "
+ )
cmake-utils_src_configure
}
@@ -92,12 +86,10 @@ src_compile() {
src_install() {
cmake-utils_src_install
- if use songs; then
+ if use songs ; then
insinto "${GAMES_DATADIR}"/${PN}
- doins -r "${S}/songs" || die "doins failed"
+ doins -r "${S}/songs" || die
fi
- cd docs
- dodoc {Authors,DeveloperReadme,instruments,TODO}.txt \
- || die "dodoc failed"
+ dodoc docs/{Authors,DeveloperReadme,instruments,TODO}.txt
prepgamesdirs
}