summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-31 18:34:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-31 18:34:46 +0000
commitcc60ec61bb9aa83607562936e37c5e5546bceca2 (patch)
treeb494fac267a4309e5cc04a167a6b7b4e74b165b6 /games-arcade
parentUpdate dependency after package move of eselect modules to app-eselect. (diff)
downloadgentoo-2-cc60ec61bb9aa83607562936e37c5e5546bceca2.tar.gz
gentoo-2-cc60ec61bb9aa83607562936e37c5e5546bceca2.tar.bz2
gentoo-2-cc60ec61bb9aa83607562936e37c5e5546bceca2.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/performous/ChangeLog12
-rw-r--r--games-arcade/performous/files/performous-1.0-gentoo.patch12
-rw-r--r--games-arcade/performous/files/performous-1.0-include.patch10
-rw-r--r--games-arcade/performous/files/performous-1.0-libav.patch19
-rw-r--r--games-arcade/performous/files/performous-1.0-linguas.patch18
-rw-r--r--games-arcade/performous/performous-1.0.ebuild113
6 files changed, 182 insertions, 2 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
index 181febdfe9e3..b148c182af5d 100644
--- a/games-arcade/performous/ChangeLog
+++ b/games-arcade/performous/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-arcade/performous
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.17 2014/07/14 12:54:24 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.18 2015/03/31 18:34:46 mr_bones_ Exp $
+
+*performous-1.0 (31 Mar 2015)
+
+ 31 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/performous-1.0-gentoo.patch, +files/performous-1.0-include.patch,
+ +files/performous-1.0-libav.patch, +files/performous-1.0-linguas.patch,
+ +performous-1.0.ebuild:
+ version bump
14 Jul 2014; Alfredo Tupone <tupone@gentoo.org> performous-0.7.0-r1.ebuild,
+files/performous-0.7.0-freetype.patch:
diff --git a/games-arcade/performous/files/performous-1.0-gentoo.patch b/games-arcade/performous/files/performous-1.0-gentoo.patch
new file mode 100644
index 000000000000..a73663a88c41
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ru performous-1.0.orig/game/CMakeLists.txt performous-1.0/game/CMakeLists.txt
+--- performous-1.0.orig/game/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
++++ performous-1.0/game/CMakeLists.txt 2015-03-31 03:01:30.806061643 -0400
+@@ -141,7 +141,7 @@
+ set(BIN_INSTALL .) # Straight to Program Files/Performous with no bin subfolder.
+ set(SUBSYSTEM_WIN32 WIN32)
+ else()
+- set(BIN_INSTALL bin)
++ set(BIN_INSTALL @GENTOO_BINDIR@)
+ endif()
+
+ # Build main executable
diff --git a/games-arcade/performous/files/performous-1.0-include.patch b/games-arcade/performous/files/performous-1.0-include.patch
new file mode 100644
index 000000000000..ba67018e5422
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-include.patch
@@ -0,0 +1,10 @@
+--- performous-1.0/game/song.hh.orig 2015-03-31 13:56:13.546360617 -0400
++++ performous-1.0/game/song.hh 2015-03-31 13:56:23.609025021 -0400
+@@ -3,6 +3,7 @@
+ #include "i18n.hh"
+ #include "notes.hh"
+ #include "util.hh"
++#include "fs.hh"
+ #include <boost/foreach.hpp>
+ #include <boost/noncopyable.hpp>
+ #include <stdexcept>
diff --git a/games-arcade/performous/files/performous-1.0-libav.patch b/games-arcade/performous/files/performous-1.0-libav.patch
new file mode 100644
index 000000000000..e3f36615281e
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-libav.patch
@@ -0,0 +1,19 @@
+diff -urN Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake
+--- Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:44:26.112930173 +0200
++++ Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:56:10.229914635 +0200
+@@ -25,9 +25,15 @@
+ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
+ set(AVUtil_INCLUDE "${suffix}avutil.h")
+ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
++ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
++ set(AVUtilMath_INCLUDE "${suffix}mathematics.h")
++ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
+ endif(NOT AVUtil_INCLUDE)
+ endforeach(suffix)
+
++ if(NOT AVUtilMath_INCLUDE)
++ message(FATAL_ERROR "Found mathematics.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
++ endif(NOT AVUtilMath_INCLUDE)
+ if(NOT AVUtil_INCLUDE)
+ message(FATAL_ERROR "Found avutil.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
+ endif(NOT AVUtil_INCLUDE)
diff --git a/games-arcade/performous/files/performous-1.0-linguas.patch b/games-arcade/performous/files/performous-1.0-linguas.patch
new file mode 100644
index 000000000000..f8f1349ea3b9
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-linguas.patch
@@ -0,0 +1,18 @@
+diff -ru performous-1.0.orig/lang/CMakeLists.txt performous-1.0/lang/CMakeLists.txt
+--- performous-1.0.orig/lang/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
++++ performous-1.0/lang/CMakeLists.txt 2015-02-22 04:25:40.502252942 -0500
+@@ -9,5 +9,13 @@
+ file(MAKE_DIRECTORY "${mobuild}")
+ add_custom_command(OUTPUT "${mofile}" COMMAND "${Msgfmt_BIN}" -v "${pofile}" -o "${mofile}" MAIN_DEPENDENCY "${pofile}" COMMENT "Building ${language} locale" VERBATIM)
+ add_custom_target("locale_${language}" ALL DEPENDS "${mofile}") # Make sure the mofiles are always built
+- install(FILES "${mofile}" DESTINATION "${LOCALE_DIR}/${language}/LC_MESSAGES")
+ endforeach(language)
++foreach(language $ENV{LINGUAS})
++ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
++ if (EXISTS ${pofile})
++ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
++ install(FILES ${mofile} DESTINATION
++{LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
++ endif()
++endforeach(language)
++
diff --git a/games-arcade/performous/performous-1.0.ebuild b/games-arcade/performous/performous-1.0.ebuild
new file mode 100644
index 000000000000..5727ea96748c
--- /dev/null
+++ b/games-arcade/performous/performous-1.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-1.0.ebuild,v 1.1 2015/03/31 18:34:46 mr_bones_ Exp $
+
+EAPI=5
+CMAKE_REMOVE_MODULES="yes"
+CMAKE_REMOVE_MODULES_LIST="FindALSA FindBoost FindFreetype FindGettext FindJpeg FindPng FindTiff FindZ"
+inherit eutils cmake-utils gnome2-utils games
+
+MY_PN=Performous
+MY_P=${MY_PN}-${PV}
+SONGS_PN=ultrastar-songs
+
+DESCRIPTION="SingStar GPL clone"
+HOMEPAGE="http://sourceforge.net/projects/performous/"
+SRC_URI="https://github.com/performous/performous/archive/1.0.tar.gz -> ${P}.tar.gz
+ songs? (
+ mirror://sourceforge/performous/${SONGS_PN}-restricted-3.zip
+ mirror://sourceforge/performous/${SONGS_PN}-jc-1.zip
+ mirror://sourceforge/performous/${SONGS_PN}-libre-3.zip
+ mirror://sourceforge/performous/${SONGS_PN}-shearer-1.zip
+ )"
+
+LICENSE="GPL-2
+ songs? (
+ CC-BY-NC-SA-2.5
+ CC-BY-NC-ND-2.5
+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="midi songs tools webcam"
+
+RDEPEND="dev-cpp/glibmm
+ dev-cpp/libxmlpp
+ media-libs/portaudio
+ dev-libs/boost[threads(+)]
+ dev-libs/glib
+ dev-libs/libxml2
+ gnome-base/librsvg
+ media-gfx/imagemagick
+ virtual/jpeg
+ media-libs/libpng:0
+ media-libs/libsdl2[joystick,video]
+ virtual/ffmpeg
+ virtual/opengl
+ virtual/glu
+ sys-libs/zlib
+ virtual/libintl
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/pango
+ media-libs/glew
+ midi? ( media-libs/portmidi )
+ webcam? ( media-libs/opencv )"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-libav.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-linguas.patch \
+ "${FILESDIR}"/${P}-include.patch
+ sed -i \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ -e '/ Z /s/ Z / ZLIB /' \
+ -e 's/Jpeg/JPEG/' \
+ -e 's/Png/PNG/' \
+ game/CMakeLists.txt || die
+
+ strip-linguas -u lang
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable tools TOOLS)
+ $(cmake-utils_use_enable webcam WEBCAM)
+ $(cmake-utils_use_enable midi MIDI)
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE
+ -DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use songs ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}/songs"
+ fi
+ dodoc docs/{Authors,instruments}.txt
+ newicon -s scalable data/themes/default/icon.svg ${PN}.svg
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}