summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-03-28 12:14:17 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-03-28 12:14:17 +0000
commitbf7748be8b42602e60941beb9ccd39b7cbea287e (patch)
treee909bf0dc3f2976d1e1bfd9d8683f6bebec7f3af /games-arcade
parentUpdated the autotools patch to fix pkg-config file and fixed header directory... (diff)
downloadgentoo-2-bf7748be8b42602e60941beb9ccd39b7cbea287e.tar.gz
gentoo-2-bf7748be8b42602e60941beb9ccd39b7cbea287e.tar.bz2
gentoo-2-bf7748be8b42602e60941beb9ccd39b7cbea287e.zip
Fix python eclass usage
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/whichwayisup/ChangeLog6
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild4
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild6
3 files changed, 10 insertions, 6 deletions
diff --git a/games-arcade/whichwayisup/ChangeLog b/games-arcade/whichwayisup/ChangeLog
index d0a84f62ec14..66d5f4bda84c 100644
--- a/games-arcade/whichwayisup/ChangeLog
+++ b/games-arcade/whichwayisup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/whichwayisup
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.8 2008/02/29 18:52:02 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.9 2008/03/28 12:14:17 nyhm Exp $
+
+ 28 Mar 2008; Tristan Heaven <nyhm@gentoo.org> whichwayisup-0.7.0.ebuild,
+ whichwayisup-0.7.9.ebuild:
+ Fix python eclass usage
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> whichwayisup-0.7.0.ebuild,
whichwayisup-0.7.9.ebuild:
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild
index 0dc4f4fc0ece..53ff29f5ec9a 100644
--- a/games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild,v 1.8 2008/02/29 18:52:02 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.0.ebuild,v 1.9 2008/03/28 12:14:17 nyhm Exp $
NEED_PYTHON="2.4"
@@ -49,7 +49,7 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "$(games_get_libdir)/${PN}"
+ python_mod_optimize "${ROOT}$(games_get_libdir)/${PN}"
games_pkg_postinst
}
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
index 8b8583af4192..d3ebf5feb240 100644
--- a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.2 2008/02/29 18:52:02 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.3 2008/03/28 12:14:17 nyhm Exp $
NEED_PYTHON="2.4"
@@ -31,7 +31,7 @@ src_unpack() {
sed -i -e "s:data_dir\ =\ .*:data_dir\ =\ \"${GAMES_DATADIR}/${PN}\":" \
lib/data.py || die "Changing data path failed"
rm data/pictures/Thumbs.db
- }
+}
src_install() {
newgamesbin run_game.py ${PN} || die "newgamesbin failed"
@@ -50,7 +50,7 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "$(games_get_libdir)/${PN}"
+ python_mod_optimize "${ROOT}$(games_get_libdir)/${PN}"
games_pkg_postinst
}