summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-05-16 19:21:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-05-16 19:21:26 +0000
commit59ed47bbf563c1d36654a730331b91aeaeba0a4d (patch)
treef1d113e3164e0704cca9c6126600dd71400250ef /games-arcade
parentFix bug #509740 - Enable USE=selinux dependency to sec-policy/selinux-java (diff)
downloadgentoo-2-59ed47bbf563c1d36654a730331b91aeaeba0a4d.tar.gz
gentoo-2-59ed47bbf563c1d36654a730331b91aeaeba0a4d.tar.bz2
gentoo-2-59ed47bbf563c1d36654a730331b91aeaeba0a4d.zip
EAPI=5
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/primateplunge/ChangeLog7
-rw-r--r--games-arcade/primateplunge/files/primateplunge-1.1-AC_SUBST.patch26
-rw-r--r--games-arcade/primateplunge/primateplunge-1.1-r1.ebuild14
3 files changed, 41 insertions, 6 deletions
diff --git a/games-arcade/primateplunge/ChangeLog b/games-arcade/primateplunge/ChangeLog
index fd6ef28c1ee9..97b6324486a0 100644
--- a/games-arcade/primateplunge/ChangeLog
+++ b/games-arcade/primateplunge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/primateplunge
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/primateplunge/ChangeLog,v 1.12 2014/05/15 16:31:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/primateplunge/ChangeLog,v 1.13 2014/05/16 19:21:26 mr_bones_ Exp $
+
+ 16 May 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/primateplunge-1.1-AC_SUBST.patch, primateplunge-1.1-r1.ebuild:
+ EAPI=5
15 May 2014; Ulrich Müller <ulm@gentoo.org> primateplunge-1.1-r1.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
@@ -48,4 +52,3 @@
25 Mar 2006; Stefan Schweizer <genstef@gentoo.org> +metadata.xml,
+primateplunge-1.1.ebuild:
New ebuild by myself
-
diff --git a/games-arcade/primateplunge/files/primateplunge-1.1-AC_SUBST.patch b/games-arcade/primateplunge/files/primateplunge-1.1-AC_SUBST.patch
new file mode 100644
index 000000000000..b5c50dcc701b
--- /dev/null
+++ b/games-arcade/primateplunge/files/primateplunge-1.1-AC_SUBST.patch
@@ -0,0 +1,26 @@
+--- configure.ac.orig
++++ configure.ac
+@@ -7,12 +7,12 @@
+
+ AC_INIT([primateplunge], [1.1], [primateplunge@aelius.com])
+
+-AC_CONFIG_SRCDIR( src/game.c )
++AC_CONFIG_SRCDIR(src/game.c)
+ AC_CANONICAL_SYSTEM
+
+ dnl Version 1.7 of automake is recommended
+-AM_INIT_AUTOMAKE( 1.7 )
+-AM_CONFIG_HEADER( src/config.h )
++AM_INIT_AUTOMAKE(1.7)
++AM_CONFIG_HEADER(src/config.h)
+
+
+
+@@ -29,7 +29,6 @@
+ [ PREFSFILE="~/.primateplunge" ]
+ )
+
+-AC_SUBST( GAMEDATADIR )
+ AC_DEFINE_DIR( GAMEDATADIR, GAMEDATADIR, [Location of game resource files] )
+ AC_DEFINE_UNQUOTED( PREFSFILE, "$PREFSFILE", [Location of preferences file] )
+
diff --git a/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild b/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild
index 626b1c5763b9..fb24c89ca830 100644
--- a/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild
+++ b/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild,v 1.8 2014/05/15 16:31:02 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/primateplunge/primateplunge-1.1-r1.ebuild,v 1.9 2014/05/16 19:21:26 mr_bones_ Exp $
-EAPI=2
-inherit eutils games
+EAPI=5
+inherit autotools eutils games
DESCRIPTION="Help poor Monkey navigate his way down through treacherous areas"
HOMEPAGE="http://www.aelius.com/primateplunge/"
@@ -17,9 +17,15 @@ RESTRICT="mirror bindist" #465850
DEPEND="media-libs/libsdl[sound,video]
media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-AC_SUBST.patch
+ eautoreconf
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
dodoc AUTHORS README TIPS
newicon graphics/idle.bmp ${PN}.bmp
make_desktop_entry ${PN} "Primate Plunge" /usr/share/pixmaps/${PN}.bmp