summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-25 08:04:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-25 08:04:49 +0000
commit512f9c92c1447e45cc80af7e2d38acfbb38926c7 (patch)
treea1c229e55da087c03147efbff168360a7d701fd3 /games-arcade
parentarm KEYWORD (diff)
downloadgentoo-2-512f9c92c1447e45cc80af7e2d38acfbb38926c7.tar.gz
gentoo-2-512f9c92c1447e45cc80af7e2d38acfbb38926c7.tar.bz2
gentoo-2-512f9c92c1447e45cc80af7e2d38acfbb38926c7.zip
IUSE; more deps; fixup makefile; use emake; tidy
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sdlsasteroids/ChangeLog8
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild39
2 files changed, 33 insertions, 14 deletions
diff --git a/games-arcade/sdlsasteroids/ChangeLog b/games-arcade/sdlsasteroids/ChangeLog
index 68be33775c89..ee99c78bc6a0 100644
--- a/games-arcade/sdlsasteroids/ChangeLog
+++ b/games-arcade/sdlsasteroids/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/sdlsasteroids
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.1 2003/09/18 22:33:20 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.2 2004/04/25 08:04:49 mr_bones_ Exp $
+
+ 25 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ sdlsasteroids-3.0.ebuild:
+ IUSE; more deps; fixup makefile; use emake; tidy
*sdlsasteroids-3.0 (18 Sep 2003)
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild
index 21d8c7fd317d..d0ea150ffa7b 100644
--- a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild
@@ -1,37 +1,52 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild,v 1.3 2004/02/20 06:20:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild,v 1.4 2004/04/25 08:04:49 mr_bones_ Exp $
inherit games
DESCRIPTION="Rework of Sasteroids using SDL"
HOMEPAGE="http://sdlsas.sourceforge.net/"
SRC_URI="mirror://sourceforge/sdlsas/sasteroids-${PV}.tar.gz"
-RESTRICT="nomirror"
LICENSE="GPL-2 freedist"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
-DEPEND=">=media-libs/sdl-mixer-1.2.0
+RDEPEND="virtual/glibc
+ virtual/opengl
+ >=media-libs/sdl-mixer-1.2.0
+ media-libs/libsdl
+ media-libs/sdl-image
media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
-S=${WORKDIR}/SDLSasteroids-${PV}
+S="${WORKDIR}/SDLSasteroids-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e '34 d' \
+ -e 's/make /$(MAKE) /' Makefile \
+ || die "sed Makefile failed"
+}
src_compile() {
- make \
- GAMEDIR=${GAMES_DATADIR}/${PN} \
- OPTS="${CFLAGS}" \
- || die
+ emake \
+ GAMEDIR="${GAMES_DATADIR}/${PN}" \
+ OPTS="${CXXFLAGS}" \
+ || die "emake failed"
}
src_install() {
dodir /usr/share/man/man6/
make \
- GAMEDIR=${D}/${GAMES_DATADIR}/${PN} \
- BINDIR=${D}/${GAMES_BINDIR} \
- MANDIR=${D}/usr/share/man/ \
- install || die
+ GAMEDIR="${D}/${GAMES_DATADIR}/${PN}" \
+ BINDIR="${D}/${GAMES_BINDIR}" \
+ MANDIR="${D}/usr/share/man/" \
+ install || die "make install failed"
dodoc ChangeLog README README.xast TODO description
prepgamesdirs
}