summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-12-08 18:29:31 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-12-08 18:29:31 +0000
commit490938c1ea27dd11c5b05cbd1df210b6b3a6323b (patch)
treec8e3f27d66f770c4d51117ebc6d89c902190ab86 /games-arcade
parentx86 stable, bug #478252 (diff)
downloadgentoo-2-490938c1ea27dd11c5b05cbd1df210b6b3a6323b.tar.gz
gentoo-2-490938c1ea27dd11c5b05cbd1df210b6b3a6323b.tar.bz2
gentoo-2-490938c1ea27dd11c5b05cbd1df210b6b3a6323b.zip
Version bump, as requested by "Lumbrius" in bug #492360. Patches rediffed.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opentyrian/ChangeLog11
-rw-r--r--games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff15
-rw-r--r--games-arcade/opentyrian/files/2.1.20130907-datapath.diff26
-rw-r--r--games-arcade/opentyrian/opentyrian-2.1.20130907.ebuild46
4 files changed, 96 insertions, 2 deletions
diff --git a/games-arcade/opentyrian/ChangeLog b/games-arcade/opentyrian/ChangeLog
index dbe87bcae29c..24c99a13d6ee 100644
--- a/games-arcade/opentyrian/ChangeLog
+++ b/games-arcade/opentyrian/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/opentyrian
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.10 2011/06/07 13:45:40 chainsaw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.11 2013/12/08 18:29:31 chainsaw Exp $
+
+*opentyrian-2.1.20130907 (08 Dec 2013)
+
+ 08 Dec 2013; Tony Vroon <chainsaw@gentoo.org>
+ +opentyrian-2.1.20130907.ebuild, +files/2.1.20130907-cflag-idiocy.diff,
+ +files/2.1.20130907-datapath.diff:
+ Version bump, as requested by "Lumbrius" in bug #492360. Patches rediffed.
*opentyrian-20110517-r1 (07 Jun 2011)
diff --git a/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff b/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff
new file mode 100644
index 000000000000..39ccf1c79f66
--- /dev/null
+++ b/games-arcade/opentyrian/files/2.1.20130907-cflag-idiocy.diff
@@ -0,0 +1,15 @@
+diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
+--- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:38:06.982842189 +0000
++++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:38:26.843842798 +0000
+@@ -21,11 +21,6 @@
+
+ # FLAGS ####################################################
+
+-ifneq ($(MAKECMDGOALS), release)
+- EXTRA_CFLAGS += -g3 -O0 -Werror
+-else
+- EXTRA_CFLAGS += -g0 -O2 -DNDEBUG
+-endif
+ EXTRA_CFLAGS += -MMD -pedantic -Wall -Wextra -Wno-missing-field-initializers
+ ifeq ($(WITH_NETWORK), true)
+ EXTRA_CFLAGS += -DWITH_NETWORK
diff --git a/games-arcade/opentyrian/files/2.1.20130907-datapath.diff b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
new file mode 100644
index 000000000000..5b0143ed9a50
--- /dev/null
+++ b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
+--- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:40:23.470846371 +0000
++++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:40:49.355847165 +0000
+@@ -49,6 +49,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+diff -uNr opentyrian-2.1.20130907.ORIG/src/file.c opentyrian-2.1.20130907/src/file.c
+--- opentyrian-2.1.20130907.ORIG/src/file.c 2013-12-08 17:40:23.468846371 +0000
++++ opentyrian-2.1.20130907/src/file.c 2013-12-08 17:40:49.355847165 +0000
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;
diff --git a/games-arcade/opentyrian/opentyrian-2.1.20130907.ebuild b/games-arcade/opentyrian/opentyrian-2.1.20130907.ebuild
new file mode 100644
index 000000000000..bc788f3d87ac
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-2.1.20130907.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/opentyrian-2.1.20130907.ebuild,v 1.1 2013/12/08 18:29:31 chainsaw Exp $
+
+inherit base games
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="http://code.google.com/p/opentyrian/"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ http://www.camanis.net/${PN}/releases/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+# Yes, mercurial is needed to set the build version stamp.
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-vcs/mercurial"
+PATCHES=(
+ "${FILESDIR}/${PV}-datapath.diff"
+ "${FILESDIR}/${PV}-cflag-idiocy.diff"
+)
+
+src_compile() {
+ emake DATA_PATH="${GAMES_DATADIR}/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ dogamesbin opentyrian || die "Failed to install game binary"
+ dosym "${GAMES_BINDIR}/opentyrian" "${GAMES_BINDIR}/tyrian" || die "Failed to symlink"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu linux/opentyrian.desktop || die "Failed to install desktop file"
+ for i in linux/icons/*.png ; do
+ local size=`echo ${i} | sed -e 's:.*-\([0-9]\+\).png:\1:'`
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins ${i} opentyrian.png || die "Failed to install program icon"
+ done
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ doins * || die "Failed to install game data"
+ prepgamesdirs
+}