summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-06-02 01:27:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-06-02 01:27:11 +0000
commit0b3b63377d5617006947e25a29517aa73669c569 (patch)
tree9cefcea53fcf5c002f5535112ebaa93f19912c97 /games-arcade/xbubble
parentadd slot dep for repoman (diff)
downloadgentoo-2-0b3b63377d5617006947e25a29517aa73669c569.tar.gz
gentoo-2-0b3b63377d5617006947e25a29517aa73669c569.tar.bz2
gentoo-2-0b3b63377d5617006947e25a29517aa73669c569.zip
add slot dep for repoman
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/xbubble')
-rw-r--r--games-arcade/xbubble/ChangeLog6
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8.ebuild12
2 files changed, 9 insertions, 9 deletions
diff --git a/games-arcade/xbubble/ChangeLog b/games-arcade/xbubble/ChangeLog
index 7efc9f325ca4..ca7abbcf2ec3 100644
--- a/games-arcade/xbubble/ChangeLog
+++ b/games-arcade/xbubble/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/xbubble
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/ChangeLog,v 1.15 2015/01/05 20:28:56 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/ChangeLog,v 1.16 2015/06/02 01:27:11 mr_bones_ Exp $
+
+ 02 Jun 2015; Michael Sterrett <mr_bones_@gentoo.org> xbubble-0.5.8.ebuild:
+ add slot dep for repoman
05 Jan 2015; Tupone Alfredo <tupone@gentoo.org> xbubble-0.5.8.ebuild:
EAPI 5
@@ -54,4 +57,3 @@
10 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+xbubble-0.5.8.ebuild:
initial commit - ebuild based on the one provided by Alex Linke via bug #63566
-
diff --git a/games-arcade/xbubble/xbubble-0.5.8.ebuild b/games-arcade/xbubble/xbubble-0.5.8.ebuild
index 0cca413eee61..6c6bb6a6b18e 100644
--- a/games-arcade/xbubble/xbubble-0.5.8.ebuild
+++ b/games-arcade/xbubble/xbubble-0.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.17 2015/01/05 20:28:56 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.18 2015/06/02 01:27:11 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -16,7 +16,7 @@ IUSE="nls"
RDEPEND="x11-libs/libX11
x11-libs/libXt
- media-libs/libpng
+ media-libs/libpng:0
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -30,16 +30,14 @@ src_prepare() {
"${FILESDIR}"/${P}-png15.patch
sed -i \
-e '/^AM_CFLAGS/d' \
- src/Makefile.in || die "sed cflags"
+ src/Makefile.in || die
sed -i \
-e '/^localedir/s:=.*:=/usr/share/locale:' \
- configure po/Makefile.in.in || die "sed locale"
+ configure po/Makefile.in.in || die
}
src_configure() {
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable nls)
+ egamesconf $(use_enable nls)
}
src_install() {