summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-05 22:52:44 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-05 22:52:44 +0000
commitcd43a53177a76e00c33f65838d2d23dc76fa1273 (patch)
tree0015ebbf6ffc627aed2d28ca2d7de7390bfdb28b /games-arcade/xbill
parentStable on amd64 wrt bug #201249 (diff)
downloadgentoo-2-cd43a53177a76e00c33f65838d2d23dc76fa1273.tar.gz
gentoo-2-cd43a53177a76e00c33f65838d2d23dc76fa1273.tar.bz2
gentoo-2-cd43a53177a76e00c33f65838d2d23dc76fa1273.zip
Patched to use gtk-2. Bug #201214
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-arcade/xbill')
-rw-r--r--games-arcade/xbill/ChangeLog8
-rw-r--r--games-arcade/xbill/files/digest-xbill-2.1-r23
-rw-r--r--games-arcade/xbill/files/xbill-2.1-gtk2.patch18
-rw-r--r--games-arcade/xbill/xbill-2.1-r2.ebuild41
4 files changed, 69 insertions, 1 deletions
diff --git a/games-arcade/xbill/ChangeLog b/games-arcade/xbill/ChangeLog
index 05ebdfe8ca0c..2dae3a04fc8a 100644
--- a/games-arcade/xbill/ChangeLog
+++ b/games-arcade/xbill/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/xbill
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbill/ChangeLog,v 1.13 2007/08/07 23:45:32 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbill/ChangeLog,v 1.14 2007/12/05 22:52:43 tupone Exp $
+
+*xbill-2.1-r2 (05 Dec 2007)
+
+ 05 Dec 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/xbill-2.1-gtk2.patch, +xbill-2.1-r2.ebuild:
+ Patched to use gtk-2. Bug #201214 by yury fedorchenko
07 Aug 2007; Tristan Heaven <nyhm@gentoo.org> xbill-2.1-r1.ebuild:
Add gtk USE flag, bug #186807 by Pacho Ramos
diff --git a/games-arcade/xbill/files/digest-xbill-2.1-r2 b/games-arcade/xbill/files/digest-xbill-2.1-r2
new file mode 100644
index 000000000000..4b819313ddc6
--- /dev/null
+++ b/games-arcade/xbill/files/digest-xbill-2.1-r2
@@ -0,0 +1,3 @@
+MD5 585e4866b15255a24203db9959407b2f xbill-2.1.tar.gz 77610
+RMD160 1d8a680f45775e7c840b4fe12cd21a439d41b2dc xbill-2.1.tar.gz 77610
+SHA256 0efdfff1ce2df70b7a15601cb488cd7b2eb918d21d78e877bd773f112945608d xbill-2.1.tar.gz 77610
diff --git a/games-arcade/xbill/files/xbill-2.1-gtk2.patch b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
new file mode 100644
index 000000000000..70817b09c7ab
--- /dev/null
+++ b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
@@ -0,0 +1,18 @@
+--- configure.in.old 2007-12-05 22:37:57.000000000 +0100
++++ configure.in 2007-12-05 22:54:57.000000000 +0100
+@@ -88,12 +88,11 @@
+ [ --enable-gtk build with the GTK widget set])
+
+ if test "$enable_gtk" != "no"; then
+- AC_CHECK_PROG(GTKCONFIG, gtk-config, yes, no)
++ PKG_CHECK_MODULES(GTK, gtk+-2.0)
+
+- if test "X$GTKCONFIG" = X"yes"; then
++ if test $pkg_failed = no; then
+ AC_DEFINE(USE_GTK)
+- GTK_CFLAGS="`gtk-config --cflags`"
+- WIDGET_LIBS="$WIDGET_LIBS `gtk-config --libs`"
++ WIDGET_LIBS="$WIDGET_LIBS $GTK_LIBS"
+ WIDGET_OBJS="$WIDGET_OBJS gtk.o"
+ fi
+ fi
diff --git a/games-arcade/xbill/xbill-2.1-r2.ebuild b/games-arcade/xbill/xbill-2.1-r2.ebuild
new file mode 100644
index 000000000000..39ea681e6d4b
--- /dev/null
+++ b/games-arcade/xbill/xbill-2.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbill/xbill-2.1-r2.ebuild,v 1.1 2007/12/05 22:52:43 tupone Exp $
+
+inherit eutils autotools games
+
+DESCRIPTION="A game about an evil hacker called Bill!"
+HOMEPAGE="http://www.xbill.org/"
+SRC_URI="http://www.xbill.org/download/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+DEPEND="gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( x11-libs/libXaw )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk2.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --disable-motif \
+ $(use_enable gtk) \
+ $(use_enable !gtk athena) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon pixmaps/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} XBill ${PN}.xpm
+ dodoc ChangeLog README
+ prepgamesdirs
+}