summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-03-30 05:38:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-03-30 05:38:14 +0000
commitf50687e7d779cb5eeb08e05e94b898858fcb1123 (patch)
treeecf66315fab1c35637f17c1acc036713b7dfd047 /games-arcade/vor
parentbup (diff)
downloadgentoo-2-f50687e7d779cb5eeb08e05e94b898858fcb1123.tar.gz
gentoo-2-f50687e7d779cb5eeb08e05e94b898858fcb1123.tar.bz2
gentoo-2-f50687e7d779cb5eeb08e05e94b898858fcb1123.zip
add underlink patch from Ted Tanberry via bug #505794
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/vor')
-rw-r--r--games-arcade/vor/ChangeLog8
-rw-r--r--games-arcade/vor/files/vor-0.5.5-underlink.patch26
-rw-r--r--games-arcade/vor/vor-0.5.5.ebuild27
3 files changed, 55 insertions, 6 deletions
diff --git a/games-arcade/vor/ChangeLog b/games-arcade/vor/ChangeLog
index 20ff9972593e..bd3d911df126 100644
--- a/games-arcade/vor/ChangeLog
+++ b/games-arcade/vor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/vor
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/vor/ChangeLog,v 1.12 2013/02/18 20:17:57 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/vor/ChangeLog,v 1.13 2014/03/30 05:38:14 mr_bones_ Exp $
+
+ 30 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vor-0.5.5-underlink.patch, vor-0.5.5.ebuild:
+ add underlink patch from Ted Tanberry via bug #505794
18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> vor-0.5.5.ebuild:
Stable for ppc, wrt bug #458050
diff --git a/games-arcade/vor/files/vor-0.5.5-underlink.patch b/games-arcade/vor/files/vor-0.5.5-underlink.patch
new file mode 100644
index 000000000000..0645c5695733
--- /dev/null
+++ b/games-arcade/vor/files/vor-0.5.5-underlink.patch
@@ -0,0 +1,26 @@
+--- Makefile.in
++++ Makefile.in
+@@ -43,7 +43,7 @@
+ SDL_CFLAGS := @SDL_CFLAGS@
+ SDL_LIBS := @SDL_LIBS@
+
+-ldflags := $(SDL_LIBS) -lSDL_image -lSDL_mixer $(LDFLAGS)
++ldflags := $(LIBS) $(SDL_LIBS) $(LDFLAGS)
+ cflags := -I. $(SDL_CFLAGS) $(paths) $(CFLAGS)
+
+ my_objects := args.@OBJEXT@ dust.@OBJEXT@ file.@OBJEXT@ mt.@OBJEXT@ rocks.@OBJEXT@ score.@OBJEXT@ sprite.@OBJEXT@ sound.@OBJEXT@ autopilot.@OBJEXT@
+
+--- configure.ac
++++ configure.ac
+@@ -12,6 +12,11 @@
+ AC_PROG_MAKE_SET
+
+ # Checks for libraries.
++dnl Check for libm for sqrt()
++AC_SEARCH_LIBS([sqrt], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrt() function])
++])
++
+ AC_CHECK_LIB([SDL_image], [IMG_LoadPNG_RW])
+ AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio])
+
diff --git a/games-arcade/vor/vor-0.5.5.ebuild b/games-arcade/vor/vor-0.5.5.ebuild
index dc5b4c846edd..23ee5747374a 100644
--- a/games-arcade/vor/vor-0.5.5.ebuild
+++ b/games-arcade/vor/vor-0.5.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/vor/vor-0.5.5.ebuild,v 1.4 2013/02/18 20:17:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/vor/vor-0.5.5.ebuild,v 1.5 2014/03/30 05:38:14 mr_bones_ Exp $
EAPI=5
-inherit eutils games
+inherit autotools eutils gnome2-utils games
DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
HOMEPAGE="http://jasonwoof.org/vor"
@@ -19,10 +19,29 @@ DEPEND="media-libs/libsdl[audio,video]
media-libs/sdl-mixer[mod]"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-underlink.patch"
+ eautoreconf
+}
+
src_install() {
dodir "${GAMES_BINDIR}"
DOCS="README* todo" default
- newicon data/icon.png ${PN}.png
+ newicon -s 48 data/icon.png ${PN}.png
make_desktop_entry ${PN} VoR
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}