summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-15 23:19:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-15 23:19:11 +0000
commitcc1899245f19035ac016a3e250eddfb014754cad (patch)
treee4041e37b7df18066c82ae93eed5135a83934278 /games-arcade/spacerider
parentrm python2_6; add slot deps (diff)
downloadgentoo-2-cc1899245f19035ac016a3e250eddfb014754cad.tar.gz
gentoo-2-cc1899245f19035ac016a3e250eddfb014754cad.tar.bz2
gentoo-2-cc1899245f19035ac016a3e250eddfb014754cad.zip
use deps for libsdl
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/spacerider')
-rw-r--r--games-arcade/spacerider/ChangeLog6
-rw-r--r--games-arcade/spacerider/spacerider-0.13.ebuild10
2 files changed, 9 insertions, 7 deletions
diff --git a/games-arcade/spacerider/ChangeLog b/games-arcade/spacerider/ChangeLog
index 4ab303226008..335a373a2d1d 100644
--- a/games-arcade/spacerider/ChangeLog
+++ b/games-arcade/spacerider/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/spacerider
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.8 2015/01/05 18:50:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.9 2015/02/15 23:19:11 mr_bones_ Exp $
+
+ 15 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> spacerider-0.13.ebuild:
+ use deps for libsdl
05 Jan 2015; Tupone Alfredo <tupone@gentoo.org> spacerider-0.13.ebuild:
EAPI 5
@@ -32,4 +35,3 @@
+files/spacerider-0.13-gentoo.patch, +metadata.xml,
+spacerider-0.13.ebuild:
New ebuild. Bug #110104 by Fernando V.
-
diff --git a/games-arcade/spacerider/spacerider-0.13.ebuild b/games-arcade/spacerider/spacerider-0.13.ebuild
index 29bcd1a4617c..0a5363e9e134 100644
--- a/games-arcade/spacerider/spacerider-0.13.ebuild
+++ b/games-arcade/spacerider/spacerider-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.10 2015/01/05 18:50:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.11 2015/02/15 23:19:11 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -14,12 +14,13 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND="media-libs/sdl-gfx
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-gfx
media-libs/sdl-mixer
media-libs/sdl-image[jpeg]
media-libs/sdl-net
media-libs/sdl-ttf"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch \
@@ -27,8 +28,7 @@ src_prepare() {
"${FILESDIR}"/${P}-ovflfix.patch
sed -i \
-e "s:/usr/share/games/spacerider:${GAMES_DATADIR}/${PN}:" \
- globals.cpp \
- || die "sed failed"
+ globals.cpp || die
}
src_install() {