summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-18 22:33:20 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-18 22:33:20 +0000
commit5d1793097bd660d746c280bc44e7436098fb68e6 (patch)
tree151ba44de4e343b45e63a25f6ed694e3d2ca575d /games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild
parentio is supposed to be oi (diff)
downloadgentoo-2-5d1793097bd660d746c280bc44e7436098fb68e6.tar.gz
gentoo-2-5d1793097bd660d746c280bc44e7436098fb68e6.tar.bz2
gentoo-2-5d1793097bd660d746c280bc44e7436098fb68e6.zip
version bump and name change #29084
Diffstat (limited to 'games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild')
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild
new file mode 100644
index 000000000000..699b9d2a32b7
--- /dev/null
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.ebuild,v 1.1 2003/09/18 22:33:20 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Rework of Sasteroids using SDL"
+HOMEPAGE="http://sdlsas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdlsas/sasteroids-${PV}.tar.gz"
+
+LICENSE="GPL-2 freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=media-libs/sdl-mixer-1.2.0
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/SDLSasteroids-${PV}
+
+src_compile() {
+ make \
+ GAMEDIR=${GAMES_DATADIR}/${PN} \
+ OPTS="${CFLAGS}" \
+ || die
+}
+
+src_install() {
+ dodir /usr/share/man/man6/
+ make \
+ GAMEDIR=${D}/${GAMES_DATADIR}/${PN} \
+ BINDIR=${D}/${GAMES_BINDIR} \
+ MANDIR=${D}/usr/share/man/ \
+ install || die
+ dodoc ChangeLog README README.xast TODO description
+ prepgamesdirs
+}