summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-23 15:13:52 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-23 15:13:52 +0000
commitfe13493003ac00919e45e0000c264cf3c207fa99 (patch)
treeb47edf04bebabb748d1d5d009dc41b7fd94cf5b9 /games-arcade/koules
parentremove unused licenses (diff)
downloadgentoo-2-fe13493003ac00919e45e0000c264cf3c207fa99.tar.gz
gentoo-2-fe13493003ac00919e45e0000c264cf3c207fa99.tar.bz2
gentoo-2-fe13493003ac00919e45e0000c264cf3c207fa99.zip
Respect LDFLAGS. Bug #337863
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade/koules')
-rw-r--r--games-arcade/koules/ChangeLog5
-rw-r--r--games-arcade/koules/koules-1.4-r2.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/games-arcade/koules/ChangeLog b/games-arcade/koules/ChangeLog
index dc14a3afe670..3d505c17bc54 100644
--- a/games-arcade/koules/ChangeLog
+++ b/games-arcade/koules/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/koules
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/ChangeLog,v 1.17 2010/05/11 10:06:15 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/ChangeLog,v 1.18 2010/09/23 15:13:52 tupone Exp $
+
+ 23 Sep 2010; Tupone Alfredo <tupone@gentoo.org> koules-1.4-r2.ebuild:
+ Respect LDFLAGS. Bug #337863 by flameeyes@gentoo.org
11 May 2010; Tupone Alfredo <tupone@gentoo.org> koules-1.4-r2.ebuild:
Fix parallel make. Bug #316845 by flameeyes@gentoo.org
diff --git a/games-arcade/koules/koules-1.4-r2.ebuild b/games-arcade/koules/koules-1.4-r2.ebuild
index c0cf7efd53c0..02fa0366012f 100644
--- a/games-arcade/koules/koules-1.4-r2.ebuild
+++ b/games-arcade/koules/koules-1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/koules-1.4-r2.ebuild,v 1.7 2010/05/11 10:06:15 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/koules-1.4-r2.ebuild,v 1.8 2010/09/23 15:13:52 tupone Exp $
EAPI=2
inherit eutils games
@@ -85,12 +85,12 @@ src_configure() {
src_compile() {
mkdir bins
if ! use svga ; then
- emake || die "emake X failed"
- emake all1 || die "emake X failed"
+ emake EXTRA_LDOPTIONS="${LDFLAGS}" || die "emake X failed"
+ emake EXTRA_LDOPTIONS="${LDFLAGS}" all1 || die "emake X failed"
mv xkoules bins/
fi
if use svga ; then
- emake -f Makefile.svgalib || die "emake svga failed"
+ emake -f Makefile.svgalib LFLAGS="${LDFLAGS}" || die "emake svga failed"
mv koules.svga bins/
fi
}