summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-03 19:38:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-03 19:38:09 +0000
commitd93c611311c47b7057a6dff6df65966cd9321235 (patch)
tree2820dac01c86c20419acf7ff2e52d1059a5194c1 /games-arcade/conveysdl
parentEAPI 5 (diff)
downloadgentoo-2-d93c611311c47b7057a6dff6df65966cd9321235.tar.gz
gentoo-2-d93c611311c47b7057a6dff6df65966cd9321235.tar.bz2
gentoo-2-d93c611311c47b7057a6dff6df65966cd9321235.zip
EAPI 5
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-arcade/conveysdl')
-rw-r--r--games-arcade/conveysdl/ChangeLog7
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3.ebuild14
2 files changed, 12 insertions, 9 deletions
diff --git a/games-arcade/conveysdl/ChangeLog b/games-arcade/conveysdl/ChangeLog
index ad2a872a488a..6410f7e66532 100644
--- a/games-arcade/conveysdl/ChangeLog
+++ b/games-arcade/conveysdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/conveysdl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.9 2010/08/14 05:50:18 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.10 2015/01/03 19:38:09 tupone Exp $
+
+ 03 Jan 2015; Tupone Alfredo <tupone@gentoo.org> conveysdl-1.3.ebuild:
+ EAPI 5
14 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> conveysdl-1.3.ebuild,
+files/conveysdl-1.3-arrays.patch, +files/conveysdl-1.3-speed.patch:
diff --git a/games-arcade/conveysdl/conveysdl-1.3.ebuild b/games-arcade/conveysdl/conveysdl-1.3.ebuild
index ee9e6917dd9a..bade047e87f9 100644
--- a/games-arcade/conveysdl/conveysdl-1.3.ebuild
+++ b/games-arcade/conveysdl/conveysdl-1.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.7 2010/08/14 05:50:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.8 2015/01/03 19:38:09 tupone Exp $
-EAPI=2
+EAPI=5
inherit eutils toolchain-funcs games
DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
@@ -16,6 +16,7 @@ IUSE=""
DEPEND="media-libs/libsdl
media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
S=${WORKDIR}
@@ -42,14 +43,13 @@ src_compile() {
CFLAGS="${CFLAGS} $(sdl-config --cflags) \
-DDATA_PREFIX=\\\"${GAMES_DATADIR}/${PN}/\\\" \
-DENABLE_SOUND" \
- LDLIBS="-lSDL_mixer $(sdl-config --libs)" \
- || die "emake failed"
+ LDLIBS="-lSDL_mixer $(sdl-config --libs)"
}
src_install() {
- newgamesbin main ${PN} || die "newgamesbin failed"
+ newgamesbin main ${PN}
insinto "${GAMES_DATADIR}"/${PN}
- doins -r gfx sounds levels || die "doins failed"
+ doins -r gfx sounds levels
newicon gfx/jblob.bmp ${PN}.bmp
make_desktop_entry ${PN} Convey /usr/share/pixmaps/${PN}.bmp
dodoc readme