summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-18 19:58:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-18 19:58:12 +0000
commitb15cc95817fd5a5eee664277286b5e9a9168a2ea (patch)
treee3718869634f1958d80d5dd46b3ca227150aa215 /games-arcade/cervi
parentamd64/x86 stable, bug #248038 (diff)
downloadgentoo-2-b15cc95817fd5a5eee664277286b5e9a9168a2ea.tar.gz
gentoo-2-b15cc95817fd5a5eee664277286b5e9a9168a2ea.tar.bz2
gentoo-2-b15cc95817fd5a5eee664277286b5e9a9168a2ea.zip
Fix gcc-4.3 build. Bug #251119
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 i686)
Diffstat (limited to 'games-arcade/cervi')
-rw-r--r--games-arcade/cervi/ChangeLog8
-rw-r--r--games-arcade/cervi/cervi-0.0.3.ebuild7
-rw-r--r--games-arcade/cervi/files/cervi-0.0.3-gcc43.patch10
3 files changed, 20 insertions, 5 deletions
diff --git a/games-arcade/cervi/ChangeLog b/games-arcade/cervi/ChangeLog
index 29cadd30115a..4d135a65d755 100644
--- a/games-arcade/cervi/ChangeLog
+++ b/games-arcade/cervi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/cervi
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cervi/ChangeLog,v 1.5 2006/10/09 16:23:11 nyhm Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cervi/ChangeLog,v 1.6 2009/01/18 19:58:12 tupone Exp $
+
+ 18 Jan 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/cervi-0.0.3-gcc43.patch, cervi-0.0.3.ebuild:
+ Fix gcc-4.3 build. Bug #251119 by flameeyes@gentoo.org
09 Oct 2006; Tristan Heaven <nyhm@gentoo.org> cervi-0.0.3.ebuild:
Add gtk+-1 to DEPEND
diff --git a/games-arcade/cervi/cervi-0.0.3.ebuild b/games-arcade/cervi/cervi-0.0.3.ebuild
index 67d3fb96e40a..3156342748cd 100644
--- a/games-arcade/cervi/cervi-0.0.3.ebuild
+++ b/games-arcade/cervi/cervi-0.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cervi/cervi-0.0.3.ebuild,v 1.7 2006/10/09 16:23:11 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cervi/cervi-0.0.3.ebuild,v 1.8 2009/01/18 19:58:12 tupone Exp $
-inherit toolchain-funcs games
+inherit eutils toolchain-funcs games
DESCRIPTION="A multiplayer game where players drive a worm and try not to collide with anything"
SRC_URI="http://tomi.nomi.cz/download/${P}.tar.bz2"
@@ -22,6 +22,7 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "/^CFLAGS/ s:-Wall:${CFLAGS}:" \
-e "/^CXXFLAGS/ s:-Wall:${CXXFLAGS}:" Makefile \
diff --git a/games-arcade/cervi/files/cervi-0.0.3-gcc43.patch b/games-arcade/cervi/files/cervi-0.0.3-gcc43.patch
new file mode 100644
index 000000000000..a02b20e2ae9a
--- /dev/null
+++ b/games-arcade/cervi/files/cervi-0.0.3-gcc43.patch
@@ -0,0 +1,10 @@
+--- game.cc.old 2009-01-18 20:27:15.000000000 +0100
++++ game.cc 2009-01-18 20:27:52.000000000 +0100
+@@ -10,6 +10,7 @@
+
+ #include <iostream>
+ #include <cmath>
++#include <cstdlib>
+ #include <gdk/gdkkeysyms.h>
+ #include "game.h"
+ #include "music.h"